Page 1 of 1

[solved] rp 0 sudo apt-get upgrade results in an error

Posted: Tue Jan 16, 2018 7:19 am
by fjr

Code: Select all

$ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Reading package lists... Done                      
pi@raspberrypi:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  python3-scrollphathd
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
Need to get 0 B/18.0 kB of archives.
After this operation, 14.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 125940 files and directories currently installed.)
Preparing to unpack .../python3-scrollphathd_1.1.0_all.deb ...
Unpacking python3-scrollphathd (1.1.0) over (1.0.1) ...
dpkg: error processing archive /var/cache/apt/archives/python3-scrollphathd_1.1.0_all.deb (--unpack):
 trying to overwrite '/usr/bin/scrollphathd_api', which is also in package python-scrollphathd 1.1.0
Errors were encountered while processing:
 /var/cache/apt/archives/python3-scrollphathd_1.1.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
$
Maybe there was a power supply break during update, upgrade. How do I get the rp 0 upgraded?
Thank you.

Re: rp 0 sudo apt-get upgrade results in an error

Posted: Tue Jan 16, 2018 8:09 am
by rpdom
Seek and ye shall find... it is a problem that others have encountered. Try the fix mentioned here viewtopic.php?f=28&t=202523

Re: rp 0 sudo apt-get upgrade results in an error

Posted: Fri Jan 19, 2018 6:15 pm
by fjr
Now I updated and upgraded.
No displayed error messages. Thank you.