lerner
Posts: 510
Joined: Sun Mar 29, 2015 12:12 am

Firefox won't install - here or mozilla?

Sun Oct 22, 2017 2:11 am

Folks,

After a long time rebuilding a couple of machines I have the problem of Firefox not wanting to install.

Following this:
sudo apt-get purge firefox
echo 'deb http://q4os.org/qextrepo q4os-rpi-firefox-cn main' | sudo tee /etc/apt/sources.list.d/qextrepo.list
wget -nv -O- http://q4os.org/qextrepo/q4a-q4os.gpg.pub | sudo apt-key add -
sudo apt-get update
sudo apt-get install firefox
It has worked many times on many machines I have bulid.

I get this.

Code: Select all

sudo apt install firefox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 firefox : Depends: libhunspell-1.3-0 (>= 1.3.3) but it is not installable
E: Unable to correct problems, you have held broken packages.
So is it Mozilla's "problem" of a Ras Pi "problem"?

Friendly question.
;)

asandford
Posts: 1998
Joined: Mon Dec 31, 2012 12:54 pm
Location: Waterlooville

Re: Firefox won't install - here or mozilla?

Sun Oct 22, 2017 3:34 am

No, it's your problem.

You uninstalled the pi version and are installing a version built for a different OS.

lerner
Posts: 510
Joined: Sun Mar 29, 2015 12:12 am

Re: Firefox won't install - here or mozilla?

Sun Oct 22, 2017 7:16 am

Gee, you got out on the wrong side of the bed today.

Ok.

I installed it on a different VERSION of the O/S.

Which to me is different to: a different O/S.

Note: VERSION.

Anyway, lesson remembered.

k-pi
Posts: 930
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Firefox won't install - here or mozilla?

Sun Oct 22, 2017 11:40 am

The following packages have unmet dependencies:
firefox : Depends: libhunspell-1.3-0 (>= 1.3.3) but it is not installable
E: Unable to correct problems, you have held broken packages.
Either the package is unavailable/not built yet, or you have it pinned.

asandford
Posts: 1998
Joined: Mon Dec 31, 2012 12:54 pm
Location: Waterlooville

Re: Firefox won't install - here or mozilla?

Mon Oct 23, 2017 12:11 am

lerner wrote:
Sun Oct 22, 2017 7:16 am
Gee, you got out on the wrong side of the bed today.

Ok.

I installed it on a different VERSION of the O/S.

Which to me is different to: a different O/S.

Note: VERSION.

Anyway, lesson remembered.
If you don't understand that "different VERSION of the O/S" are actually different, then there's no hope. The word you want is Distributions, and the supported one is not the one you're asking about.

Note: Distribution

Good luck with your problem, I'm out.

Return to “Beginners”