DPaul
Posts: 39
Joined: Fri Oct 13, 2017 7:39 am

Azerty prob [solved]

Thu Oct 19, 2017 7:52 am

Hi,

Booted up pi3 for the first time, it works !
Except....
In the preference menu, keyb/mouse, i changed the keyb to Azerty.
Doing the test with "raspberry" it indeed puts the a in the right place (not "rqspberry")

I wanted to test changing user (via Log out), and since i only have one user (default pi),
i log back in with the password "raspberry". Only it has not remembered the Azerty keyboard,
so i have to accomodate for querty keys.

Once logged in, i checked the keyb/mouse settings immediately, but those were still happily on azerty.

Why the login probs?
(If it's a known prob, sorry, but the forum search does not seem to work at the moment "very busy")

thx,
Paul
Last edited by DPaul on Sun Oct 29, 2017 6:41 am, edited 1 time in total.

User avatar
DougieLawson
Posts: 30171
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Azerty prob

Thu Oct 19, 2017 9:53 am

How have you set your AZERTY keyboard?

sudo dpkg-reconfigure keyboard-reconfiguration
or
sudo nano /etc/default/keyboard
change

Code: Select all

XKBLAYOUT="gb"
to

Code: Select all

XKBLAYOUT="fr"
Have you rebooted after changing the layout?
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

DPaul
Posts: 39
Joined: Fri Oct 13, 2017 7:39 am

Re: Azerty prob

Thu Oct 19, 2017 10:01 am

OK, i just changed it via the menu / preferences.
Said nothing about rebooting.

I'll see what happens next time i power up.
Will let you know.

thx,
Paul

DPaul
Posts: 39
Joined: Fri Oct 13, 2017 7:39 am

Re: Azerty prob

Fri Oct 20, 2017 9:23 am

No succes yet !

Started again, finding my preferences intact, as i set them, Azerty keyboard.
In command mode, i was able to enter the long command to create a new user "sudo useradd -m -G ...etc etc "
clearly with a azerty character layout.
I even logout-rebooted.

All is well EXCEPT when i change accounts, and i want to go to "Pi, pw = raspberry", it keeps on typing "rqspberry".
That is the moment when the azerty keyboard setting is not respected.

Not that it is a big issue, but every account and password that i create may have the prob if i don't watch out. (if i don't find a solution.)

thx,
Paul

B.Goode
Posts: 4623
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Azerty prob

Thu Oct 26, 2017 3:49 pm

The Raspberry Pi Foundation documentation about configuration of Raspbian suggests using the raspi-config utility. I don't think that in any of your posts you have mentioned doing that?

https://www.raspberrypi.org/documentati ... isation.md

DPaul
Posts: 39
Joined: Fri Oct 13, 2017 7:39 am

Re: Azerty prob

Sat Oct 28, 2017 6:22 am

Raspi-config utility ?
No idea what that is, but i will find out and let you know. :-)

Paul

DPaul
Posts: 39
Joined: Fri Oct 13, 2017 7:39 am

Re: Azerty prob [solved]

Sat Oct 28, 2017 7:38 am

Hi,

Thanks B.Goode, very simple solution, took me a couple of seconds to put it right.
Passwords are in azerty now.

Paul

Return to “Beginners”

Who is online

Users browsing this forum: ajmas, mfa298, samarkh and 67 guests