lerner
Posts: 548
Joined: Sun Mar 29, 2015 12:12 am

Problems compiling code. QT stufff

Mon Oct 16, 2017 9:25 pm

I am trying to be brief as possible but not so brief, no help will be possible.

Back in about April this year I downloaded QT5 for the RPI.
At that time I was running Jessie.

It downloaded and I compiled it.
Then, with it compiled, I then compiled some source and the program worked/was compiled.

Alas other things were a problem and I still couldn't use the program.

In the mean time I upgraded to strech - AFAIK anyway.

The program was re-released and the new code was there to download.
I downloaded it and went through the steps. But it wouldn't work.

This is what happens:
qmake ../Moolticute.pro
qmake: could not exec '/usr/lib/arm-linux-gnueabihf/qt4/bin/qmake': No such file or directory

That had me stumped until I realised that it was pointing to QT4 and not QT5!

So I don't get/understand how/when QT4 got on the system and that if I installed QT5 back in April how did QT4 get into the equation?
Yes, maybe it was there all the time, and I needed QT5, but still..... Why did it work then and not now?

Maybe the update from Jessie to Strech?

So how do I set the system to understand it has QT5?

Thanks in advance.

piras77
Posts: 147
Joined: Mon Jun 13, 2016 11:39 am

Re: Problems compiling code. QT stufff

Tue Oct 17, 2017 7:18 am

Maybe this helps: https://stackoverflow.com/questions/397 ... by-default

(There may be several Qt installations on your system; you can select among them by env variable, symlink or direct call.)

lerner
Posts: 548
Joined: Sun Mar 29, 2015 12:12 am

Re: Problems compiling code. QT stufff

Tue Oct 17, 2017 9:41 am

Thanks looking into it now.

Got and installed qt5-default.

Seems to have moved me forward one square.

Now I'm getting this error:
( test -e Makefile.daemon || /usr/lib/arm-linux-gnueabihf/qt5/bin/qmake /home/pi/Downloads/moolticute-master/daemon.pro -o Makefile.daemon ) && make -f Makefile.daemon
Project ERROR: Unknown module(s) in QT: websockets
Makefile:38: recipe for target 'sub-daemon-pro-make_first' failed
make: *** [sub-daemon-pro-make_first] Error 3


AARRGGHH!
Seems I may have to install/get the latest version.
:(

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Problems compiling code. QT stufff

Tue Oct 17, 2017 10:50 am


lerner
Posts: 548
Joined: Sun Mar 29, 2015 12:12 am

Re: Problems compiling code. QT stufff

Tue Oct 17, 2017 11:16 am

Thanks much.

I shall have to start asking there.

Reading their last solution it now gives a new weirder error.

I'll take it up there.

Thanks though and sorry I didn't go there at the start.

I wasn't sure if it was a RasPi problem, compiler problem or what.

Appreciated.

Return to “Beginners”