Posts: 9
Joined: Sun Sep 03, 2017 1:21 pm


Fri Sep 15, 2017 4:14 pm

Hi Guys

Im after a bit of help

Ive just got the enviro pHat from pinoroni and am trying to set it up in my PiClock that ive set up on my PiZero W

Ive tried to install the software but when I run in through Python
Screen.jpg (22.01 KiB) Viewed 627 times
This is what I get.

Raspberian was installed through Noobs as I dont have access to a keyboard so everything has to be done through my vnc server

User avatar
Posts: 8926
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: EnviropHat

Fri Sep 15, 2017 4:29 pm

Probably a question best raised directly with Pimoroni, the suppliers and developers.

At a quick glance it seems that the tutorial here: https://learn.pimoroni.com/tutorial/san ... nviro-phat is written using Python2, whereas you are using Python3.

Do you get the same error if you follow the instructions on that page?

Posts: 354
Joined: Fri Feb 13, 2015 3:18 pm

Re: EnviropHat

Sat Sep 16, 2017 10:09 am

Have you enabled I2C in the Preferences-->Configuration-->Interfaces panel?

Posts: 2121
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: EnviropHat

Sat Sep 16, 2017 1:27 pm

Be careful when installing packages, example
sudo python setup.py install < Installs as Python 2, run it from idle3 and it will fail with errors like your seeing.
sudo python3 setup.py install < Installs for use with Python 3. This has caught me out a few times.
Try running your python script from idel2 and see what happens.
If you used the Pimoroni Dashboard, or the one line installer this shouldn't be your issue. Just a heads up anyway, just in case you did things manually.

Return to “Beginners”