Uwes
Posts: 1
Joined: Thu Sep 27, 2012 10:03 am

[rt2832u] cannot load Modul rt2832u for Terratec Noxxon!

Thu Oct 04, 2012 9:47 am

Hello.
I have trying to install the driver for this howto -->http://www.dfragos.me/2011/11/installat ... -in-linux/.
The linux-headers I got from here --> http://www.raspberrypi.org/phpBB3/viewt ... 73#p164373
The driver of the compile is fine, but I can not load the module.
Does anyone have an idea what goes wrong here?

Code: Select all

~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 045e:0730 Microsoft Corp. Digital Media Keyboard 3000
Bus 001 Device 005: ID 2001:f103 D-Link Corp. DUB-H7 7-port USB 2.0 hub
Bus 001 Device 009: ID 0ccd:00b3 TerraTec Electronic GmbH NOXON DAB/DAB+ Stick

Code: Select all

dmesg
...
[ 8100.144985] usb 1-1.3.5: new high-speed USB device number 9 using dwc_otg
[ 8100.257150] usb 1-1.3.5: New USB device found, idVendor=0ccd, idProduct=00b3
[ 8100.257179] usb 1-1.3.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8100.257197] usb 1-1.3.5: Product: DAB Stick
[ 8100.257209] usb 1-1.3.5: Manufacturer: NOXON
[ 8100.257220] usb 1-1.3.5: SerialNumber: 0
[ 8100.321715] dvb_usb_rtl2832u: Unknown symbol __aeabi_uldivmod (err 0)
[ 8100.322008] dvb_usb_rtl2832u: Unknown symbol __aeabi_ldivmod (err 0)
~# modprobe -vv dvb_usb_rtl2832u
insmod /lib/modules/3.2.27+/kernel/drivers/media/dvb/dvb-usb/dvb-usb-rtl2832u.ko
libkmod: INFO ../libkmod/libkmod-module.c:829 kmod_module_insert_module: Failed to insert module '/lib/modules/3.2.27+/kernel/drivers/media/dvb/dvb-usb/dvb-usb-rtl2832u.ko': No such file or directory
ERROR: could not insert 'dvb_usb_rtl2832u': Unknown symbol in module, or unknown parameter (see dmesg)
libkmod: INFO ../libkmod/libkmod.c:319 kmod_unref: context 0x418b3108 released

vmp32k
Posts: 14
Joined: Fri Jul 27, 2012 3:05 pm

Re: [rt2832u] cannot load Modul rt2832u for Terratec Noxxon!

Mon Nov 26, 2012 10:48 am

Same problem here, did you ever get it to load properly?

Return to “Beginners”