ericg75
Posts: 5
Joined: Tue Nov 22, 2016 5:36 pm

unmet dependancies

Tue Nov 22, 2016 5:57 pm

Hi- Attempting to install a package (wview) for interfacing to a Davis weather station; I am running into UNMET DEPENDANCIES and NO INSTALLATION CANDIDATE for 2 lib packages. I am wondering what- if anything I can do as a newby rpi user to resolve the issues. Is this a situation where I would need to MAKE my own rpi image? I am seeking advice to assist me with my project. Thanks much! :?:

User avatar
topguy
Posts: 6473
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: unmet dependancies

Thu Nov 24, 2016 12:55 pm

So much easier if you could cut&paste the exact command and error messages, right now we lack a lot of information.

You probably dont need to make you own pi-image, but you might need to build some libraries from source and force the installation "wview" .

ericg75
Posts: 5
Joined: Tue Nov 22, 2016 5:36 pm

Re: unmet dependancies

Thu Nov 24, 2016 5:12 pm

Thank you much for your response- below is a list of cmds and responses from my rpi which I hope will be helpful to you.

root@raspberrypi:~# dpkg --print-architecture
armhf
root@raspberrypi:~# cat /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
deb http://www.wviewweather.com/apt/wheezy wheezy main
deb-src http://www.wviewweather.com/apt/wheezy wheezy main

root@raspberrypi:~# apt-cache search wview
wview - unix weather application that generates web sites
root@raspberrypi:~# apt-get install wview
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wview : Depends: libgd2-noxpm (>= 2.0.36~rc1~dfsg) but it is not installable or
libgd2-xpm (>= 2.0.36~rc1~dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@raspberrypi:~# apt-cache search libgd
falconpl-gd2 - Falcon graphic image manipulation module
flydraw - command-line drawing tool
fp-units-gfx - Free Pascal - graphics-library units dependency package
fp-units-gfx-2.6.4 - Free Pascal - graphics-library units
gir1.2-gda-5.0 - data abstraction library based on GLib -- GObject Introspection
gir1.2-gdata-0.0 - GObject introspection data for the GData webservices library
gir1.2-midgard-10.05 - Midgard2 - GObject Introspection
gir1.2-uhm-0.0 - HTTP web service mocking - development files
libg3d-plugin-gdkpixbuf - plugin for the LibG3D library
libgd-barcode-perl - Perl module to create barcode images (GD::Barcode)
libgd-dbg - Debug symbols for GD Graphics Library
libgd-dev - GD Graphics Library (development version)
libgd-gd2-noxpm-ocaml - OCaml interface to the GD library -- transitional package
libgd-gd2-noxpm-ocaml-dev - OCaml interface to the GD library -- transitional package
libgd-gd2-noxpm-perl - Perl module wrapper for libgd - gd2 variant without XPM support
libgd-gd2-perl - Perl module wrapper for libgd - gd2 variant
libgd-graph-perl - Graph Plotting Module for Perl 5
libgd-graph3d-perl - Create 3D Graphs with GD and GD::Graph
libgd-ocaml - OCaml interface to the GD library -- runtime files
libgd-ocaml-dev - OCaml interface to the GD library -- developpement files
libgd-perl - Perl module wrapper for libgd
libgd-securityimage-perl - security image (captcha) generator
libgd-svg-perl - Seamlessly enable SVG output from scripts written using GD
libgd-text-perl - Text utilities for use with GD
libgd-tools - GD command line tools and example code
libgd2-noxpm-dev - GD Graphics Library (transitional package)
libgd2-xpm-dev - GD Graphics Library (transitional package)
Last edited by ericg75 on Thu Nov 24, 2016 8:19 pm, edited 1 time in total.

asavah
Posts: 371
Joined: Thu Aug 14, 2014 12:49 am

Re: unmet dependancies

Thu Nov 24, 2016 6:27 pm

You are mixing jessie and wheezy repos, this will not work.
If the author of whatever stuff you are trying to install is not providing jessie repo - bad luck for you.
Either contact the author(s) and ask them to provide jessie packages or install raspbian wheezy (oudated and no longer supported) on your pi.

Edit: a quick look at the project's sf page suggests that the project is abandoned.

Return to “Beginners”