bugart303
Posts: 1
Joined: Fri Jul 22, 2016 5:36 pm

WebIOPi on Raspberry Pi 3 error

Fri Jul 22, 2016 6:13 pm

hello i'm using a raspberry pi 3 running on Ubuntu Mate 16.04 and after installing WebIOPi (with the patch https://github.com/doublebind/raspi) but when i run

Code: Select all

sudo webiopi
it shows me an error which i posted here http://stackoverflow.com/questions/3846 ... 0_38473180

After doing some research i found out that the port can be changed so i tried changing it to 8001, but when i go to http://raspi-ip:8001, it displays an error response when i use mozilla and just displays a blank screen in chrome after inputting login and password. anyone know how to fix this? or has anyone installed webiopi successfully on raspi3?
Attachments
SF53FO~I.PNG
error shown on mozilla
SF53FO~I.PNG (62.89 KiB) Viewed 2888 times

nee
Posts: 1
Joined: Tue Jan 03, 2017 9:23 pm

Re: WebIOPi on Raspberry Pi 3 error

Tue Jan 03, 2017 9:30 pm

Hi

Have you any success in this problem? I got the same

rdie77
Posts: 16
Joined: Mon Oct 17, 2016 8:25 am

Re: WebIOPi on Raspberry Pi 3 error

Thu Jan 19, 2017 5:52 pm

Hi
I got the same too :-(

User avatar
B.Goode
Posts: 9582
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: WebIOPi on Raspberry Pi 3 error

Thu Jan 19, 2017 6:15 pm

From the Installation instructions here: http://webiopi.trouch.com/INSTALL.html
WebIOPi is developed and tested on Raspbian.
WebIOPi has its own support forum which is actively run by the developer/maintainer - you might get more knowledgeable and informed advice there?

https://groups.google.com/forum/m/#!forum/webiopi

User avatar
DougieLawson
Posts: 37627
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: WebIOPi on Raspberry Pi 3 error

Thu Jan 19, 2017 6:39 pm

B.Goode wrote: WebIOPi has its own support forum which is actively run by the developer/maintainer - you might get more knowledgeable and informed advice there?
FTFY

To me it looks like WebIOPi is 100% dead. There's not been a release for RPi2B, RPi3B or RPi2B2. Latest version 0.71 dates back 15 months to 2nd Oct 2015. There's a whole raft of open/unresolved bugs and the last bug was reported against Wheezy.
https://groups.google.com/d/msg/webiopi ... iXE5SjDAAJ is a telling indictment.

My recommendation is to find any other way to do the stuff you're trying to do with WebIOPi.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
B.Goode
Posts: 9582
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: WebIOPi on Raspberry Pi 3 error

Thu Jan 19, 2017 7:07 pm

Looks like I misread the date of Eric's last contribution...

User avatar
freedomotic
Posts: 154
Joined: Sat Apr 21, 2012 3:59 pm
Location: Italy
Contact: Website

Re: WebIOPi on Raspberry Pi 3 error

Fri Jan 20, 2017 10:22 am

Hi
it seems there is an active fork https://github.com/thortex/rpi3-webiopi working on the project
Freedomotic Open IoT Framework
http://freedomotic.com

Return to “Beginners”