aeromaxx
Posts: 20
Joined: Sat Jun 11, 2016 11:37 am

Configuring HDMI resolution for more than one monitor

Sat Jun 11, 2016 11:59 am

I am hoping someone can jog my memory as to how to do this.

I have a more than one monitor/tv that I use with the raspberry pi, and would like them both to be configured so that they have the correct resolution as and when I connect them to my pi.

Please note that I don't need and won't be using them both at the same time.

I did this a very long time ago, but have since accidently reflashed the sd card also a long time ago, and as I haven't needed to connect either monitor or tv to the raspberry pi for a while haven't noticed what I have done, and as such am unable to remember what I did before.

I vaguely remember that I used the HDMI EDID information, and enclosed the name of the monitor in square brackets with the settings below, but I can't recall how to get the name of the monitor.

I've tried a couple of commands which tell me what modes the monitor supports which was useful to know, but I am sure I need the name also, which I cant seem to find out.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5592
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Configuring HDMI resolution for more than one monitor

Sat Jun 11, 2016 4:01 pm

aeromaxx wrote: ...
I vaguely remember that I used the HDMI EDID information, and enclosed the name of the monitor in square brackets with the settings below, but I can't recall how to get the name of the monitor.
...
IIRC, one way might be to use the tvservice command's -n option:
https://www.cpmspectrepi.uk/raspberry_p ... tings.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Configuring HDMI resolution for more than one monitor

Sat Jun 11, 2016 4:20 pm

aeromaxx wrote:I vaguely remember that I used the HDMI EDID information, and enclosed the name of the monitor in square brackets with the settings below,
For a quick overview: https://www.raspberrypi.org/documentati ... fig-txt.md, search that page for '[edid'

aeromaxx
Posts: 20
Joined: Sat Jun 11, 2016 11:37 am

Re: Configuring HDMI resolution for more than one monitor

Sat Jun 11, 2016 7:50 pm

Thank you both for taking the time to reply to my post.

Should the below work in my config.txt file ? as it doesn't seem to work or am I trying to do something that isn't possible. I had thought that I did have this working somehow but I am unable to remember just what I did.

Code: Select all

[SNY-SONY_TV]
hdmi_group=2
hdmi_mode=23

[EMA-e17t4]
hdmi_group=1
hdmi_mode=4

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Configuring HDMI resolution for more than one monitor

Sun Jun 12, 2016 2:38 am

aeromaxx wrote:Should the below work in my config.txt file ?
No. Please check the doc I linked to.
The syntax is

Code: Select all

[EDID=VSC-TD2220]
And the value can be found by using 'tvservice -n'

aeromaxx
Posts: 20
Joined: Sat Jun 11, 2016 11:37 am

Re: Configuring HDMI resolution for more than one monitor

Sun Jun 12, 2016 8:46 am

DirkS wrote:
aeromaxx wrote:Should the below work in my config.txt file ?
No. Please check the doc I linked to.
The syntax is

Code: Select all

[EDID=VSC-TD2220]
And the value can be found by using 'tvservice -n'
Oh yes, sorry I have looked again and see it now.

I've since corrected it as follows, with the settings for the monitor/tv I will be using with the pi, but it's still not working as I expected it to. The TV was connected at boot time to the pi, but the pi is using the settings for the "EMA-e17t4" monitor instead. As I wasn't why this was I ran the tvservice -n command again and the EDID name is set correctly for the TV.

Code: Select all

[EDID=SNY-SONY_TV]
hdmi_group=2
hdmi_mode=23

[EDID=EMA-e17t4]
hdmi_group=1
hdmi_mode=4
As the above didn't work as intended I added the [all] filter to the bottom, the raspberry pi now skips the specific settings for the actual monitor and instead uses the very last entry settings.

Code: Select all

[all]
hdmi_group=1
hdmi_mode=1

Return to “Beginners”