Derkomai
Posts: 10
Joined: Wed Aug 08, 2012 10:07 pm

Transmission permissions

Thu Aug 09, 2012 8:12 pm

Hello. I've installed transmission and configured it following this tutorial. However, when i run web interface, and after downloading a couple of MB, Transmission shows "Permission denied" error.

It seems like a permissions problem. I've tried chmod to change the downloads folder permisions. I also edited umask value in settings.json file and added my user to debian-transmission group, but nothing works, and i definitely ran out of ideas, because i'm a total noob (it's my 3rd day with the pi.)

¿Any ideas?

Thanks.

kennyvb
Posts: 8
Joined: Wed Aug 08, 2012 8:02 pm
Location: Denmark
Contact: Website

Re: Transmission permissions

Fri Aug 10, 2012 7:32 pm

does the user that runs tranmission have write permission to the download dir ?

Derkomai
Posts: 10
Joined: Wed Aug 08, 2012 10:07 pm

Re: Transmission permissions

Mon Aug 13, 2012 2:47 pm

When i run "ls -l" i see the download directory is owned by debian-transmission and 777 permissions. Is anything more neccesary?

bredman
Posts: 1415
Joined: Tue Jan 17, 2012 2:38 pm

Re: Transmission permissions

Mon Aug 13, 2012 2:54 pm

Check the contents of the transmission log file to see if any errors are reported.

I'm not sure where this log file is stored, but this command will find it for you
sudo find / -name transmission.log

Derkomai
Posts: 10
Joined: Wed Aug 08, 2012 10:07 pm

Re: Transmission permissions

Mon Aug 13, 2012 10:29 pm

When i run that, nothing seems to happen, and no error is printed.

benchu2012
Posts: 2
Joined: Wed Oct 03, 2012 3:33 am

Re: Transmission permissions

Wed Oct 03, 2012 3:43 am

i found that because transmission has two download locations: "download-dir" and "incomplete-dir" [assuming this incomplete-dir-enabled is true] you need to set permissions correctly for both otherwise the permission denied error occurs.

Orionn
Posts: 9
Joined: Fri May 04, 2012 1:11 pm

Re: Transmission permissions

Wed Oct 31, 2012 8:44 am

I ended up having to use the setfacl command.

Code: Select all

chmod g+s /home/pi/downloads
setfacl -m u:debian-transmission:rwx /home/pi/downloads
setfacl -d -m g::rwx /home/pi/downloads
setfacl -d -m o::rwx /home/pi/downloads
setfacl -m o::rwx /home/pi/downloads
setfacl -m g::rwx /home/pi/downloads
Once you do that, any file that is created in that directory can be read and written by others.

Return to “Beginners”