purelife
Posts: 29
Joined: Thu Aug 09, 2012 7:11 pm

Arch Linux Arm not starting up on my Pi

Thu Aug 09, 2012 7:39 pm

After I put in the login and password I type in startx, but it does not recognise this command. Alot of people are having the same issue, any thoughts please?

User avatar
M.M
Posts: 107
Joined: Fri Aug 03, 2012 7:40 am
Location: Hamburg, GER

Re: Arch Linux Arm not starting up on my Pi

Thu Aug 09, 2012 8:04 pm

Hi purelife,

there is a thread over at the Arch forums: http://archlinuxarm.org/forum/viewtopic.php?f=31&t=2877

The user solved the problem by installing the package "xf86-video-fbdev". Could that be a solution for you, too?

It's a little different with him, though. Because his Pi seems to at least recognize the command.

Do you have "startx" in your bin or sbin folder?

Regards
"If people read the FAQs the Qs wouldn't be A F, would they?"

JeremyF
Posts: 515
Joined: Wed Jan 25, 2012 9:06 pm
Contact: Website

Re: Arch Linux Arm not starting up on my Pi

Thu Aug 09, 2012 8:12 pm

Do you have a DE installed?
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge


Hiro
Posts: 78
Joined: Fri Dec 30, 2011 11:09 am

Re: Arch Linux Arm not starting up on my Pi

Fri Aug 10, 2012 7:44 pm

I haven't used arch on the Pi but the normal PC version doesn't install GUI. I had to do something like:

Code: Select all

pacman -S lxde 
If that is not right the exact command can be found in the Arch wiki pages just google "archwiki" and it comes up first.

Return to “Beginners”