User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Main Menu Editor doesn't update

Wed Mar 16, 2016 8:57 pm

My problem is that changes I make in Main Menu Editor don't show in the main menu. Both ways: selected programs don't show up and unselected, even deleted programs do show up. It drives me crazy.
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

DirkS
Posts: 10014
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Main Menu Editor doesn't update

Wed Mar 16, 2016 11:43 pm

IIRC this is a known problem. I thought that had been fixed recently.
Did you do an apt-get update / upgrade recently to get the latest versions?

User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Re: Main Menu Editor doesn't update

Thu Mar 17, 2016 6:37 am

Twice a day :-D
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

dshan
Posts: 3
Joined: Sun Mar 20, 2016 2:41 am

Re: Main Menu Editor doesn't update

Thu Mar 24, 2016 8:50 pm

I'm having the same problem - changes made using Main Menu Editor don't stick, and some disappear after initially appearing for a while.

For example, I enabled several apps and added some new apps in the System Tools group only to have the whole group disappear from the main menu sometime later (it's still visible in the menu editor but with all changes I'd made gone and no apps enabled). Some of the apps I added to System Tools have been mysteriously added to the Other group, most of them not enabled however. If I enable them in Other they appear there briefly but later become disabled again.

It seems like every time I open the Main Menu Editor it randomly changes various app settings, disabling previously enabled apps and moving some into different groups too..

CraigV
Posts: 35
Joined: Tue May 21, 2013 11:45 am

Re: Main Menu Editor doesn't update

Fri Mar 25, 2016 8:47 am

I also had problems with the menu editor losing additions. I described my experience and workaround at
viewtopic.php?f=66&t=137671

User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Re: Main Menu Editor doesn't update

Fri Mar 25, 2016 7:36 pm

Where's the workaround?
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

CraigV
Posts: 35
Joined: Tue May 21, 2013 11:45 am

Re: Main Menu Editor doesn't update

Sun Mar 27, 2016 4:05 am

Maybe I should not call it a work-around. What I do is make a copy of my additions in case I lose them again:
From the link:
I found that I could backup the ~/.config/menus/lxde-pi-applications menu entry elsewhere and restore it when my "Science-1A" menu tree vanished. However, after doing that, it only reappears if I then use the Menu Editor to add something new and then reboot.
The menu is lost when you open the menu editor and then decide to do nothing and click "Cancel". The program then fails to reconstruct the menu it had when it was opened and reverts to the original default menu.

User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Re: Main Menu Editor doesn't update

Sun Mar 27, 2016 10:07 am

Ah! Thank you.
That's part of a solution, yes.
I'm also looking for the solution of the problem: new installed programs don't appear in the menu, and when you use the editor, they're checked to appear. And vice versa: unchecked programs DO appear.

I guess editing the file you mention would be a way to solve that as well.

EDIT:
nope, that doesn't work, I see the following in that file (Exclude!), while it is included. Is the menu editor reading a different file?

Code: Select all

		<Exclude>
			<Filename>wolfram-mathematica.desktop</Filename>
		</Exclude>
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Re: Main Menu Editor doesn't update

Mon Mar 28, 2016 11:45 am

The problem with the menu not updating is the following:

The Raspbian OS uses /usr/share/raspi-ui-overrides/applications as a place to store the desktop files (and those are the ones that get into menus).
When installing stuff, a lot of intallers store the desktop files in the default location, which is /usr/share/applications.

I have 90 files in the default location and only 55 in the raspi-ui-override.

I guess copying or moving the desktop files to the raspi-place will solve the problem.
Last edited by Taxicletter on Tue Feb 27, 2018 9:25 pm, edited 1 time in total.
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

TopherGopher
Posts: 5
Joined: Sat Jan 30, 2016 4:59 am

Re: Main Menu Editor doesn't update

Fri Apr 22, 2016 4:05 am

This following worked for me, but only in removing programs menu.

In the File Manager, I went to home/pi and then right clicked in empty space of the folder and selected Show Hidden. Then I went to .local/share/applications. I found the program icon and a few other files I had deleted in this folder. I then sent it to the Trash, emptied the Trash and then rebooted.

I found a folder called expunged in the applications folder as well, which I also removed.

I hope this works for you.

User avatar
Taxicletter
Posts: 218
Joined: Sat Mar 05, 2016 4:25 pm
Location: Antwerp, Belgium
Contact: Website

Re: Main Menu Editor doesn't update

Fri Apr 22, 2016 7:17 pm

Thank You TopherGopher.
There's nothing in /home/pi/.local/share/applications on my Pi.

I don't use the menu anymore, I make launcher icons in my bottom panel for the programs I use regularly. That way, I'm not annoyed anymore by the faulty updating of the main menu :-).
--::--::- 3 x Raspberry Pi 3 - Raspbian Lite 9 - RuneAudio - one broke (wifi) - not in use -::--::--

Maras
Posts: 6
Joined: Sun May 22, 2016 3:34 pm
Location: Germany

Re: Main Menu Editor doesn't update

Sun May 22, 2016 3:59 pm

I just had similar problems with the menu
- items, that should be there not showing,
items that should not show still showing.

Inspired by the previous posts, I found my way to

Code: Select all

/home/pi/.local/share/applications
.

There I found quite a few items, that should have been gone long ago and were basically useless trash.

I cleaned up the contents of that area - meaning I deleted those unwanted files.
After that, my menu worked again, the way I expected it to work. :)
Raspberry Pi 3

royleith
Posts: 25
Joined: Sun Jul 01, 2012 2:39 pm

Re: Main Menu Editor doesn't update

Thu May 11, 2017 7:25 am

I've had this problem for years with many Raspbian releases. What is irritating is that I keep forgetting the fix (your mileage may vary).

Make sure the desktop files for the menu entries you want are in /usr/share/raspi-ui-overides/applications. Usually,

sudo pcmanfm

will give you a file manager that can move, copy and delete system files. It can, also, destroy Raspbian, so beware. The .desktop files don't have the .desktop extension when viewed in file manager, but appear in full in Open File dialogues.

I have used desktop files edited in leafpad to make new entries for additional programs.

rename lxde-pi-applications.menu in /home/pi/.config/menus/ to lxde-pi-applications.menu.old and reboot.

The programs you have installed should appear and the default catagory folders should also appear. Custom folders may be saved in another .config file and may not appear correctly.

Return to “Beginners”