JarJarGeek
Posts: 48
Joined: Tue Mar 18, 2014 11:32 am

Re: Pi 3 wifi

Fri Mar 04, 2016 10:25 am

here we go - thanks to user ; rsenio

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off
iface default inet dhcp
@jarjargeek

syntax-err0r.com

JarJarGeek
Posts: 48
Joined: Tue Mar 18, 2014 11:32 am

Re: Pi 3 wifi

Fri Mar 04, 2016 10:28 am

rurwin wrote:Power management. Turn it off.
here we go - thanks to user ; rsenio

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off
iface default inet dhcp
@jarjargeek

syntax-err0r.com

User avatar
InsecureSpike
Posts: 23
Joined: Thu Feb 07, 2013 5:37 pm

Re: Pi 3 wifi

Fri Mar 04, 2016 10:35 am

this is what i've done (thanks, buzz & crazyspence)

Code: Select all

sudo nano /etc/rc.local
then add this

Code: Select all

iwconfig wlan0 power off
so it looks like this,

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

iwconfig wlan0 power off

exit 0
ctrl + x then y then enter

then reboot

User avatar
DougieLawson
Posts: 35823
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi 3 wifi

Sat Mar 05, 2016 12:02 pm

rurwin wrote:It is possible that the rpi-update doesn't play nicely with NOOBS, either because of the way it does the update or because of the content of the update. If you wait a while I think the changes should make their way out to the OS images and upgrades. (dist-upgrade possibly.)

Note that to get the extra channels you also need to configure the WiFi internationalisation in raspi-config. But if your Pi is hanging on boot, that's of little immediate help. The reason is that some countries, USA being the main one, don't permit those extra channels to be used. So the initial configuration, with no country defined, doesn't allow them.

Of course, because you have to tell all your equipment to use them and lots of people don't bother, they tend to be good to use because they are nice and quiet.

If you have an Android phone, install "Wifi Analyser". It draws a nice graph of all the WiFi signals around you and lets you pick the channel with the least contention. IIRC, there is no iPhone version because Apple stopped allowing the apps to access the signal strength of other networks.
Both
sudo rpi-update
and
sudo BRANCH=next rpi-update
rendered my Pi3B as a disconnected system until I plugged in a wire and re-installed the raspberrypi-bootloader package. So the practical advice being offered will break your systems.

If you're going to run rpi-update make sure you backup /lib/modules/`uname -r` and /boot to somewhere safe and convenient so you can get your Pi3B running again.

EDIT: I've tried again today and BRANCH=next got my Pi3B running with WiFi working. But that is not a recommendation that any beginners run it.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Pi 3 wifi

Sat Mar 05, 2016 3:06 pm

As I also said in the previous page:
rpi-update is required to get the optional WiFi channels working . Not only that, but what I assume is the bleeding edge development build you get by setting BRANCH to "next". Unless you need to use the extra channels and are willing to put up with development-grade software (ie pre-alpha) then using rpi-update is best avoided.
I might also add, rpi-update is only required to get channels 12 & 13. It doesn't fix anything else. Several people have said it stopped their Pi booting.

kkaiser
Posts: 29
Joined: Tue Jun 09, 2015 3:25 am

Pi 3 wifi - Not Connecting

Fri Apr 01, 2016 2:11 am

I have the most current Jessie running. I've updated and upgraded. But all I get is "No wireless interface found" when I select in the GUI the icon in the upper right corner. If I leave the cursor there I get eth0: with two different Configured items, and two wlan0, one says "Associate with" the other Configured 169.254.6.63/16. I have added to spa_supplicant my home wi-fi but regardless of what I do it doesn't connect.
I am connected via ethernet but I was hoping to also be able to connect via wi-fi. I was able to successfully set up my bluetooth.

So why can't I see my available wi-fi signals? Or how do I turn on the wi-fi so I can see them?

Return to “Beginners”