TotheMax
Posts: 4
Joined: Sat Feb 20, 2016 9:07 pm

Brand new raspberry pi 2 model b not turning on when plugged

Sat Feb 20, 2016 11:34 pm

Is there a light that is supposed to turn on when it's on? I plugged in my pi with the micro Usb psu it came with and it didn't show any signs of turning on. i plugged it into a TV an there was no signal coming from the pi. is the Ethernet light supposed to come on? I soldered on an LCD screen hat kit to the Pi and that isn't coming on either.

drgeoff
Posts: 9368
Joined: Wed Jan 25, 2012 6:39 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Sun Feb 21, 2016 9:54 am

There is a red LED near the corner diagonally opposite the ethernet socket. That should be lit whenever power is applied to the micro-USB socket.

Normally I would expect that your PSU is no good but your mention of soldering makes me wonder if you have caused some problem doing that.

TotheMax
Posts: 4
Joined: Sat Feb 20, 2016 9:07 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Sun Feb 21, 2016 5:30 pm

That light is probably covered by the LCD Hat now... I did an alright soldering job a few of the pins are connected by solder because my iron is a bit big but otherwise I think it's okay. The psu works I charged an external battery for phone with it... I can't unsolder the hat...

I didn't use a tutorial for how

User avatar
Douglas6
Posts: 4672
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: Brand new raspberry pi 2 model b not turning on when plu

Sun Feb 21, 2016 5:55 pm

TotheMax wrote:a few of the pins are connected by solder because my iron is a bit big
That's probably not OK and could damage the add-on or the Pi. A clear picture of the soldering could be helpful to determine the likelihood of damage.

drgeoff
Posts: 9368
Joined: Wed Jan 25, 2012 6:39 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Sun Feb 21, 2016 10:19 pm

The LED is bright enough and close enough to the edge of the board that it would be obvious if it were lit despite the presence of the HAT.

TotheMax
Posts: 4
Joined: Sat Feb 20, 2016 9:07 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 2:10 am

http://i.imgur.com/V67fmao.jpg

There is a picture of my terrible soldering job. I was antsy and just went at it instead of looking for a tutorial. First time soldering too.

I dunno how this could have screwed up the pi but I can definitely unsolder and still use the LCD I'm pretty sure.

fsr
Posts: 88
Joined: Wed Jan 13, 2016 2:29 am

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 2:34 am

TotheMax wrote:There is a picture of my terrible soldering job.
dude are you serious? Why did you even think that would work

you've grounded the 5v (pins 4 & 6)

User avatar
Douglas6
Posts: 4672
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 3:01 am

Yeah, that looks like a pretty horrific soldering job. I'd be surprised if it didn't permanently damage the Pi and the add-on. The good news is that it's only a Pi. The lesson is to learn to solder in small steps, with good instruction.

Goraxium
Posts: 122
Joined: Tue Jan 26, 2016 1:42 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 8:14 am

Can't tell if serious... I understand the desire to get things done, but still... If you want a decent example of how it's supposed to look, flip the Pi over and look at how the header is soldered on.

Alternatively, here's the first thing that came up from a Google image search for "soldered header", which, coincidentally, shows you how it will look if you use too much, or too little solder:
http://web.cecs.pdx.edu/~eas199/B/howto ... _prep.html

TotheMax
Posts: 4
Joined: Sat Feb 20, 2016 9:07 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 11:10 pm

I just figured that since all the holes lined up I needed to solder all of them and a little over soldering wouldn't be an issue.

I'm sure I can salvage the LCD, hopefully this didn't short the Pi.

Does anyone know of a tutorial for this LCD Hat specifically? or another LCD hat that uses the GPIO? I have the card that came with my kit that I got the Pi in that labels the GPIO pins but I didn't realize that would affect this project.

Is there any material I can read on the GPIO to better understand what it is?

User avatar
Douglas6
Posts: 4672
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: Brand new raspberry pi 2 model b not turning on when plu

Mon Feb 22, 2016 11:31 pm

That's an Adafruit TFT. Their website has excellent tutorials on all their products, and also general topics such as soldering and the Pi's GPIOs.

drgeoff
Posts: 9368
Joined: Wed Jan 25, 2012 6:39 pm

Re: Brand new raspberry pi 2 model b not turning on when plu

Tue Feb 23, 2016 12:29 am

TotheMax wrote:I just figured that since all the holes lined up I needed to solder all of them and a little over soldering wouldn't be an issue.
Did it never cross your mind that if it would be OK to join up connections like you did, why would the designers and manufacturers go to the trouble and expense of providing all those separate pins instead of joining those parts of the circuit on the RPi itself and having only one pin per blob?

TheQuestor
Posts: 80
Joined: Wed Nov 28, 2012 9:15 am

Re: Brand new raspberry pi 2 model b not turning on when plu

Tue Feb 23, 2016 2:10 am

Isn't this a little early for an April fools joke? There is no way anyone would think that solder job would not immediately smoke anything you plugged it into. It HAS to be a joke.

User avatar
GTR2Fan
Posts: 1601
Joined: Sun Feb 23, 2014 9:20 pm
Location: South East UK

Re: Brand new raspberry pi 2 model b not turning on when plu

Tue Feb 23, 2016 12:34 pm

Looking on the bright side, the 5V rail on the GPIO header is shorted to ground, so no power will have reached anything apart from the input polyfuse. I'd be surprised if any damage has been caused, except for a 'tripped' polyfuse.
Pi2B Mini-PC/Media Centre: ARM=1GHz (+3), Core=500MHz, v3d=500MHz, h264=333MHz, RAM=DDR2-1200 (+6/+4/+4+schmoo). Sandisk Ultra HC-I 32GB microSD card on '50=100' OCed slot (42MB/s read) running Raspbian/KODI16, Seagate 3.5" 1.5TB HDD mass storage.

Return to “Beginners”