raspmypi
Posts: 7
Joined: Sat Feb 20, 2016 4:59 pm

Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 5:41 pm

First, KODOS 2 ALL @ Raspberry Pi Foundation, for all U DO!!!....You Guys ROCK!!!....
Now, I have been using Debian Linux Ubuntu since like 6.0 around 2012 or so.. By far the best linux distro I have used/seen.. I am a hardware techsupport Hobbyist.. I like to fix things, Mainly Microsoft junk.... I have to say Linux live distros have been a godsend to my work for years now, Iike said i fix windows junk mostly,..
I say that because I, over the years have worked on countless windows systems, I can count on one hand the number of linux systems I have had to fix... In short Linux doesn't breakdown like windows junk..Nor do i have to search the web for drivers,.. Audio, video and the like.. Ubuntu was the first live distro I installed where I didn't have to find a driver for anything..., just a little configuring here and there that is all....
Sorry for my paragraph of not so essential background info...
So I got all my pi hardware together, wireless keyboard and mouse, wifi n dongle,usb audio jack,and 4 port powered hub, all of which worked first try out of the box...
Thank You Again Pi Foundation Guru GODS....

Now my problem is quite simply this, I am trying to edit etc/xdg/lxsession/LXDE-PI/autostart file from the gui, (not as root), to include the tree lines of code to stop the screensaver from blanking on me, I dont know exactly what to do to fix this issue, whether it be login as root from cli then startx and go from there.. or is there a way to edit this file as root from the limited user gui??? (say with a right click ((edit as root option))... all help with this will be greatly appreciated...
like I said i have been using ubuntu for years now but my cli experience is very limited as far as being able to see things, and edit stuff via nano or vi , that is one reason i went and bought my pi 2 qual core with 1 gig ram, so i can properly learn these things for myself.. and teach others with layman like learning abilities I possess..
I am NOT Dyslexic.. I just think in Three Dimensions!!...
Dyslexic's are teople poo!!....2 NOOBS like me READ MORE, POST LESS....

raspmypi
Posts: 7
Joined: Sat Feb 20, 2016 4:59 pm

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 6:17 pm

Fixed: Sorry, :D :oops: for wasting your time, got my problem fixed by reading more in the posts of others...Duh
Dyslexic's are teeple poo.....Thx Guys!!...
I am NOT Dyslexic.. I just think in Three Dimensions!!...
Dyslexic's are teople poo!!....2 NOOBS like me READ MORE, POST LESS....

raspmypi
Posts: 7
Joined: Sat Feb 20, 2016 4:59 pm

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 6:34 pm

Just so others with my limited abilities know..
From Desktop, open Terminal, the little black computer monitor icon in between, File manager,and Mathematica's kewl thorny icon, anyways; cd to file , in my case, cd /etc/xdg/lxsession/LXDE-pi/, then type: "sudo leafpad autostart", without quotes "",edit away via typing, or copy and paste code... then save file,quit leafpad, exit terminal, and reboot via the gui menu shutdown button.. then go back to file in gui file manager and check that edit was successful.....
I am NOT Dyslexic.. I just think in Three Dimensions!!...
Dyslexic's are teople poo!!....2 NOOBS like me READ MORE, POST LESS....

raspmypi
Posts: 7
Joined: Sat Feb 20, 2016 4:59 pm

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 7:17 pm

No Joy, hahahahaha... :lol:
Screen still blanks, darn-it.. O well time to try something else... :roll: :(
I am NOT Dyslexic.. I just think in Three Dimensions!!...
Dyslexic's are teople poo!!....2 NOOBS like me READ MORE, POST LESS....

gordon77
Posts: 4303
Joined: Sun Aug 05, 2012 3:12 pm

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 7:21 pm

With Jessie try sudo nano ~/.config/lxsession/LXDE-pi/autostart

JimmyN
Posts: 1109
Joined: Wed Mar 18, 2015 7:05 pm
Location: Virginia, USA

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sat Feb 20, 2016 9:14 pm

To stop screen blanking for the desktop it works best to just edit the "lightdm.conf" file rather than add to your autostart file.
Open a terminal and....
First make a copy in case you mess it up.

Code: Select all

sudo cp /etc/lightdm/lightdm.conf /etc/lightdm/lightdm.conf.orig
Once you have a backup copy then do

Code: Select all

sudo nano /etc/lightdm/lightdm.conf
Scroll down until you get to "[SeatDefaults]". Make sure it's the "SeatDefaults" with the brackets around it. Then add a line underneath so it looks like this..

Code: Select all

[SeatDefaults]
xserver-command=X -s 0 -dpms
To exit nano and save press <CTRL> and x, then press y to confirm, then press <ENTER>
You'll need to either restart the desktop or reboot for it to take effect, it only reads the config file when the desktop starts.

EDIT: Changed "command=x" to "command=X"
Last edited by JimmyN on Sun Feb 28, 2016 11:31 pm, edited 1 time in total.

TrianP
Posts: 7
Joined: Sat Jan 02, 2016 8:19 pm

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sun Feb 28, 2016 10:53 pm

Editing the lightdm.conf file worked for me, but I found that the "X" in the "command=X" has to be upper case. Always a chance that I had a different typo the first time around, but an upper case X works.

JimmyN
Posts: 1109
Joined: Wed Mar 18, 2015 7:05 pm
Location: Virginia, USA

Re: Cant edit LXDE-pi/autostart to disable screen saver...

Sun Feb 28, 2016 11:25 pm

You're right the lower case is a typo, I should have copied the line right from the file, rather than pulling it out of my... head. Sorry about that. I guess I should edit that line to correct it.

Return to “Beginners”