Page 1 of 1

Local settings on the Pi

Posted: Fri Jan 01, 2016 11:44 am
by Milorad
Hello to all and a happy new year.
It seems that I have a local settings problem. I'm trying to "execute" (well I think it's that) the file deluge-web
Unfortunately on enter it returns the following error:
[ERROR ] 11:29:27 server:76 Unable to initialize gettext/locale: unsupported locale setting.
Can someone help
Subsidiary question.
When I first set up the pi, I did not set up the prefs like language, hour, time zone and the like. Where do I set those prefs and how.
Best regards.

Re: Local settings on the Pi

Posted: Fri Jan 01, 2016 11:51 am
by gordon77
For preferences try sudo raspi-config

Re: Local settings on the Pi

Posted: Fri Apr 22, 2016 4:26 pm
by Milorad
Hello to all
I hope someone will see this follow up. I'm trying to set my locales in raspi-config. So far I've set the timezone (Zürich) and language
None │
│ en_GB.UTF-8 │
│ en_US.UTF-8 │
│ fr_CH.UTF-8

When exit raspi-config, it returns the following:

sudo raspi-config
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
en_GB.UTF-8... done
en_US.UTF-8... done
fr_CH.UTF-8... done
Generation complete.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "C"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

I've read in an other post that when I ssh into the Pi, it could send different locale settings. But, on the mac the file /etc/ssh/ssh-config is empty.

Am I missing something ?

Thank you for your help.

Re: Local settings on the Pi

Posted: Sat Jun 06, 2020 5:19 pm
by kartable
I imagine you solved your problem with the locale. Maybe you can help then?

In raspi-config, I am trying to select LANG=fr_FR.UTF-8 but there is no way to have it done. The system configures LANG=en_GB.UTF-8 each time I am trying. What happens? That should be so easy.

Re: Local settings on the Pi

Posted: Sat Jun 06, 2020 6:07 pm
by jbudd
You could try this:

sudo mv /etc/default/locale /etc/default/locale.old
Now go into raspi-config, localisation soptions, change locale.
Deselect en_GB.UTF-8 and select fr_FR.UTF-8

Re: Local settings on the Pi

Posted: Sat Jun 06, 2020 6:34 pm
by W. H. Heydt
kartable wrote:
Sat Jun 06, 2020 5:19 pm
I imagine you solved your problem with the locale. Maybe you can help then?

In raspi-config, I am trying to select LANG=fr_FR.UTF-8 but there is no way to have it done. The system configures LANG=en_GB.UTF-8 each time I am trying. What happens? That should be so easy.
In raspi-config for language settings, the space bar selects and deselects entries.