gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Wed Jul 15, 2015 4:40 am

emeyeraway wrote:I tried that already. The fact is, when I run a Scratch program, the sound works just fine (through the audio jack connected to a stereo set). Why shouldn't it work for YouTube videos?
omxplayer(GUI) doesn't care about the audio mixer settings, because it accesses the audio hardware directly. I suppose your system (in config.txt) is set to enable HDMI audio.
omxplayer can be told to use the audio jacks with the following option:
-o local
omxplayerGUI can be set to use those options.Open the settings page in kweb. Scroll down to "omxoptions". Enter
-o
local
and click "save"
Do the the same in the area below, called "omxaudiooptions" and also in the next field, "omx_livetv_options"-

Scroll down to "youtube_omxoptions" and do the same.

The default settings are overwritten, when kweb is updated. So it's a good idea to save your settings as a preset:
Enter a name, e. g. "audiojack" and click "save preset".

Check the omxplayerGUI manual for more details.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

emeyeraway
Posts: 146
Joined: Tue Mar 24, 2015 7:11 am

Re: Raspi and YouTube

Thu Jul 16, 2015 6:41 am

My audio started working suddenly without any input from me, and it worked until I shut down. Next time I tried it didn't work any more. So I thought I'd try reloading Minimal Kiosk Browser. I deleted it, then went back to:

wget http://steinerdatenbank.de/software/kweb-1.6.5.tar.gz
tar -xzf kweb-1.6.5.tar.gz
cd kweb-1.6.5
./debinstall

When it finished, it said all important programs had been found, and that I could start using MKB after I install it. I tried "sudo apt-get install kweb_1.6.5-1_armhf.deb", but that didn't work. What is the final step? How do I install once all the files are available?

gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Thu Jul 16, 2015 6:54 am

./debinstall does everything you need. Kweb is already installed.
The message is a bit irritating. In the past the script was run before installation, now it's run after installation, I'll change the text in the next version.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

emeyeraway
Posts: 146
Joined: Tue Mar 24, 2015 7:11 am

Re: Raspi and YouTube

Thu Jul 16, 2015 10:20 am

But it's NOT! When I go to "Internet" in the "Menu" at the top left of the screen, neither Minimal Kiosk Browser icon is there, so I have nothing to click on. That's how I used to go to MKB. Now I'm stumped!

gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Thu Jul 16, 2015 10:45 am

emeyeraway wrote:But it's NOT! When I go to "Internet" in the "Menu" at the top left of the screen, neither Minimal Kiosk Browser icon is there, so I have nothing to click on. That's how I used to go to MKB. Now I'm stumped!
I have no idea. Try running ,/debinstall again.

You cannot install it with apt-get.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

emeyeraway
Posts: 146
Joined: Tue Mar 24, 2015 7:11 am

Re: Raspi and YouTube

Thu Jul 16, 2015 7:03 pm

I've tried unsuccessfully 3 times to install MKB. But I did notice that when I boot up my RasPi, I get the following warning:

"Kernel lacks cgroups or memory controller not available, not starting cgroups. ...warning"

Could this be the problem?

emeyeraway
Posts: 146
Joined: Tue Mar 24, 2015 7:11 am

Re: Raspi and YouTube

Thu Jul 16, 2015 7:36 pm

...or is it possible that I somehow deleted the MKB icon permanently, and the software is actually installed, but I can't see it?

gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Thu Jul 16, 2015 8:11 pm

emeyeraway wrote:I've tried unsuccessfully 3 times to install MKB. But I did notice that when I boot up my RasPi, I get the following warning:

"Kernel lacks cgroups or memory controller not available, not starting cgroups. ...warning"

Could this be the problem?
No. this is normal.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

ThomasS
Posts: 118
Joined: Thu Jan 23, 2014 7:05 pm
Location: Leeds
Contact: Website

Re: Raspi and YouTube

Thu Jul 16, 2015 8:12 pm

I'd try Chromium with pepperflash. Works fine for me.
ThomasS

gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Thu Jul 16, 2015 8:13 pm

emeyeraway wrote:...or is it possible that I somehow deleted the MKB icon permanently, and the software is actually installed, but I can't see it?
you can simply test that. Run from a terminal
kweb
or
kweb3

and also try
omxplayergui.py
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

gkreidl
Posts: 6048
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Raspi and YouTube

Thu Jul 16, 2015 8:15 pm

ThomasS wrote:I'd try Chromium with pepperflash. Works fine for me.
To play youtube video?
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

emeyeraway
Posts: 146
Joined: Tue Mar 24, 2015 7:11 am

Re: Raspi and YouTube

Thu Jul 16, 2015 10:37 pm

gkriedl, YOU DA MAN!!

What I mean is, yes, MKB is still there, and as soon as I entered kweb from the terminal window, it jumped to the page with the youtube option. However, there was still no sound when I chose a video and clicked on play. So I went back to the instructions you had sent regarding -o and local, and after making all those changes (and saving them as "audiojack", as you suggested), I now have both great video AND great sound.

You have the makings of a great teacher: (1) Competence and (2) Patience. Thank you for hanging in there with me until the problem was solved.

Return to “Beginners”