media4
Posts: 5
Joined: Sat Jul 14, 2012 8:50 pm

Bootup notf completing

Sun Jul 15, 2012 10:22 pm

After three different SD cards and about seven boot attempts, I'm not sure what comes next. I've checksunmed the Debian download and it"s ok. But I keep seeing code scroll across my screen, then stop. Some halts have obiously been problems (so I've reloaded the OS and tried again. ) But I keep getting one where it seems to be OK until a certain point, then....nothing....no place to input user name or password to get going. Red and Green LEDs are on steady Help!!

Bad Wolf
Posts: 66
Joined: Wed Jan 25, 2012 11:18 pm

Re: Bootup notf completing

Mon Jul 16, 2012 5:43 pm

Seeing as no one else wants to help I will try using my crystal ball and fill in some blanks correct me if I get it wrong!

Here goes:
The Debian download was of the “squeeze” variety dated 19-04-12
Your SD card is between 4Gb and 16GB in size and is a class 6, to 10

OK so what’s happening?
The “code” you see on screen is actually readable text even though it is fast moving
Somewhere several lines up in this text is a mention of “mmc0: error-110” and another with another mention with “….failed to switch retrying…” I forget the exact words

A quick trip to Github to download updated firmware will help resolve this
https://github.com/raspberrypi/firmware/downloads

Download the zip or tar file depending on which operating system you use to write your SD card and extract them to the boot section of your SD card so they replace the existing files and try again.
To a person with a hammer, everything looks like a nail.

media4
Posts: 5
Joined: Sat Jul 14, 2012 8:50 pm

Re: Bootup notf completing

Tue Jul 17, 2012 2:01 am

Thanks Bad Wolf. Check on the card and the distro...I guess that should have been mentioned. :)
I seem to have it stabilized to the point where it leaves me at...
"mode: e1aocood e92dd800 e24ch004 e5903128 (e51300004)"
Above that on what's still on the screen are "function entered at...." various addresses. The only issue I can see is one "exception stack."
Still go for a fimware upgrade?

media4
Posts: 5
Joined: Sat Jul 14, 2012 8:50 pm

Re: Bootup notf completing (solved)

Wed Jul 18, 2012 1:24 am

It turns out it was my keyboard. Unplug it, and the Pi boots up sedately to the request for the password. Plug it in, and the code starts rocketing by again to end up at the same point as mentioned earlier.
In case anyone tries it, the keyboard is the Nexxtech "wired keyboard" from "The Source" in Canada...the former Radio Shack.

Return to “Beginners”