Page 1 of 1

Mac SD card creation problem, Error: -69877: (solved)

Posted: Sat Mar 14, 2015 1:34 pm
by mraak

Code: Select all

sudo diskutil partitionDisk /dev/disk2 1 MBR "Free Space" "%noformat%" 100%
Started partitioning on disk2
Unmounting disk
Error: -69877: Couldn't open device
Getting the above error while following the instructions here: http://www.raspberrypi.org/documentatio ... ges/mac.md

I was trying to partition the disk using this command:

Code: Select all

sudo diskutil partitionDisk /dev/disk2 1 MBR "Free Space" "%noformat%" 100%
Not sure what to do from here. I'm having Intenso SDHC card 8GB. It is a readonly for some reason and I made sure it is not locked. In the Disk Utility all options are greyed out. Pretty frustrated at this point. Do I have to use Windows to fix it?

Code: Select all

diskutil info /dev/disk2
   Device Identifier:        disk2
   Device Node:              /dev/disk2
   Part of Whole:            disk2
   Device / Media Name:      APPLE SD Card Reader Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      FDisk_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               7.7 GB (7746879488 Bytes) (exactly 15130624 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          Yes
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 Yes
   OS 9 Drivers:             No
   Low Level Format:         Not supported

Re: Mac SD card creation problem, Error: -69877: Couldn't op

Posted: Sat Mar 14, 2015 6:16 pm
by mraak
The solution was something out of this world. Seems like the card was "locked" by an external switch even though it was in unlocked position. What you need to do is put the small switch in between the locked and unlocked position and then it worked. For me it worked when it was about 75% towards the unlocked position, but you might need to fiddle with it a bit.

After that I could use the Disk Utility to erase it and now it works like a charm.

Re: Mac SD card creation problem, Error: -69877: (solved)

Posted: Tue Apr 28, 2015 3:33 pm
by marcogomes
I'm surprised, my micro-sd card was not writable too, the solution to put the lock switch on 75% to the "unlock" position and format using Disk Utility (OS X) made it work again. WEIRD! Thanks! :D