0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Connect to hidden ssid

Wed Apr 28, 2021 11:10 pm

Hi

I'm just setting up my new RPi4 with OpenMediaVault. I installed the latest Raspberry Pi OS Lite (VERSION="10 (buster)"), then flashed OpenMediaVault.

I'm following THIS tutorial from ExplainingComputers on YouTube.

What I want is to connect the RPi to my hidden WiFi - I know that hiding a network does not significantly increase security, but I want to set it up that way.
I did manage to connect it to my WiFi with SSID enabled, but when I disable the SSID broadcasting, it doesn't connect.


With some research I found a few suggestions:
1) sudo nano /etc/network/interfaces
2) sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

But when I open those, they are almost empty.

With the first (sudo nano /etc/network/interfaces) I get the following output:

Code: Select all

# This file is auto-generated by openmediavault (https://www.openmediavault.org)
# WARNING: Do not edit this file, your changes will get lost.

# interfaces(5) file used by ifup(8) and ifdown(8)
# Better use netplan.io or systemd-networkd to configure additional interface stanzas.

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

With the second (sudo nano /etc/wpa_supplicant/wpa_supplicant.conf) I get this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

I tried editing the wpa_supplicant.conf to this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	scan_ssid=1
	ssid="LIMITED"
	psk="1234"
}
Any suggestions?

klricks
Posts: 7787
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Connect to hidden ssid

Thu Apr 29, 2021 4:33 pm

0v3rl0rd wrote:
Wed Apr 28, 2021 11:10 pm
....
I tried editing the wpa_supplicant.conf to this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	scan_ssid=1
	ssid="LIMITED"
	psk="1234"
}
Any suggestions?
Your country code is missing.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

User avatar
B.Goode
Posts: 12103
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Connect to hidden ssid

Thu Apr 29, 2021 4:52 pm

0v3rl0rd wrote:
Wed Apr 28, 2021 11:10 pm

Any suggestions?


You could refer to the usually-reliable information published by Raspberry Pi themselves -

https://www.raspberrypi.org/documentati ... ess-cli.md


(It does mention both the option needed for a hidden SSID, and the necessity for a Country Code.)

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Fri May 07, 2021 12:17 am

klricks wrote:
Thu Apr 29, 2021 4:33 pm
Your country code is missing.
B.Goode wrote:
Thu Apr 29, 2021 4:52 pm
[quote=You could refer to the usually-reliable information published by Raspberry Pi themselves -
https://www.raspberrypi.org/documentati ... ess-cli.md
(It does mention both the option needed for a hidden SSID, and the necessity for a Country Code.)
I added the country code. Now it looks like this:

Code: Select all

network={
	scan_ssid=1
	ssid="LIMITED"
	psk="1234"
        country=HR
}
But it still doesn't connect when the SSID is hidden :/

User avatar
HawaiianPi
Posts: 6343
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Connect to hidden ssid

Fri May 07, 2021 12:40 am

Country code doesn't go in the network block.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
	scan_ssid=1
	ssid="WiFi SSID"
	psk="WPA/WPA2 passphrase"
}
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

User avatar
DougieLawson
Posts: 41321
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Connect to hidden ssid

Fri May 07, 2021 8:19 am

You also need

Code: Select all

bssid=ca:fe:de:ad:be:ef
with the MAC address of your access point in your network={} block.
Any language using left-hand whitespace for syntax is ridiculous

Any DMs sent on Twitter will be answered next month.
Fake doctors - are all on my foes list.

Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Fri May 07, 2021 10:14 pm

HawaiianPi wrote:
Fri May 07, 2021 12:40 am
Country code doesn't go in the network block.
DougieLawson wrote:
Fri May 07, 2021 8:19 am
You also need

Code: Select all

bssid=ca:fe:de:ad:be:ef
with the MAC address of your access point in your network={} block.
I moved the country code where it's supposed to be now.
I also added the MAC of my router inside the "network={}" block.

Now it looks like this:

Code: Select all

update_config=1
country=HR

network={
        bssid=CA:FE:DE:AD:BE:EF
	ssid="LIMITED"
        scan_ssid=1
	psk="1234"
}
Still no success. Just a reminder: I can connect to that same WiFi when SSID broadcast is enabled in router options. When selecting "hide SSID", no WiFi connection with my Pi4.

bls
Posts: 1486
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA

Re: Connect to hidden ssid

Fri May 07, 2021 10:23 pm

0v3rl0rd wrote:
Fri May 07, 2021 10:14 pm
HawaiianPi wrote:
Fri May 07, 2021 12:40 am
Country code doesn't go in the network block.
DougieLawson wrote:
Fri May 07, 2021 8:19 am
You also need

Code: Select all

bssid=ca:fe:de:ad:be:ef
with the MAC address of your access point in your network={} block.
I moved the country code where it's supposed to be now.
I also added the MAC of my router inside the "network={}" block.

Now it looks like this:

Code: Select all

update_config=1
country=HR

network={
        bssid=CA:FE:DE:AD:BE:EF
	ssid="LIMITED"
        scan_ssid=1
	psk="1234"
}
Still no success. Just a reminder: I can connect to that same WiFi when SSID broadcast is enabled in router options. When selecting "hide SSID", no WiFi connection with my Pi4.
Is there any useful information in the system log? sudo journalctl -b | grep wpa and post here in code tags.
Pi tools:
Quickly and easily build customized-just-for-you SSDs/SD Cards: https://github.com/gitbls/sdm
Easily run and manage your network's DHCP/DNS servers on a Pi: https://github.com/gitbls/ndm
Easy and secure strongSwan VPN installer/manager: https://github.com/gitbls/pistrong
Lightweight Virtual VNC Config: https://github.com/gitbls/RPiVNCHowTo

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Fri May 07, 2021 10:26 pm

bls wrote:
Fri May 07, 2021 10:23 pm
Is there any useful information in the system log? sudo journalctl -b | grep wpa and post here in code tags.
Hi.
Here is C/P from the "sudo journalctl -b | grep wpa":

Code: Select all

May 07 23:18:49 raspberrypi wpa_supplicant[662]: Successfully initialized wpa_supplicant
May 07 23:18:49 raspberrypi wpa_supplicant[651]: Successfully initialized wpa_supplicant
May 07 23:21:25 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:32 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:40 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:47 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:55 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:03 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:07 raspberrypi sudo[923]:       pi : TTY=pts/0 ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/nano /etc/wpa_supplicant/wpa_supplicant.conf
May 07 23:22:10 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:19 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:27 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:34 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:42 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:49 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:57 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:05 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:12 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:20 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:27 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:35 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:43 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:50 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:58 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:24:05 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan

bls
Posts: 1486
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA

Re: Connect to hidden ssid

Fri May 07, 2021 10:34 pm

0v3rl0rd wrote:
Fri May 07, 2021 10:26 pm
bls wrote:
Fri May 07, 2021 10:23 pm
Is there any useful information in the system log? sudo journalctl -b | grep wpa and post here in code tags.
Hi.
Here is C/P from the "sudo journalctl -b | grep wpa":

Code: Select all

May 07 23:18:49 raspberrypi wpa_supplicant[662]: Successfully initialized wpa_supplicant
May 07 23:18:49 raspberrypi wpa_supplicant[651]: Successfully initialized wpa_supplicant
May 07 23:21:25 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:32 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:40 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:47 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:21:55 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:03 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:07 raspberrypi sudo[923]:       pi : TTY=pts/0 ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/nano /etc/wpa_supplicant/wpa_supplicant.conf
May 07 23:22:10 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:19 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:27 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:34 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:42 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:49 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:22:57 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:05 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:12 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:20 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:27 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:35 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:43 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:50 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:23:58 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
May 07 23:24:05 raspberrypi wpa_supplicant[662]: wlan0: Failed to initiate sched scan
Obviously it didn't connect because there's a problem. Taking a quick look at your wpa_supplicant.conf, it appears that you've lost the ctrl_interface line, which is probably why you're seeing the above in the log. Here's what it should look like:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=HR

network={
        bssid=CA:FE:DE:AD:BE:EF
	ssid="LIMITED"
        scan_ssid=1
	psk="1234"
}
PS Cafe DeadBeef sounds reallly appetizing :lol:
Pi tools:
Quickly and easily build customized-just-for-you SSDs/SD Cards: https://github.com/gitbls/sdm
Easily run and manage your network's DHCP/DNS servers on a Pi: https://github.com/gitbls/ndm
Easy and secure strongSwan VPN installer/manager: https://github.com/gitbls/pistrong
Lightweight Virtual VNC Config: https://github.com/gitbls/RPiVNCHowTo

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Fri May 07, 2021 10:48 pm

bls wrote:
Fri May 07, 2021 10:34 pm
Obviously it didn't connect because there's a problem. Taking a quick look at your wpa_supplicant.conf, it appears that you've lost the ctrl_interface line, which is probably why you're seeing the above in the log. Here's what it should look like:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=HR

network={
        bssid=CA:FE:DE:AD:BE:EF
	ssid="LIMITED"
        scan_ssid=1
	psk="1234"
}
PS Cafe DeadBeef sounds reallly appetizing :lol:
Sorry, my bad. I just didn't copy the "ctrl-interface..." part here - it does exist.
I tried running the system log command again and I got this:

Code: Select all

pi@raspberrypi:~ $ sudo journalctl -b | grep wpa
May 08 00:40:23 raspberrypi systemd[1]: Created slice system-netplan\x2dwpa.slice.
May 08 00:40:29 raspberrypi wpa_supplicant[646]: Successfully initialized wpa_supplicant
May 08 00:40:29 raspberrypi wpa_supplicant[665]: Successfully initialized wpa_supplicant
May 08 00:41:03 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:11 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:19 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:26 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:34 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan

bls
Posts: 1486
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA

Re: Connect to hidden ssid

Fri May 07, 2021 11:04 pm

0v3rl0rd wrote:
Fri May 07, 2021 10:48 pm
bls wrote:
Fri May 07, 2021 10:34 pm
Obviously it didn't connect because there's a problem. Taking a quick look at your wpa_supplicant.conf, it appears that you've lost the ctrl_interface line, which is probably why you're seeing the above in the log. Here's what it should look like:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=HR

network={
        bssid=CA:FE:DE:AD:BE:EF
	ssid="LIMITED"
        scan_ssid=1
	psk="1234"
}
PS Cafe DeadBeef sounds reallly appetizing :lol:
Sorry, my bad. I just didn't copy the "ctrl-interface..." part here - it does exist.
I tried running the system log command again and I got this:

Code: Select all

pi@raspberrypi:~ $ sudo journalctl -b | grep wpa
May 08 00:40:23 raspberrypi systemd[1]: Created slice system-netplan\x2dwpa.slice.
May 08 00:40:29 raspberrypi wpa_supplicant[646]: Successfully initialized wpa_supplicant
May 08 00:40:29 raspberrypi wpa_supplicant[665]: Successfully initialized wpa_supplicant
May 08 00:41:03 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:11 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:19 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:26 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
May 08 00:41:34 raspberrypi wpa_supplicant[646]: wlan0: Failed to initiate sched scan
Running out of ideas. Check that there is only one wpa_supplicant running pgrep -a wpa. If there's more than one, Kill the one with the lowest PID. Then sudo systemctl restart dhcpcd.

If there's only one, then the next thing to try would be to get some additional debug output from wpa_supplicant:

Code: Select all

sudo systemctl stop dhcpcd          # This should shut down wpa_supplicant
sudo pgrep -a wpa                       # Make sure it's shutdown
sudo /sbin/wpa_supplicant -u -s -d -d -O /run/wpa_supplicant # Each -d increases the debug level
Copy the output from running wpa_supplicant with a few -d switches and post it here.
Pi tools:
Quickly and easily build customized-just-for-you SSDs/SD Cards: https://github.com/gitbls/sdm
Easily run and manage your network's DHCP/DNS servers on a Pi: https://github.com/gitbls/ndm
Easy and secure strongSwan VPN installer/manager: https://github.com/gitbls/pistrong
Lightweight Virtual VNC Config: https://github.com/gitbls/RPiVNCHowTo

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Fri May 07, 2021 11:24 pm

bls wrote:
Fri May 07, 2021 11:04 pm
Running out of ideas. Check that there is only one wpa_supplicant running pgrep -a wpa. If there's more than one, Kill the one with the lowest PID. Then sudo systemctl restart dhcpcd.

If there's only one, then the next thing to try would be to get some additional debug output from wpa_supplicant:

Code: Select all

sudo systemctl stop dhcpcd          # This should shut down wpa_supplicant
sudo pgrep -a wpa                       # Make sure it's shutdown
sudo /sbin/wpa_supplicant -u -s -d -d -O /run/wpa_supplicant # Each -d increases the debug level
Copy the output from running wpa_supplicant with a few -d switches and post it here.


So, here is some output when running commands You suggested.
There were two wpa_supplicant running and I killed the one You said.
When running the last command, there is no output as You can see.

Code: Select all

pi@raspberrypi:~ $ pgrep -a wpa
647 /sbin/wpa_supplicant -c /run/netplan/wpa-wlan0.conf -iwlan0
666 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
pi@raspberrypi:~ $ kill 647
-bash: kill: (647) - Operation not permitted
pi@raspberrypi:~ $ sudo kill 647
pi@raspberrypi:~ $ pgrep -a wpa
666 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
pi@raspberrypi:~ $ sudo systemctl restart dhcpcd
Failed to restart dhcpcd.service: Unit dhcpcd.service not found.
pi@raspberrypi:~ $ sudo systemctl stop dhcpcd
Failed to stop dhcpcd.service: Unit dhcpcd.service not loaded.
pi@raspberrypi:~ $ sudo pgrep -a wpa
666 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
pi@raspberrypi:~ $ sudo /sbin/wpa_supplicant -u -s -d -d -O /run/wpa_supplicant
pi@raspberrypi:~ $ sudo /sbin/wpa_supplicant -u -s -d -d -O /run/wpa_supplicant
pi@raspberrypi:~ $

bls
Posts: 1486
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA

Re: Connect to hidden ssid

Fri May 07, 2021 11:32 pm

Let's try this one more time.
  • Kill ALL running wpa_supplicants (pgrep -a and then kill each and every one of them)
  • sudo /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
And paste the output. If running wpa_supplicant doesn't produce any output on your terminal, then something else is wrong. If that's the case, reboot and try the steps above again. If that doesn't do it, then... :roll:

EDIT: I reread the thread and I see that you aren't using dhcpcd. Too bad. I (and I'd guess most others here) haven't used the old networking stuff you're using in quite some time. I've updated the steps above.
Pi tools:
Quickly and easily build customized-just-for-you SSDs/SD Cards: https://github.com/gitbls/sdm
Easily run and manage your network's DHCP/DNS servers on a Pi: https://github.com/gitbls/ndm
Easy and secure strongSwan VPN installer/manager: https://github.com/gitbls/pistrong
Lightweight Virtual VNC Config: https://github.com/gitbls/RPiVNCHowTo

User avatar
DougieLawson
Posts: 41321
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Connect to hidden ssid

Sat May 08, 2021 8:44 am

bls wrote:
Fri May 07, 2021 10:34 pm

PS Cafe DeadBeef sounds reallly appetizing :lol:
It's the Voodoo café, there's a bit of a hex on it.
Any language using left-hand whitespace for syntax is ridiculous

Any DMs sent on Twitter will be answered next month.
Fake doctors - are all on my foes list.

Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

0v3rl0rd
Posts: 9
Joined: Wed Apr 28, 2021 10:25 pm

Re: Connect to hidden ssid

Sat May 08, 2021 4:48 pm

bls wrote:
Fri May 07, 2021 11:32 pm
Let's try this one more time.
  • Kill ALL running wpa_supplicants (pgrep -a and then kill each and every one of them)
  • sudo /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
And paste the output. If running wpa_supplicant doesn't produce any output on your terminal, then something else is wrong. If that's the case, reboot and try the steps above again. If that doesn't do it, then... :roll:

EDIT: I reread the thread and I see that you aren't using dhcpcd. Too bad. I (and I'd guess most others here) haven't used the old networking stuff you're using in quite some time. I've updated the steps above.
About DHCPCD - to be honest, I have no idea what that is. I do have some experience in using Ubuntu, but all in all I'm new to Linux, especially the command line and the logic behind it.
It's my first try in using RPi at all. I'm trying to build a home NAS using RPiOS Lite and OMV on top of it.

Anyway, while I was waiting for a response I tried something (and after that I went to sleep... it was too much of a command line in one go for me :D ):
1. I formatted the MicroSD card
2. flashed Raspberry OS LITE
3. edited the wpa_supplicant to the simplest form for hidden network (even excluded the "country" line):

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	scan_ssid=1
	ssid="LIMITED"
	psk="1234"
}
And it works.

Then I tried installing OpenMediaVault, and upon finishing the script resulted with this:

Code: Select all

----------
          ID: apply_netplan_config
    Function: cmd.run
        Name: netplan apply
      Result: False
     Comment: Command "netplan apply" run
     Started: 13:55:22.069676
    Duration: 282.54 ms
     Changes:
              ----------
              pid:
                  1659
              retcode:
                  78
              stderr:
                  /etc/netplan/20-openmediavault-eth0.yaml:16:1: Invalid YAML: aliases are not supported:


                  ^
              stdout:

Summary for raspberrypi
------------
Succeeded: 8 (changed=8)
Failed:    1
------------
Total states run:     9
Total run time:   5.058 s
Error applying network changes.  Skipping reboot!
So I guess that the problem is with how OMV handles the ethernet/WiFi connections, because the hidden WiFi connection works normally when flashed fresh RPiOS Lite, and doesn't work after flashing OMV.

Because of the error mentioned above (when installing OMV), I tried:
sudo nano /etc/netplan/30-openmediavault-wlan0.yaml
... and the output is:

Code: Select all

network:
  wifis:
    wlan0:
      dhcp4: true
      dhcp6: false
      link-local: []
      access-points:
        "LIMITED":
          password: "1234"
So my best guess is that OMV uses that file instead of the wpa_supplicant when connecting to WiFi, so I think that the settings must be changed there (after installing OMV)... must find how.

LTolledo
Posts: 5378
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Connect to hidden ssid

Sat May 08, 2021 11:11 pm

that's one big reason to stay away from OMV....(for now)

for network sharing... I used the simplest method.... just plain old reliable samba on top of lite OS...(others prefer NFS on top of lite OS)
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “Beginners”