User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Tue Mar 21, 2017 4:57 am

KLL wrote:
jessiewonka wrote:I don't have a Linux box around
jessiewonka wrote:Next up, will throw Raspbian on another SD to test out.
it's about time!
so you can work on SD partitions and use the nice SD card copier tool ( from desktop menu)
jessiewonka wrote:Btw, is it best practice to format an SD card before installing an image? Or due to the nature of an image, is it irrelevant? If yes, since I'm on a Mac, should I use a prompt command vs some other method/app?
find the proper system image and the manual to install it by "MAC".
I started using Paragon ExtFS for Mac which mounts both partitions in Finder, and while it's pretty simple at the prompt to make disk images, ApplePi-Baker is quite nice. While I'd like a little Linux, and Windows for that matter, system to play with, it's not imperative for my needs.
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Tue Mar 21, 2017 5:22 am

ktb wrote:
jessiewonka wrote: Btw I also then ran "sudo raspi-config --expand-rootfs" to resize the partition, as my SD card is much larger than that image. Is this best practice?
That is usually a good idea.
It seems that raspi-config can resize the partition by ssh into the Pi, and then the final step takes places upon reboot? So is this approach getting around unmounting the drive by that last step reboot? Their warning, "Calling ioctl() to re-read partition table.
Re-reading the partition table failed.: Device or resource busy. The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or kpartx(8)." made me a little nervous.
ktb
Posts: 1379
Joined: Fri Dec 26, 2014 7:53 pm

Re: Can't get on wifi

Postby ktb » Tue Mar 21, 2017 7:10 am

jessiewonka wrote:
ktb wrote:
jessiewonka wrote: Btw I also then ran "sudo raspi-config --expand-rootfs" to resize the partition, as my SD card is much larger than that image. Is this best practice?
That is usually a good idea.
It seems that raspi-config can resize the partition by ssh into the Pi, and then the final step takes places upon reboot?
Yes. You should reboot after using the raspi-config option to expand the root filesystem.
jessiewonka wrote:So is this approach getting around unmounting the drive by that last step reboot? Their warning, "Calling ioctl() to re-read partition table.
Re-reading the partition table failed.: Device or resource busy. The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or kpartx(8)." made me a little nervous.
I don't think I understand exactly what you are asking here. If you use raspi-config to expand the root filesystem, you should reboot regardless of whether you choose the "A1 Expand Filesystem" option from the interactive ncurses menu interface or call raspi-config directly from the command line with the "--expand-rootfs" option. I don't think you need to worry about that warning message.

Actually, I think recent versions of Raspbian come with init=/usr/lib/raspi-config/init_resize.sh in the /boot/cmdline.txt file so that it's the first thing that happens when you install and boot up a fresh copy of Raspbian. It should then reboot automatically. The custom ARpiCADE images do not have that, so you need to do it manually.
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Tue Mar 21, 2017 11:59 pm

ktb wrote:Yes. You should reboot after using the raspi-config option to expand the root filesystem.

Actually, I think recent versions of Raspbian come with init=/usr/lib/raspi-config/init_resize.sh in the /boot/cmdline.txt file so that it's the first thing that happens when you install and boot up a fresh copy of Raspbian. It should then reboot automatically. The custom ARpiCADE images do not have that, so you need to do it manually.
Got it, thank you.

Realizing that before I can try a vanilla Raspbian build I may need an HDMI cable for my monitor, and a power supply for the Pi. :lol:
User avatar
KLL
Posts: 773
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact:

Re: Can't get on wifi

Postby KLL » Wed Mar 22, 2017 12:30 am

jessiewonka wrote:Realizing that before I can try a vanilla Raspbian build I may need an HDMI cable for my monitor
not at all, you can run a RPI headless ( from a PC in your network can ssh putty / VNC into it)
and that is what i talked about in my first post viewtopic.php?p=1132542#p1132542 how to set it up ( without monitor .. ).

and for the power supply you can use a ( better ) mobile charger PS as long you not connect USB devices to the RPI.
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Wed Mar 22, 2017 1:26 am

KLL wrote:
jessiewonka wrote:Realizing that before I can try a vanilla Raspbian build I may need an HDMI cable for my monitor
not at all, you can run a RPI headless ( from a PC in your network can ssh putty / VNC into it)
and that is what i talked about in my first post viewtopic.php?p=1132542#p1132542 how to set it up ( without monitor .. ).

and for the power supply you can use a ( better ) mobile charger PS as long you not connect USB devices to the RPI.
Ah right, I'll give the headless method a go. There's a pc store down the street so I just picked up a PS.
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Wed Mar 22, 2017 7:22 am

KLL wrote: HEAD-LESS SETUP
-1- copy /etc/wpa_supplicant/wpa_supplicant.conf ( from the running system ) to your PC
-2- burn actual raspbian to SD card
-3- while still in PC card reader
copy wpa_supplicant.conf to SD card
create a file "ssh" on SD card
-4- boot SD card in RPI 3 / RPI 2 with WIFI adapter / and power supply
it should come up in router / wifi / after a few seconds, find its IP
-5- putty ssh login into RPI with that IP user pi, password raspberry (edit: corrected)

later can fix IP by /etc/dhcpcd.conf ( and /etc/network/interfaces usually untouched )
Break out the champagne folks, the Pi's on wifi. I followed these steps and had it online in 10 minutes. :D

So Raspbian build works with wifi -- I would think that rules out issues with my router. And the ARpiCADE modified Raspbian build can work with wifi, but not for everyone. While I and ktb had a build working, every build after that would not work for me, and it looks elsewhere like I'm not the only one.
ktb
Posts: 1379
Joined: Fri Dec 26, 2014 7:53 pm

Re: Can't get on wifi

Postby ktb » Wed Mar 22, 2017 7:32 am

Hallelujah :D
ktb
Posts: 1379
Joined: Fri Dec 26, 2014 7:53 pm

Re: Can't get on wifi

Postby ktb » Wed Mar 22, 2017 7:37 am

The only other thing I noticed about the ARpiCADE 3.7 image is that the root partition appears to be delivered in a somewhat corrupt state to begin with. It isn't possible to easily mount the root partition as I normally would on my Ubuntu box, while the boot partition doesn't have any problems. After writing the ARpiCADE 3.7 image to a micro SD card, I was able to mount both partitions without any problems.
ktb
Posts: 1379
Joined: Fri Dec 26, 2014 7:53 pm

Re: Can't get on wifi

Postby ktb » Thu Mar 23, 2017 6:53 am

Well, I feel silly now. One thing I never thought about checking on the ARpiCADE 3.7 image is which modules are blacklisted. If I had used my Pi3B, I probably would have figured this out. Here is the cause of the trouble for Pi3B's WiFi:

Code: Select all

pi@raspberrypi:/etc/modprobe.d $ cat raspi-blacklist.conf
# disable wifi
blacklist brcmfmac
blacklist brcmutil
# disable bluetooth
blacklist btbcm
blacklist hci_uart
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Thu Mar 23, 2017 6:57 am

ktb wrote:Well, I feel silly now. One thing I never thought about checking on the ARpiCADE 3.7 image is which modules are blacklisted. If I had used my Pi3B, I probably would have figured this out. Here is the cause of the trouble for Pi3B's WiFi:

Code: Select all

pi@raspberrypi:/etc/modprobe.d $ cat raspi-blacklist.conf
# disable wifi
blacklist brcmfmac
blacklist brcmutil
# disable bluetooth
blacklist btbcm
blacklist hci_uart
:lol: Yahoo! So excellent, thank you ktb. =D I commented out all of those, rebooted, and it immediately jumped online. :lol:
ktb
Posts: 1379
Joined: Fri Dec 26, 2014 7:53 pm

Re: Can't get on wifi

Postby ktb » Thu Mar 23, 2017 7:17 am

You're welcome. I'm sorry I didn't think of that earlier.
User avatar
jessiewonka
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
Contact:

Re: Can't get on wifi

Postby jessiewonka » Thu Mar 23, 2017 7:33 am

Thanks to everyone for their help with this, very appreciative indeed.