Can't get on wifi [solved]


63 posts   Page 2 of 3   1, 2, 3
by jessiewonka » Sat Mar 18, 2017 4:47 am
TracyLBaker wrote:Before I continue... Is this one Pi, or two?


To clarify, we're only talking about one Pi, two SD cards. (Not to confuse things, but I do have a second Pi-to-jamma setup, but I've not had it in the mix at all. It's identical to the first. I'm trying to help my friend setup his first, then got excited and bought my own.)

TracyLBaker wrote:1) Why is there a wlan1 (in both)? Do you have two wireless adapters? If so, the working in the "working" machine isn't even configured. This is seen in your /etc/network/interfaces file.


TracyLBaker wrote:3) On the working config, you're showing two IPv4 addresses 192.168.7.34/24 and 192.168.7.33/24 on the wlan0 interface. While it is obviously working, this something that is most likely misconfigured.


TracyLBaker wrote:4) Why do you have AppleTalk filing protocol (on port 548) on the working config? I only ask because I can't remember the last time I saw anything AppleTalk -- but if its needed, it is needed.


TracyLBaker wrote:2) On both configurations, DHCP isn't working with the eth0 interface. That's why it shows an APIPA address (169.254.x.x), which is an address that a computer assigns to itself when it cannot reach a DHCP server, see: http://www.webopedia.com/TERM/A/APIPA.html -- APIPA is actually a Microsoft thing, not a Linux thing. Upon doing a little research, I found that Avahi (a zero configuration tool for Linux) will do the same thing.

They both show the same APIPA addresses. This is interesting because APIPA addresses are randomly derived from the 169.254.0.0/16 network -- meaning they can range from 169.254.0.1 to 169.254.255.254 -- a total of 65,534 different addresses -- to have two that are the same is very unlikely (but possible). Additionally, before a machine uses an APIPA address, it pings the network to make certain it isn't already in use.

In either case, the address is not in your network. So now you apparently have something else jacking with the network settings ... and maybe the thing that's preventing your being able to fix this.


A lot of good detective work here, but I'm afraid I'm not sure how to provide answers. Again we're just talking about one Pi 3, with its built-in wifi. I'm plugging an ethernet into the Pi, then that cable is going into a USB-C adapter and into my MBP. AppleTalk must be showing on the working wifi build because initially I thought I needed to setup VNC, tried and failed, but along the way, once the wifi was working, the Pi would show itself as a shared computer in Finder. It may have been a "getting your Pi to work with OS X" tutorial, wish I could remember, but as far as I can tell I've already reread all of the tutorials I worked through with the first build. I'd love to have the new build showing up in Finder again, as that was a great pairing along with SSH to modify certain files.

All I recall with that first build is working through a few tutorials and to my surprise I got the wifi working somehow. Perhaps when I was trying to prep for VNC I installed a package that modified a few things.

TracyLBaker wrote:Before I continue... I had a thought. Since you have two of these, have you tried swapping the SD cards to see if the problem follows the card? If it does, it is something hosed with the installation. If it does not, then you most likely have a hardware problem.

If it follows the card, you can use dd to copy the working image onto the SD card with the non-working image. You'd need a USB micro SD card reader to do this.

I'm wondering, where did you get the pi-to-jamma image? I've done a little looking and I don't see it about.


Per your request, I put the non working wifi image into my second Pi (that's been sitting aside, unused through all of this), and have the exact same results -- no wifi.

I'm concerned about copying the working wifi image because I believe this build or the SD card to be bad in other ways. I spent several nights trying to make an image from that card and it fails partway through. I tried one MBP, one Windows machine with an internal SD reader, command line, a gui, all with the same results. Someone suggested due to my original SD reader having its own issues and randomly unmounting the SD card, it may have corrupted something.

So while that build has the lovely working wifi, it likely has other faults. I've only kept it around for testing, but glad I did.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by jessiewonka » Sat Mar 18, 2017 4:49 am
ktb wrote:
jessiewonka wrote:Wow you're going above and beyond! If you really want to, his v3.7 is here (see 10 part download). Looks like he still has v3.6 up as well. Remember, 3.6 is on one SD card that has working wifi, 3.7 is on another SD card that has nonworking wifi.

Well, to be honest, I have mixed feelings about helping as this is apparently a paid-for product which doesn't appear to be completely open source or at the very least isn't openly available for download. I'll take a look at it.


Yes, the Australian has his own Pi-to-jamma project, it's a board that the Pi mounts on, and software he's written, though I think it's mostly just configured with other open source software. There are a couple other similar projects out there like this.

If you're not comfortable continuing I understand.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sat Mar 18, 2017 5:19 am
jessiewonka wrote:
ktb wrote:
jessiewonka wrote:Wow you're going above and beyond! If you really want to, his v3.7 is here (see 10 part download). Looks like he still has v3.6 up as well. Remember, 3.6 is on one SD card that has working wifi, 3.7 is on another SD card that has nonworking wifi.

Well, to be honest, I have mixed feelings about helping as this is apparently a paid-for product which doesn't appear to be completely open source or at the very least isn't openly available for download. I'll take a look at it.


Yes, the Australian has his own Pi-to-jamma project, it's a board that the Pi mounts on, and software he's written, though I think it's mostly just configured with other open source software. There are a couple other similar projects out there like this.

If you're not comfortable continuing I understand.

I'm still downloading the 10-part version 3.7.

Version 3.6 answers one of my questions:
Code: Select all
Raspberry Pi reference 2016-02-26
Generated using Pi-gen, https://github.com/RPi-Distro/Pi-gen, stage2


I have some other things to do, but I'll be back.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by ktb » Sat Mar 18, 2017 5:31 am
One last question:

What is the gateway address of your WiFi router? It's likely something like 192.168.0.1 or 192.168.1.1.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sat Mar 18, 2017 7:51 am
ktb wrote:One last question:

What is the gateway address of your WiFi router? It's likely something like 192.168.0.1 or 192.168.1.1.


I believe it's 192.168.7.1. Btw I noticed under OS X Settings / Network / DNS I see 75.75.75.75 and 75.75.75.76, which also showed up in my working wifi image log I posted:

Code: Select all
_____/etc/resolv.conf
# Generated by resolvconf
nameserver 75.75.75.75
nameserver 75.75.76.76
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sat Mar 18, 2017 8:18 am
OK. I wrote the 170211_ARpiCADE_3.7.img to a 16 GB micro SD and tested it out on my Raspberry Pi 2 B which has a USB WiFi dongle. My 3B is busy doing other things.

Before I inserted the micro SD card into the Pi2B, I mounted the card on a Mac Mini running Ubuntu 17.04. I then ran wpa_passphrase on my Ubuntu machine to generate a network config for my WiFi network (note: the following is not the real SSID and password for my access point, but just an example):
Code: Select all
ktb@KTBMacMini:~$ wpa_passphrase ktbnet password
network={
   ssid="ktbnet"
   #psk="password"
   psk=ee63db139c5c109ebdfdf35fcd89af68e146c1110cba5228bfd4f7c1f395125f
}


I then edited the /etc/wpa_supplicant/wpa_supplicant.conf file on the mounted micro SD card which included adding the above generated network config:
Code: Select all
country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
   ssid="ktbnet"
   #psk="password"
   psk=ee63db139c5c109ebdfdf35fcd89af68e146c1110cba5228bfd4f7c1f395125f
}


At that point, I booted up the Pi2B with an HDMI-connected TV and the ARpiCADE system seemed to start up fine. Checking the web interface for my router (http://192.168.1.1) on my Ubuntu box, I could see that the Pi2B had been leased an IP from my router. Good, I thought. So, I tried to SSH into the pi:
Code: Select all
ssh pi@192.168.1.33


That led to a bunch of this junk being outputted:
Code: Select all
                        BUILDING GAMELIST... PLEASE WAIT
/home/pi/.attract/sortRomsConsoles.sh: line 83: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 83: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 83: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 83: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 101: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 101: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 101: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 101: -4: substring expression < 0
/home/pi/.attract/sortRomsConsoles.sh: line 101: -4: substring expression < 0

                                  NOW LOADING...


and I was unable to actually do anything over SSH. The tricky thing about this ARpiCADE system is that the .bashrc file located in /home/pi almost immediately starts up a script when booting completes and takes over control. The ARpiCADE system also makes it difficult to switch to a different tty (Ctrl + Alt + F2, Ctrl + Alt + F3, etc.).

So, I shutdown the Pi2B, then removed the micro SD card from the Pi2B and mounted the micro SD card on the Ubuntu box again. I edited the /boot/cmdline.txt file to enable the systemd debug-shell on tty9 like this:
Code: Select all
dwc_otg.lpm_enable=0 console=serial0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait logo.nologo quiet loglevel=0 consoleblank=0 vt.global_cursor_default=0 systemd.debug-shell
#dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty3 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait loglevel=0 logo.nologo vt.global_cursor_default=0


Then I put the card back in the Pi2B and booted it up again. Still, the ARpiCADE system didn't want to let me just easily pull up tty9 (Ctrl + Alt + F9) and kept switching back to it's default screens. I found that if I used the left and right arrow keys on my keyboard I could navigate to a configuration menu where it allowed me to select an option to adjust the volume. After I selected that option (which brings up alsamixer, I think), I found that I could switch to the systemd.debug-shell on tty9 (Ctrl + Alt + F9). Great, now I had root access and could add a new user which I could use to SSH in to the Pi without that annoying script running from the .bashrc file located at /home/pi/.bashrc. So I did, setting and confirming a password for the new user and pressing enter through the rest of the prompts:
Code: Select all
root@raspberrypi:/# adduser ktb


I also added the new ktb user to the same groups as the pi user:
Code: Select all
root@raspberrypi:/# usermod -a -G adm,dialout,cdrom,sudo,audio,video,plugdev,games,users,input,netdev,spi,i2c,gpio ktb



Back on the Mac Mini running Ubuntu, I tried to ssh into the Pi2B with the new user (ktb) I created and that worked fine.
Code: Select all
ktb@KTBMacMini:~$ ssh ktb@192.168.1.35
The authenticity of host '192.168.1.35 (192.168.1.35)' can't be established.
ECDSA key fingerprint is SHA256:bidGAcU0pa/lN9n/zPcmpmo1FR2u+/x9ANHWKj6MBGA.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.35' (ECDSA) to the list of known hosts.
ktb@192.168.1.35's password:
ktb@raspberrypi:~ $ ls -la
total 20
drwxr-xr-x 2 ktb  ktb  4096 Mar 18 07:17 .
drwxr-xr-x 4 root root 4096 Mar 18 07:17 ..
-rw-r--r-- 1 ktb  ktb   220 Mar 18 07:17 .bash_logout
-rw-r--r-- 1 ktb  ktb  3512 Mar 18 07:17 .bashrc
-rw-r--r-- 1 ktb  ktb   675 Mar 18 07:17 .profile


The bottom line is that you shouldn't need to touch /etc/network/interfaces or /etc/dhcpcd.conf.

I suggest you return your /etc/network/interfaces file to the default:
Code: Select all
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 2:17 am
ktb wrote:Before I inserted the micro SD card into the Pi2B, I mounted the card on a Mac Mini running Ubuntu 17.04. I then ran wpa_passphrase on my Ubuntu machine to generate a network config for my WiFi network.


I don't have a Linux box around so I had to run that wpa_passphrase from ssh'ing into the Pi, then included in wpa_supplicant.conf as mentioned, but still no wifi.

ktb wrote:The tricky thing about this ARpiCADE system is that the .bashrc file located in /home/pi almost immediately starts up a script when booting completes and takes over control. The ARpiCADE system also makes it difficult to switch to a different tty (Ctrl + Alt + F2, Ctrl + Alt + F3, etc.).


Yes, when I ssh in, once it says it's loading the game menu, I press control+x which brings you to the Pi prompt.

ktb wrote:So, I shutdown the Pi2B, then removed the micro SD card from the Pi2B and mounted the micro SD card on the Ubuntu box again. I edited the /boot/cmdline.txt file to enable the systemd debug-shell on tty9 like this:
Code: Select all
dwc_otg.lpm_enable=0 console=serial0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait logo.nologo quiet loglevel=0 consoleblank=0 vt.global_cursor_default=0 systemd.debug-shell
#dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty3 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait loglevel=0 logo.nologo vt.global_cursor_default=0


I'm not sure what this is doing, but doesn't seem like something I need to do.

ktb wrote:I also added the new ktb user to the same groups as the pi user:
Code: Select all
root@raspberrypi:/# usermod -a -G adm,dialout,cdrom,sudo,audio,video,plugdev,games,users,input,netdev,spi,i2c,gpio ktb


Also unsure whether or not I need to create a new user -- seems unnecessary for the little that I'm modifying files on the Pi.

ktb wrote:The bottom line is that you shouldn't need to touch /etc/network/interfaces or /etc/dhcpcd.conf. I suggest you return your /etc/network/interfaces file to the default.


I tried this, still no wifi.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by jessiewonka » Sun Mar 19, 2017 2:25 am
A few updates. I started fresh by putting an image of ARpiCADE 3.6 onto my SD card (http://www.aussiearcade.com/showthread. ... nformation) -- this is the version that had the working wifi.

Btw I also then ran "sudo raspi-config --expand-rootfs" to resize the partition, as my SD card is much larger than that image. Is this best practice? It's a bit concerning that some tutorials are two pages long about a more manual approach to resizing the partition.

Then I ssh into the Pi, and before I can even configure my wifi network, I still can't ping a website, and sudo apt-get does very little as it can't connect to websites. This seems to be the core problem, but out of the box this build simply won't let me reach out to the internet. So same behavior, but it seems vital to fix this first, then the wifi, though I guess that's assuming the Pi is getting to the internet through the ethernet to my laptop, which is obviously on my wifi. Again unsure which comes first, but it just won't connect.

In my notes I had overlooked some links I'd added weeks ago when I was working on the build with working wifi. So I assume one of these had me do something at some point that made the Pi have a connection. I've read through them but overall I can't do much since the Pi won't connect. :-/

https://www.dexterindustries.com/howto/ ... beginners/
http://www.makeuseof.com/tag/vnc-ssh-an ... pberry-pi/
http://www.makeuseof.com/tag/setup-wi-f ... erry-pi-3/
http://stackoverflow.com/questions/3236 ... nd-mac-osx
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 4:38 am
jessiewonka wrote:Yes, when I ssh in, once it says it's loading the game menu, I press control+x which brings you to the Pi prompt.

Well, that is a bit helpful. It looks like Ctrl+c works for me.

jessiewonka wrote:I'm not sure what this is doing, but doesn't seem like something I need to do.

Also unsure whether or not I need to create a new user -- seems unnecessary for the little that I'm modifying files on the Pi.

Correct, you don't need to do any of that provided you can get to the "Pi prompt" over SSH. I didn't want to mess with the existing configuration. I also probably could have just temporarily disabled the script that runs from /home/pi/.bashrc, but all that is probably unnecessary seeing as how that script can be canceled with Ctrl+C (or control+x in your case) when connecting over SSH.
jessiewonka wrote:I tried this, still no wifi.

Well, then my best guess is that there is something unusual about your local WiFi network/router.

Which WiFi router are you using? Brand? Model? Is it the public/private WiFi network of a school or university or your own private WiFi router? Does the router use WPA/WPA2 security? 192.168.7.1 seems like an unusual gateway address for a consumer WiFi router, but certainly not impossible.

Based on experience, the name servers 75.75.75.75 and 75.75.76.76 are for Comcast/Xfinity service. Are you using a cable modem+WiFi router combo unit leased from Comcast?

If you want to try setting a static IP address on your Pi, then you can try adding something like the following to the bottom of the file /etc/dhcpcd.conf (again, /etc/network/interfaces should remain unmodified from the default file which came with version 3.6 or 3.7 of ARpiCADE):
Code: Select all
# Static IP address for wlan0
interface wlan0
static ip_address=192.168.7.36/24
static routers=192.168.7.1
static domain_name_servers=192.168.7.1 75.75.75.75 75.75.76.76


You could also try leaving out the static ip_address and seeing if the router leases out proper IP's:
Code: Select all
# Static IP address for wlan0
interface wlan0
static routers=192.168.7.1
static domain_name_servers=192.168.7.1 75.75.75.75 75.75.76.76


When I just ran sudo apt-get update on my Pi2B running ARpiCADE 3.7, I noticed it tries to use IPv6 and it takes forever. Using sudo apt-get -o Acquire::ForceIPv4=true update appears to work better, but it's still SLOWWW. I wonder if killing the script which runs from /home/pi/.bashrc and whatever else that script runs when you want to update or install other packages would help in general. Doing anything over SSH feels very sluggish.

Modifying /etc/apt/sources.list so that it doesn't use a mirror also seems to help a little bit with apt-get update's, but it's still slow:
Code: Select all
deb http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi


EDIT:
Using kill -9 on the PID's (you can get the process ID numbers by running top) for the programs/scripts (attract, leanstick.pl, advmenu) running as part of the ARpiCADE system also seems to help a bit. For example:
Code: Select all
pi@raspberrypi:~ $ kill -9 854
pi@raspberrypi:~ $ kill -9 749
pi@raspberrypi:~ $ kill -9 1120
Last edited by ktb on Sun Mar 19, 2017 5:04 am, edited 2 times in total.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by ktb » Sun Mar 19, 2017 4:41 am
jessiewonka wrote:Btw I also then ran "sudo raspi-config --expand-rootfs" to resize the partition, as my SD card is much larger than that image. Is this best practice?

That is usually a good idea.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 6:01 am
ktb wrote:
jessiewonka wrote:Yes, when I ssh in, once it says it's loading the game menu, I press control+x which brings you to the Pi prompt.

Well, that is a bit helpful. It looks like Ctrl+c works for me.


Oops yes, ctrl+c.

ktb wrote:Well, then my best guess is that there is something unusual about your local WiFi network/router.

Which WiFi router are you using? Brand? Model? Is it the public/private WiFi network of a school or university or your own private WiFi router? Does the router use WPA/WPA2 security? 192.168.7.1 seems like an unusual gateway address for a consumer WiFi router, but certainly not impossible.


I'm thinking that's possible too, but since we have a working wifi build, not sure how. I'm at home and have an Eero router, WPA2, which I installed one month ago, so I was already working on this project well before and after, with the working version working across both Eero and an Apple router previously.

ktb wrote:Based on experience, the name servers 75.75.75.75 and 75.75.76.76 are for Comcast/Xfinity service. Are you using a cable modem+WiFi router combo unit leased from Comcast?


Yes, Comcast service and my own ARRIS SURFboard SB6141 DOCSIS 3.0 Cable Modem.

ktb wrote:If you want to try setting a static IP address on your Pi, then you can try adding something like the following to the bottom of the file /etc/dhcpcd.conf (again, /etc/network/interfaces should remain unmodified from the default file which came with version 3.6 or 3.7 of ARpiCADE):


Tried this, rebooted, no change. I got the "static routers" address from OS X Prefs / Network / wifi / advanced / TCP/IP, which was the same as you wrote actually.

Btw the working wifi version of /etc/dhcpcd.conf was the same as the non working wifi version before I tried editing as you suggested.

While I had the working version running I looked at my iOS Eero app and indeed the Pi shows as a connected device (with the IP 192.168.7.34). Maddening! :-0


ktb wrote:When I just ran sudo apt-get update on my Pi2B running ARpiCADE 3.7, I noticed it tries to use IPv6 and it takes forever. Using sudo apt-get -o Acquire::ForceIPv4=true update appears to work better, but it's still SLOWWW. I wonder if killing the script which runs from /home/pi/.bashrc and whatever else that script runs when you want to update or install other packages would help in general. Doing anything over SSH feels very sluggish.

Modifying /etc/apt/sources.list so that it doesn't use a mirror also seems to help a little bit with apt-get update's, but it's still slow:
Code: Select all
deb http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi


EDIT:
Using kill -9 on the PID's (you can get the process ID numbers by running top) for the programs/scripts (attract, leanstick.pl, advmenu) running as part of the ARpiCADE system also seems to help a bit. For example:
Code: Select all
pi@raspberrypi:~ $ kill -9 854
pi@raspberrypi:~ $ kill -9 749
pi@raspberrypi:~ $ kill -9 1120


I tried killing some processes, but nothing helps. It's not slow, it's just as if the door is shut.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 6:15 am
Hmmm... well, I think I'm stumped.

I've never heard of Eero routers. Have you tried logging into the web interface and checking to see if there is a way to update the firmware (and an available firmware update)?

Here are the packages which I'm currently installing/upgrading (slowly).
Code: Select all
pi@raspberrypi:~ $ sudo apt-get -o Acquire::ForceIPv4=true dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libllvm3.7
Use 'apt-get autoremove' to remove it.
Done
The following NEW packages will be installed:
  libgudev-1.0-0 libinput-bin libinput10 libjsoncpp0 libllvm3.9 libpam-systemd libwacom-bin libwacom-common
  libwacom2 libwayland-bin whois xserver-xorg-input-libinput
The following packages will be upgraded:
  bash bind9-host ca-certificates cmake cmake-data file libasound2 libasound2-data libasound2-dev
  libbind9-90 libcairo2 libdns-export100 libdns100 libegl1-mesa libegl1-mesa-dev libevent-2.0-5 libfcgi-perl
  libgl1-mesa-dri libgnutls-deb0-28 libgnutls-openssl27 libhogweed2 libirs-export91 libisc-export95 libisc95
  libisccc90 libisccfg-export90 libisccfg90 libjasper1 liblcms2-2 liblwres90 libmagic1 libnettle4
  libpam-modules libpam-modules-bin libpam-runtime libpam0g libpcsclite1 libpng12-0 libpng12-dev
  libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libssl1.0.0 libsystemd0 libtiff5
  libudev-dev libudev1 libwayland-client0 libwayland-cursor0 libwayland-dev libwayland-egl1-mesa
  libwayland-server0 libxpm4 login multiarch-support openssl passwd pi-bluetooth raspberrypi-bootloader
  raspberrypi-kernel raspberrypi-kernel-headers raspberrypi-sys-mods raspi-config sed systemd systemd-sysv
  tzdata udev vim-common vim-tiny wireless-regdb x11-common xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-fbdev
80 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 118 MB of archives.
After this operation, 48.4 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 6:21 am
ktb wrote:Hmmm... well, I think I'm stumped.

I've never heard of Eero routers. Have you tried logging into the web interface and checking to see if there is a way to update the firmware (and an available firmware update)?


Eero is a newish company that makes mesh routers. No pending firmware updates.

I don't think I could install any packages since it can't get a connection going.

Edit: I looked at the dates from my notes. So I setup the working wifi build before I changed over from an Apple router to an Eero router. And I setup the non working wifi build while on the Eero router. Was there something about the previous router that allowed scanning? And then once set, it keeps working even on the new router? Seems a stretch but I'm at a loss.

Edit: I'm wondering if I need to turn on port forwarding or a "reservation" on my router so the Pi can access it.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 8:40 am
jessiewonka wrote:Edit: I'm wondering if I need to turn on port forwarding or a "reservation" on my router so the Pi can access it.
Port forwarding will not help in this case. Configuring a DHCP reservation for the Pi (however you would do that with the Eero system) might help. Can you really only configure it with an Android or iOS app? That seems ridiculous. https://support.eero.com/hc/en-us/artic ... -my-eeros-

I know a little about mesh networking, but the Eero system doesn't appear to be simple mesh networking. I read a little bit about their products on their website. The part about automatically switching between 2.4GHz and 5GHz seems troublesome for a Pi3B's WiFi hardware which only supports 2.4GHz. Though it seems like there could be tons of potential issues with their system.

TrueMesh is the next generation of mesh technology, designed to work perfectly with eero hardware and significantly improve eero’s mesh routing algorithms. While eero mesh technology has always automatically switched between the 2.4GHz and 5GHz radio bands to find the clearest channel, TrueMesh understands and navigates a network’s topology in real-time. This means eero will dynamically find the best route to pass data through a network and quickly switch paths to avoid any interference.


I think your next step is to contact Eero for support.
Last edited by ktb on Sun Mar 19, 2017 8:46 am, edited 2 times in total.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 8:42 am
ktb wrote:I know a little about mesh networking, but the Eero system doesn't appear to be simple mesh networking. I read a little bit about their products on their website. The part about automatically switching between 2.4GHz and 5GHz seems troublesome for a Pi3B's WiFi hardware which only supports 2.4GHz. Though it seems like there could be tons of potential issues with their system.

TrueMesh is the next generation of mesh technology, designed to work perfectly with eero hardware and significantly improve eero’s mesh routing algorithms. While eero mesh technology has always automatically switched between the 2.4GHz and 5GHz radio bands to find the clearest channel, TrueMesh understands and navigates a network’s topology in real-time. This means eero will dynamically find the best route to pass data through a network and quickly switch paths to avoid any interference.


I think your next step is to contact Eero for support.


Yeah I wrote them. But the fact that the working build does connect just fine to the Eero is proof it works. So it must be a configuration issue. I noticed it was connected at 2.4ghz when I saw the working build in the Eero app.
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 9:11 am
jessiewonka wrote:
ktb wrote:I know a little about mesh networking, but the Eero system doesn't appear to be simple mesh networking. I read a little bit about their products on their website. The part about automatically switching between 2.4GHz and 5GHz seems troublesome for a Pi3B's WiFi hardware which only supports 2.4GHz. Though it seems like there could be tons of potential issues with their system.

TrueMesh is the next generation of mesh technology, designed to work perfectly with eero hardware and significantly improve eero’s mesh routing algorithms. While eero mesh technology has always automatically switched between the 2.4GHz and 5GHz radio bands to find the clearest channel, TrueMesh understands and navigates a network’s topology in real-time. This means eero will dynamically find the best route to pass data through a network and quickly switch paths to avoid any interference.


I think your next step is to contact Eero for support.


Yeah I wrote them. But the fact that the working build does connect just fine to the Eero is proof it works. So it must be a configuration issue. I noticed it was connected at 2.4ghz when I saw the working build in the Eero app.

That doesn't really matter. If you are unable to simply setup and get a new Raspberry Pi system (whether it is running regular Raspbian or the custom ARpiCADE version of Raspbian) connected to the internet at this point (without your old router), then something is wrong.

I wonder if any complications might be caused by the Eero system remembering and using the hostname ("raspberrypi" and possibly other device information) of devices which have already been connected. Changing the hostname of the new Pi system you're trying to setup might be worth a try.

It might also be worth trying to set up a plain Raspbian Jessie installation and use it in a desktop manner (direct HDMI or composite connected TV/monitor, mouse, keyboard). While booted into the Pixel desktop environment , you could try seeing if you can connect to your WiFi network using the dhcpcd-gtk GUI tool in LXPanel at the top right of the screen.

"eero - Finally, WiFi that works" :lol:

UPDATE: That dist-upgrade I ran failed due to the /etc/fstab file which comes with it:
Code: Select all
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults,noatime  0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
# Temporary mount points
#tmpfs /tmp tmpfs defaults,noatime,nosuid,nodev,noexec,mode=1777 0 0
#tmpfs /var/log tmpfs defaults,noatime,nosuid,nodev,noexec,mode=0755 0 0
tmpfs /var/cache/apt tmpfs defaults,noatime,nosuid,nodev,noexec 0 0
none            /var/tmp        tmpfs   size=1M,noatime   0       0
none            /tmp            tmpfs   size=1M,noatime   0       0
none            /var/log        tmpfs   size=1M,noatime   0       0
#none            /var/run        tmpfs   size=1M,noatime   0       0


If you ever do get a working internet connection, the size=1M set there will be a problem when upgrading. Increasing all those to 300M allowed me to finish the dist-upgrade. You could also probably just comment those lines out. I wonder if that is causing any other problems for you.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 6:36 pm
ktb wrote:That doesn't really matter. If you are unable to simply setup and get a new Raspberry Pi system (whether it is running regular Raspbian or the custom ARpiCADE version of Raspbian) connected to the internet at this point (without your old router), then something is wrong.

I wonder if any complications might be caused by the Eero system remembering and using the hostname ("raspberrypi" and possibly other device information) of devices which have already been connected. Changing the hostname of the new Pi system you're trying to setup might be worth a try.

It might also be worth trying to set up a plain Raspbian Jessie installation and use it in a desktop manner (direct HDMI or composite connected TV/monitor, mouse, keyboard). While booted into the Pixel desktop environment , you could try seeing if you can connect to your WiFi network using the dhcpcd-gtk GUI tool in LXPanel at the top right of the screen.

"eero - Finally, WiFi that works" :lol:


Good idea, I'll try changing the hostname, and if still no wifi, I'll work on a new test build of just Raspbian Jessie (oh hi, me). I've wanted to play around with that anyway.

"Pi - With enough tutorials, WiFi that sometimes works!"
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 6:43 pm
jessiewonka wrote:"Pi - With enough tutorials, WiFi that sometimes works!"

TBH, it's more like... "Pi - Follow up-to-date tutorials, and you'll get WiFi that works!"
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Sun Mar 19, 2017 6:48 pm
ktb wrote:
jessiewonka wrote:"Pi - With enough tutorials, WiFi that sometimes works!"

TBH, it's more like... "Pi - Follow up-to-date tutorials, and you'll get WiFi that works!"


Sure a lot of articles, blog posts, and threads for such a simple thing. Still, I definitely acknowledge it could very well be something in the dev's build or my router. As long as it can be worked around.

Ahh, the dev just replied, "For wifi try enabling it in the raspi-config script, I disabled it in there to speed up the boot time a release or 2 ago, that may be whats stopping it from working for you."
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Sun Mar 19, 2017 7:00 pm
jessiewonka wrote:Ahh, the dev just replied, "For wifi try enabling it in the raspi-config script, I disabled it in there to speed up the boot time a release or 2 ago, that may be whats stopping it from working for you."

That doesn't really make any sense.

You can see the source for raspi-config here (there is no option to enable/disable WiFi in raspi-config, there is only an option to set the country for WiFi):
https://github.com/RPi-Distro/raspi-con ... spi-config

Futhermore, here is the default /boot/config.txt file which comes with ARpiCADE 3.7 and WiFi is not disabled in there:
Code: Select all
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# disable Rpi rainbow splash
disable_splash=1

# to flip the image to account for monitor mounting
#display_rotate=2

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# make sure the pi outputs to correct scanlines without overscan
# use this even when playing with overscan settings for best results
# on CRT monitors always use this setting
disable_overscan=1

# uncomment the following to adjust overscan / picture position. Use positive
# numbers if console goes off screen, and negative if there is too much border
# also use overscan_scale so the emulators comply & still use disable_overscan
# do not adjust top and bottom or you will loose scanline perfect output although
# you can move the picture up or down evenly with okay-ish results better not to
overscan_scale=1
overscan_left=33
overscan_right=32
##overscan_top=4
##overscan_bottom=-4

# ignore edid - we just want video output to do as we say anyway
hdmi_ignore_edid=0xa5000080

# force hdmi output
hdmi_force_hotplug=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=6

# use full spectrum RGB over HDMI
hdmi_pixel_encoding=2

## PLEASE NOTE: due to the resolution switching launcher scripts changes made
## in this section are at your own risk, 480i is correct for this build
## if you change settings here make sure to modify the launchers for each system
# uncomment to force a specific HDMI mode (this will force VGA) Group 1 (DMT) 
# and Group 2 (CVT) behave slightly differently.  You can only use one Group
# and Mode at a time.  For Group 1 Mode 8 is 720x240, Mode 6 is 720x480i & Mode 
# 1 is 640x480p.  Group 2 allows custom settings using mode 87.
hdmi_group=1
hdmi_mode=6
### Group 1 custom modes (don't seem to work well, timings are very specific)
###hdmi_timings=640 0 16 16 34 480 0 21 1 22 0 0 0 60 1 327300000 1
###hdmi_mode=65
## CVT custom modes (works well but cannot do 480i)
#hdmi_cvt=720 240 60 1 0 0 0
#hdmi_group=2
#hdmi_mode=87

# Uncomment for composite PAL
#sdtv_mode=2

# Increase gpu mem for complex attract-mode themes to work properly
gpu_mem=256
#gpu_mem=128

# Uncomment to overclock RPi2
#arm_freq=1000
#sdram_freq=500
#core_freq=500
#over_voltage=2
#temp_limit=80 #Will throttle to default clock speed if hit.

# Experimental RPi3 overclocking - reported stable, you may want a heatsink
# the 1A fuse on a RaspberryJAMMA can be safely upgraded to a 2.5A fuse for RPi3
# and probably should be for overclocking
#arm_freq=1400
#over_voltage=4
#sdram_freq=500
#core_freq=500
#gpu_freq=400
#temp_limit=80 #Will throttle to default clock speed if hit.

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Mon Mar 20, 2017 8:35 pm
ktb wrote:That doesn't really make any sense.

You can see the source for raspi-config here (there is no option to enable/disable WiFi in raspi-config, there is only an option to set the country for WiFi)


I'll have to address that with him. In the meantime I have a few things to try out that you've suggested...maybe tonight. Additionally, I just received this from Eero support, "You shouldn't have to open any ports to get any client device to authenticate onto a network. Are you seeing any specific errors when connecting? Does any device have issues?The only thing I can think of is the wireless adapter for the Pi doesn't support our wireless encryption of WPA2-PSK-AES."
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by ktb » Mon Mar 20, 2017 8:42 pm
WPA2-PSK-AES is supported by the Pi3B on-board WiFi.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm
by jessiewonka » Tue Mar 21, 2017 12:34 am
ktb wrote:WPA2-PSK-AES is supported by the Pi3B on-board WiFi.


So one image works on my router, one image does not, and my router company claims no issues with Pi other than their security protocol, which you point out is not an issue with the Pi 3. Making me feel like it's not necessarily the router.

Tried changing Pi's hostname, no change.

Next up, will throw Raspbian on another SD to test out.

Edit: Btw, is it best practice to format an SD card before installing an image? Or due to the nature of an image, is it irrelevant? If yes, since I'm on a Mac, should I use a prompt command vs some other method/app?
User avatar
Posts: 30
Joined: Fri Mar 17, 2017 8:00 am
Location: Berkeley, CA
by KLL » Tue Mar 21, 2017 1:48 am
jessiewonka wrote:I don't have a Linux box around

jessiewonka wrote:Next up, will throw Raspbian on another SD to test out.

it's about time!
so you can work on SD partitions and use the nice SD card copier tool ( from desktop menu)

jessiewonka wrote:Btw, is it best practice to format an SD card before installing an image? Or due to the nature of an image, is it irrelevant? If yes, since I'm on a Mac, should I use a prompt command vs some other method/app?

find the proper system image and the manual to install it by "MAC".
Posts: 621
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
by ktb » Tue Mar 21, 2017 1:53 am
jessiewonka wrote:
ktb wrote:WPA2-PSK-AES is supported by the Pi3B on-board WiFi.


So one image works on my router, one image does not, and my router company claims no issues with Pi other than their security protocol, which you point out is not an issue with the Pi 3. Making me feel like it's not necessarily the router.

Tried changing Pi's hostname, no change.

Next up, will throw Raspbian on another SD to test out.

Edit: Btw, is it best practice to format an SD card before installing an image? Or due to the nature of an image, is it irrelevant? If yes, since I'm on a Mac, should I use a prompt command vs some other method/app?

In most cases, when writing a Raspberry Pi OS image file to an SD card you shouldn't need to format or erase the card before doing so. If you don't have experience with writing images from the command line or are simply concerned about screwing something up, then use the PiBakery application.
Posts: 1284
Joined: Fri Dec 26, 2014 7:53 pm