zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Storing op gpio

Sat Aug 18, 2018 7:12 pm

Configuratie
RPI2
2 relais boards
Image
Voeding 24VDC in woning
Step down converter naast RPI
Image
RPI schakelt 3 kringen met verlichting via relaisboard 1 en zwembadpomp via board 2

Probleem, als de verlichting brand en de zwembadpomp springt aan of uit dan schakelt de verlichting soms ook uit. (niet altijd)
Als ik de thermische beveiliging van de pomp uitzet blijft alles wel werken.

Wie weet raad af advies?

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Sat Aug 18, 2018 7:23 pm

Hallo,

Even een vraagje. Schakelt het relais uit die alles aanstuurt, of is er iets anders aan de hand?
Als ik de thermische beveiliging van de pomp uitzet blijft alles wel werken.
Dit is sowieso onverstandig om te doen. Aangezien er nu brand kan ontstaan.

Hoe heb je alles aan elkaar vast gemaakt trouwens? En wat heb je exact gebruikt.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Sat Aug 18, 2018 7:56 pm

De relais die de verlichting aansturen schakelen uit, ze krijgen dus een puls van de RPI

Ik bedoel als ik het thermische relais uitzet (en de pomp dus niet aankan slaan) blijft de verlichting wel branden op het moment dat het relaisboard de pomp inschakelt.
Hoe heb je alles aan elkaar vast gemaakt trouwens? En wat heb je exact gebruikt.
Gewoon de GPIO's aan het relaisboard en die schakelen op hun beurt een relais voor de verlichting of de pomp.

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Sat Aug 18, 2018 8:16 pm

Als eerste, hoe "dik" is trouwens die motor van je pomp. Want als hij van zich zelf een thermische relais heeft. Dan het meestal geen kleine motor. En dan is mogelijk de kleine relais niet echt geschikt voor deze toepassing.
zonstraal wrote:
Sat Aug 18, 2018 7:56 pm
De relais die de verlichting aansturen schakelen uit, ze krijgen dus een puls van de RPI
Als het een "dikke" pomp is kan die tijdens het inschakelen een grote piek stroom generenen. Dit levert dan vervolgens weer een spaningspike, die invloed ergens anders op heeft. Maar stuur je jou relais aan met een puls. En niet met een vaste spanning? Kan je misschien een link sturen van je relais board. Aangezien er honderden verschillende soorten zijn..

Loopt je pi ook vast als dit gebeurt of blijft hij werken
zonstraal wrote:
Sat Aug 18, 2018 7:56 pm
Gewoon de GPIO's aan het relaisboard en die schakelen op hun beurt een relais voor de verlichting of de pomp.
Dan nog kan er veel verkeerd gaat ;) of je bent ergens wat vergeten aan te sluiten of je bekabeling is slecht. Want misschien is je gpio pin wel niet geschikt om je relais kaart te bedienen. Verkeerde voltage bijvoorbeeld. En als die dan 'net' aanstaat. Kan een spanningspike veel roet in het eten gooien.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Mon Aug 20, 2018 7:52 pm

Oei sorry mijn antwoord is blijkbaar weggevallen, zal het nogmaals plaatsen.

Pomp is 1000Watt en de RPI met relaisbord schakeld het orginele relais, dus dat zit wel goed.
Als het een "dikke" pomp is kan die tijdens het inschakelen een grote piek stroom generenen. Dit levert dan vervolgens weer een spaningspike, die invloed ergens anders op heeft. Maar stuur je jou relais aan met een puls. En niet met een vaste spanning? Kan je misschien een link sturen van je relais board. Aangezien er honderden verschillende soorten zijn..

Loopt je pi ook vast als dit gebeurt of blijft hij werken
Pi blijft gewoon werken, alleen het licht gaat soms uit.
relaisbord is de deze https://www.ebay.es/itm/4-Channel-5V-Re ... 6bd&_uhb=1

Aangesloten volgens deze site https://www.instructables.com/id/Raspbe ... or-Opener/

De truc met de jumpers ook al geprobeerd maar dat helpt niet
https://raspberrypi.stackexchange.com/q ... ay-modules

De gebruikte GPIO's zijn:
[sw_in = 12 #GPIO 26 relais to Grd
LED1=6 #GPIO 22 led
LED2=13 #GPIO 23 led
LED3=19 #GPIO 24 led/quote]
Voor de 4 relais van de lampen en de GPOI 5 voor het pomp relais

Alles in GPIO.setmode(GPIO.BCM)

Als je nog meer info nodig hebt hoor ik het wel.

Ter info alles draait al 1,5 jaar foutloos op dit ene foutje na.

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Mon Aug 20, 2018 8:41 pm

Okey,
zonstraal wrote: Pi blijft gewoon werken, alleen het licht gaat soms uit.
relaisbord is de deze https://www.ebay.es/itm/4-Channel-5V-Re ... 6bd&_uhb=1
Ehm, misschien kan het heir aan liggen:
  • 4-canales-5V-modulo-de-reles-Para-Arduino-TTL-Logik-LW
  • Each channel requires 15-20 mA
De uitgang van je pi is namelijk maximaal 3.3V en kan maximaal maar 16mA leveren. Dit kan misschien betekenen dat je relais wel aangestuurd wordt, maar niet op volle kracht. Waardoor er door een storing van buiten af een relais weer uit kan gaan.

In deze topic wordt wat meer besproken over het aansturen van je relais board. Misschien wel even interessant om door te kijken.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Mon Aug 20, 2018 8:45 pm

De GPIO's sturen de optocoupler aan en de 5V van de RPI het relais.
Dat is de oorzaak dus niet, zie de derde link in het bovenstaande bericht.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Mon Aug 20, 2018 9:05 pm

Edit: Ik zit nu buiten op het terras en de pomp is om 23:00 uur aangegaan en de verlichting is blijven branden.
Waarmee ik maar wel zeggen dat het niet altijd gebeurd.

Alvast bedankt voor je hulp en suggesties .

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Mon Aug 20, 2018 9:16 pm

zonstraal wrote:
Mon Aug 20, 2018 8:45 pm
De GPIO's sturen de optocoupler aan en de 5V van de RPI het relais.
Dat is de oorzaak dus niet, zie de derde link in het bovenstaande bericht.
Anders gezegd, als er niet genoeg stroom door de led van je optocoupler gaat, dan gaat de transistor in de optocoupler ook niet volledig open.
zonstraal wrote: De GPIO's sturen de optocoupler aan en de 5V van de RPI het relais.
Dat is de oorzaak dus niet, zie de derde link in het bovenstaande bericht.
Oke, wat is de weerstand die er gebruikt wordt bij je optocoupler ingang. Dit kan ook nog trouwens, als je pi de relay aan stuurt. Wat is de spanning over de ingang (Led) van je optocoupler .

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Mon Aug 20, 2018 9:22 pm

Anders gezegd, als er niet genoeg stroom door de led van je optocoupler gaat, dan gaat de transistor in de optocoupler ook niet volledig open.
Oké maar waarom zou er niet genoeg stroom zijn voor de optocoupler en als dat zo zou zijn zou het probleem zich ook voordoen zonder de pomp denk ik?

Image

De R4 bedoel je?
Ga ff kijken of ik dat ergens kan vinden.

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Mon Aug 20, 2018 9:36 pm

Ik bedoel inderdaad r4. En welke spanning staat op de (linker) vcc?

Mijn punt is meer dat wanneer je pomp aangaat, er mogelijk een stoor signaal terug komt over je kabel. En dit komt dan terug op diverse "banen" van je printplaat. En dit kan er dan voor zorgen dan je schakeling niet goed meer werkt. Maar het kan ook zo zijn dat je gpio pin van je pi niet meer "sterk' genoeg is. Mogelijk door wat ik verteld in die gelinkte topic.

edit
Het kan ook zijn dat je relais niet meer 100% is.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Mon Aug 20, 2018 9:40 pm

Er staat 102 op is dat +/-1000 Ohm dat meet ik namelijk?
(Sorry ik ben geen elektronikus )

Gemeten op een relaisboard wat een blikseminslag heeft meegemaakt, dus ook niet zo betrouwbaar :lol:
Ik bedoel inderdaad r4. En welke spanning staat op de (linker) vcc?
Ik heb geen apparatuur om op tiende van Volts nauwkeurig te meten :(

Ps ook met het uitschakelen van de pomp is vandaag alles blijven branden.

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Fri Aug 24, 2018 2:46 pm

zonstraal wrote:
Mon Aug 20, 2018 9:40 pm
Er staat 102 op is dat +/-1000 Ohm dat meet ik namelijk?
(Sorry ik ben geen elektronikus )

Gemeten op een relaisboard wat een blikseminslag heeft meegemaakt, dus ook niet zo betrouwbaar :lol:
Dat is inderdaad een 1000 ohm weerstand.

Kijk dat is informatie waar ik wat aan heb. Aangzien dat relais borden van eBay komen zijn ze daar niet tegen beveiligt. En os er hoogstwaarschijk wat kapot gegaan in de halfgeleiders. Hierdoor kunnen ze nog wel werken. Maar presteren niet meer optimaal. Ik zou dus beginnen me het vervangen van de onderdelen die zijn blootgesteld aan die inslag.

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Fri Aug 24, 2018 3:00 pm

Uiteraard is alles vervangen na de blikseminslag, alles was toen trouwens kapot, 2 PLC's en 1 RPI plus alles sensors in en rond het huis.
Ik had alleen even de weerstand gemeten gemeten op het bewaarde bordje omdat dat gemakkelijker is dan de in dienst zijnde bordjes.
Ik zal straks die 3,3V eens nazien maar zoals geschreven, nauwkeurig zal dat niet zijn.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 11017
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Storing op gpio

Fri Aug 24, 2018 3:15 pm

zonstraal wrote:
Mon Aug 20, 2018 9:22 pm
Oké maar waarom zou er niet genoeg stroom zijn voor de optocoupler en als dat zo zou zijn zou het probleem zich ook voordoen zonder de pomp denk ik?
Image
waarom? dat is duidelijk!

Zoals je in het schema kan zien staan de LED van de opto-coupler, U3 and de indicatie LED L4 in *SERIE* !!! Dat will zeggen dat er pas een LED stroom gaat lopen als de spanning over de string groter is dan de SOM van beide forward voltages, typisch 2Volt elk, oftewel je hebt meer van 4 Volt nodig voor er een LED stroom gaat lopen!

Deze modules zijn ontworpen om met 5V logica te werken, en er is een cent bespaard door een tweede LED stroombegrenzings weerstand weg te bezuinigen.

Zulke lulligheden maaken dat deze modules dus NIET GESCHIKT ZIJN voor 3V3 logica!

Oplossing, sluit de indicatie LED kort!

Helaas helaas, dat betekend dus solderen!

Wat je ook doet, kom NIET in de verleiding om J4 op 5Volt aan te sluiten, want dat gaat dus helemaal niet werken!
Je denkt misschien dat je IN2 aan een GPIO kunt hangen die of UIT staat (als input geschakeld), maar dan komt er 5V op IN2 te staat, en kan je een latchup veroorzaken in de RPI's GPIO logica, een diode (LED) waar vrijwel geen stroom door loopt daar valt ook bijna geen spanning over, dus komt het grootste deel op de GPIO terecht.
VCC MOET lager dan 4Volt zijn.

wil je toch deze relay module gebruiken, zonder L4 kort te sluiten, gebruik dan een transistor (of FET) om IN2 al of niet met GND te verbinden, en zet 5V op VCC..

zonstraal
Posts: 63
Joined: Fri Apr 10, 2015 8:50 am
Location: Spain

Re: Storing op gpio

Fri Aug 24, 2018 5:32 pm

Is er een relais bord wat volgens jullie wel werkt dan?

Brandon92
Posts: 497
Joined: Wed Jul 25, 2018 9:29 pm
Location: Netherlands

Re: Storing op gpio

Sat Aug 25, 2018 10:19 am

Die zijn er inderdaad relay modules die je kan aansluiten op je pi. En die zijn op dit forum meerdere keren voorbij gekomen.

Return to “Nederlands”