Posts: 106
Joined: Mon Nov 20, 2017 7:57 pm

Is anyone running openSUSE on a Pi 3B+ ?

Fri Feb 08, 2019 4:43 pm

Last year I tried openSUSE on a Pi 3B (I think it was.) I did not do much with it as I was not familiar with SUSE. I decided to try again using one of my Pi 3B+ machines. I tried these images from https://en.opensuse.org/HCL:Raspberry_Pi3

Leap 42.3 XFCE - would not boot - just the multicolor screen comes up

Leap 15.0 XFCE - this booted fine but I had no Ethernet connectivity. I tried a USB to Ethernet dongle (which I have used in Raspbian and Ubuntu) but it would not connect either. The NetworkManager applet would not allow me to "Edit Connections..." I noticed something during startup about a "wicked network management" job running long. The network and NetworkManager services were running. I did not diagnose further.

Tumbleweed XFCE - booted fine and both network cards work. I have connectivity. However, when I went to check for updates I was informed that repositories were not configured. I checked the repositories and they did seem to be configured. Not very encouraging.

And, attempting to do ANYTHING seems to be so slow as to be almost unusable.

Just curious if anyone else has had success on the Pi 3B+ (before I devote more time on a loose loose situation.)



User avatar
Posts: 840
Joined: Fri Feb 13, 2015 9:22 pm
Location: EU

Re: Is anyone running openSUSE on a Pi 3B+ ?

Mon Feb 25, 2019 3:52 pm

I still have some TW JeOS with a graphical desktop added, use them with Wireshark and 2 USB-NICs, as I can't get Raspbian to shut up on the bridge made of the two USB-NICs (some arp spam or so, no way around that, apparently).

But I would never do a real update anymore on these SD-cards. No way to clone them to have a functional copy in case (nearly 100% chance) somethings break on updating.

Had some NAS with TW, but the same problem, every update might break the whole system. To me simply a pain.
Kind regards


Return to “openSUSE”