Page 1 of 1

Help needed to get omxplayer on SUSE aarch64

Posted: Tue Feb 07, 2017 8:51 pm
by dukla2000
OK, in my quest to keep fiddling with my Pi3 have discovered a recent Tumbleweed image is quite usable (openSUSE-Tumbleweed-ARM-XFCE-raspberrypi3.aarch64-2017.01.31-Build1.1.raw.xz) and even better it now has a 4.9 kernel.

However to justify splashing out on another EVO+ sdcard (to speed IO) I really need to get omxplayer to work and can't find a way. I have considered/tried 3 options:

1) Compile omxplayer as per popcornmix git. Can't even get going as can't find raspberrypi headers for SUSE viz the Raspbian packages libraspberrypi-dev, libraspberrypi0 & libraspberrypi-bin. Let alone worrying about what compile options to set or some of the other dependencies like fbset (see 3 below).

2) Try install from the Pi2 Packman Essentials & Multimedia repositories. Doesn't work as they only have armv6 and armv7 stuff (no v8/aarch64). I did think to try manually download the v7 and force the install but not sure if a Pi3 in aarch64 mode is backward compatible with v7 executables?

3) I did try a file copy of my Raspbian stuff (/usr/lib/omxplayer/* and /usr/bin/omxplayer*) and failed miserably

Code: Select all

omxplayer -i
which: no fbset in (/home/chris/bin:/usr/local/bin:/usr/bin:/bin:/usr/games)
/usr/bin/omxplayer: line 67: /usr/bin/omxplayer.bin: No such file or directory
The real biggie is I can't find fbset in SUSE repositories: no sure about the line 67 fail as I had copied omxplayer.bin to /usr/bin and checked it was there.


Any hints, tips or suggestions welcome!

TIA

Re: Help needed to get omxplayer on SUSE aarch64

Posted: Tue Feb 07, 2017 8:58 pm
by dom
The aarch64 kernel doesn't currently support some of the firmware APIs (e.g. openmax/mmal) so you can't do this currently.

Re: Help needed to get omxplayer on SUSE aarch64

Posted: Tue Feb 07, 2017 10:19 pm
by dukla2000
Thanks dom. Short, sweet, disappointing but hey, facts are our friends :D

Are there any possible milestones visible? Is a solution more likely on 4.10?