ebijun
Posts: 57
Joined: Sat Feb 09, 2013 1:39 am

2017-09-02-netbsd-raspi-earmv6hf.img

Fri Sep 01, 2017 2:36 am

For Open Source Conference 2017 chiba demonstration use,
I've updated 2017-09-02-netbsd-raspi-earmv6hf.img.gz for RPI.

http://mail-index.netbsd.org/port-arm/2 ... 04383.html

http://cdn.netbsd.org/pub/NetBSD/misc/j ... 6hf.img.gz

Update:
- NetBSD-current 8.99.2 evbarm-earmv6hf 201708290440Z rpi.img from nyftp.
- ruby23-base-2.3.4nb1
"Add patch to fix vulnerabilities of rubygems."
http://mail-index.netbsd.org/pkgsrc-cha ... 62219.html
- mikutter-3.5.10
http://mail-index.netbsd.org/pkgsrc-cha ... 62098.html

Overview:
http://wiki.NetBSD.org/ports/evbarm/raspberry_pi/

dmesg:
https://github.com/ebijun/NetBSD/blob/m ... rmv6hf/RPI
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI0
https://github.com/ebijun/NetBSD/blob/m ... v6hf/RPI0W
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI2
https://github.com/ebijun/NetBSD/blob/m ... f/RPI2-1.2
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI3

Pre-installed packages:
https://github.com/ebijun/NetBSD/blob/m ... rc/pkginfo

Problem:
- pkgsrc/devel/boost-libs compile failed.
http://gnats.netbsd.org/cgi-bin/query-p ... mber=52425
"Maybe we should default to a vfp3 FPU when configuring the compiler for
earmv6hf or earmv7hf targets ?"
- webkit24-gtk-2.4.11nb9 compile failed.
- dillo-3.0.5nb2 works with -O0
thanx Jared McNeill.
- Xfce4 4.13:
# hang with xfce4-sessions,4.12 works fine.

Security:
- security.pax.mprotect.enabled
http://netbsd.org/gallery/presentations ... NetBSD.pdf
man security
man paxctl
sysctl -a |grep pax
If application failed, such as omxplayer.
try to test
sysctl -w security.pax.mprotect.enabled=0

---
Comments are welcome on port-arm netbsd mailinglist or
twitter @ebijun

Return to “NetBSD”

Who is online

Users browsing this forum: No registered users and 1 guest