ebijun
Posts: 57
Joined: Sat Feb 09, 2013 1:39 am

2017-08-04-netbsd-raspi-earmv6hf.img

Wed Aug 02, 2017 3:59 am

For OpenSourceConference 2017 Kyoto demonstration use,
I've updated 2017-08-04-netbsd-raspi-earmv6hf.img.gz for RPI.

http://mail-index.netbsd.org/port-arm/2 ... 04344.html

http://cdn.netbsd.org/pub/NetBSD/misc/j ... 6hf.img.gz

Update:
- NetBSD-current 8.99.1 evbarm-earmv6hf 201707301430Z rpi.img from nyftp.

Overview:
http://wiki.NetBSD.org/ports/evbarm/raspberry_pi/

dmesg:
https://github.com/ebijun/NetBSD/blob/m ... rmv6hf/RPI
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI0
https://github.com/ebijun/NetBSD/blob/m ... v6hf/RPI0W
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI2
https://github.com/ebijun/NetBSD/blob/m ... f/RPI2-1.2
https://github.com/ebijun/NetBSD/blob/m ... mv6hf/RPI3

Pre-installed packages:
https://github.com/ebijun/NetBSD/blob/m ... rc/pkginfo

Problem:
- sdhost:
with 201708010210Z,only RPI3 can mount sdcard,others failed.
http://cdn.netbsd.org/pub/NetBSD/misc/j ... hf/sdhost/
- pkgsrc/devel/boost-libs compile failed.
# compile option issue.
- webkit24-gtk-2.4.11nb9 compile failed.
- dillo-3.0.5nb2 works with -O0
thanx Jared McNeill.
- Xfce4 4.13:
# hang with xfce4-sessions,4.12 works fine.

Security:
- security.pax.mprotect.enabled
http://netbsd.org/gallery/presentations ... NetBSD.pdf
man security
man paxctl
sysctl -a |grep pax
If application failed, such as omxplayer.
try to test
sysctl -w security.pax.mprotect.enabled=0

---
Comments are welcome on port-arm netbsd mailinglist or
twitter @ebijun

Return to “NetBSD”

Who is online

Users browsing this forum: No registered users and 1 guest