User avatar
ab1jx
Posts: 867
Joined: Thu Sep 26, 2013 1:54 pm
Location: Heath, MA USA
Contact: Website

Trouble building ports

Sat Oct 19, 2013 5:13 am

I've got the image from http://www.db.net/downloads/bsd-pi-252209M.img.xz loaded, which is FreeBSD 10 CURRENT and a CURRENT ports tree for 10, and I'm seeing a bunch of strange problems with a couple ports now. The latest is devel/gettext. Errors that are telling me to submit a bug report to places like http://llvm.org/bugs

I'm just wondering if too much stuff has been stripped out of the image or I should expect it to behave like any normal image? Maybe something in the ports infrastructure?

I don't usually run FreeBSD, but I've been using OpenBSD for about 13 years, always build everything from ports, never had a problem. One error would be one thing, but 2 makes me wonder how much time I want to invest in this. I'm just beginning, trying to get my usual editor (joe) built. I've built dialog4ports-0.1.5_1,
libiconv-1.14_1, libtool-2.4.2_2, perl-5.14.4_2, pkg-1.1.4_8 mostly still building dependencies. The gettext I'm trying to build is gettext-0.18.3.1. I'm helpless without joe and mc!

Alan

delta898
Posts: 1
Joined: Tue Dec 10, 2013 4:11 am

Re: Trouble building ports

Tue Dec 10, 2013 4:14 am

native build on RPI? or cross build?

You may need swap because of lack of memory.

How about swap on?

$dd if=/dev/zero of=/usr/swap0 bs=1m count=128

$mdconfig -a -t vnode -f /usr/swap0

$swapon /dev/md0

ingmar
Posts: 7
Joined: Fri Oct 26, 2012 2:45 am

Re: Trouble building ports

Wed Jan 29, 2014 12:00 pm

This bug has been resolved in 10.0-RELEASE.


BigJacobus
Posts: 7
Joined: Sat Sep 13, 2014 9:47 pm

Re: Trouble building ports

Fri Sep 19, 2014 10:41 pm

I am having the same problems compiling/making the PKG port in FreeBSD. I don't know if anyone has been able to complete this on the B+ model. It sounds like these bugs were already worked out in the previous model.

Return to “FreeBSD”