Page 1 of 1

RPi 3 B+ and FreeBSD 12 Works But LEDs Do Not

Posted: Sat Apr 13, 2019 7:26 pm
by rtb190413
On a headless RPi3 B+ (Element 14) with FreeBSD 12.0-RELEASE and an RJ45 connection, the OS loads and I can ssh into it with no apparent problems. However the LEDs at the base of the ethernet jack have never lit up, and the red power LED only lights briefly when powering up. The board is totally dark, yet seems to otherwise work fine.

Anyone come across this problem and know if it's faulty hardware or an issue with the particular version of OS? (I've not tried any other OSs.)

EDIT: Bought a spare micro SD and tried Raspian Stretch Lite. Here's the rundown if any other FreeBSD RPi3 users have similar questions or issues.
1) The red power LED still flashed only for only a few seconds, but changing to a different wall adapter for the USB now has it staying permanently on for both Raspian and FreeBSD. (So this was probably a power-source issue.)
2) The green light now occasionally flashes for Raspian (but never worked at all for FreeBSD).
3) The yellow ethernet LED (on the right, facing the board) flashes with Raspian and never worked once for FreeBSD.
4) The second ethernet LED on the left never lit up for either Raspian or FreeBSD. According to this blog https://blog.samcater.com/raspberry-pi- ... dont-work/, 10/100Mb connections get the green light, and Gigabit connections get the flashing orange (yellow to my eyes) one.

HTH, and if anyone can add to this, especially explaining how FreeBSD handles the LED indicators different than Linux, that would be great to see. (And thanks to the other two posters for responding to my question.)

Re: RPi 3 B+ and FreeBSD 12 Works But LEDs Do Not

Posted: Sat Apr 13, 2019 7:33 pm
by pcmanbob
Hi.

To eliminate it being a fault pi why not just flash an SD card with raspbian which is known to drive all the LED's on the pi correctly.

https://www.raspberrypi.org/downloads/raspbian/

Re: RPi 3 B+ and FreeBSD 12 Works But LEDs Do Not

Posted: Sat Apr 13, 2019 7:37 pm
by mahjongg
FreeBSD has its own forum section, moved this post there, where it belongs.
The chance this is a hardware error, instead of a fault in the ethernet driver is quite remote, I agree try raspbian first.