MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Нет изображения на мониторе(NO SIGNAL)

Fri May 18, 2018 5:25 pm

Всем привет! Заказывал на али от ресселлера Element14 бандл с карточкой и блоком питания на 2.5А, источники питания менял, не помогает.

Закидывал на сд карту и BerryBoot, и Raspbian with Desktop, и NOOBS, результат один и тот же. Зеленый светодиод мигает, красный пару раз мигает при запуске и все, но, подключаю через HDMI к монитору, пишет NO INPUT(NO SIGNAL), не знаю, как фиксить. Учитывая, что диоды вроде показывают, что она запустилась, и то, что диоды на Ethernet-port'е мигают, то в чем дело? В NOOBS пробовал с клавиатуры от 1-4 понажимать, там вроде меняет режимы выхода, не помогло

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sat May 19, 2018 2:36 am

Забыл написать, что у меня raspberry pi 3 model b

peppy.player
Posts: 110
Joined: Mon Mar 07, 2016 6:10 am

Re: Нет изображения на мониторе(NO SIGNAL)

Sat May 19, 2018 5:18 pm

Возможных причин вагон и маленькая тележка. Попробуйте сначала выяснить малина у вас рабочая или нет?
Установите Stretch или с десктопом (если он вам нужен в дальнейшем) или без:
https://www.raspberrypi.org/downloads/raspbian/

Положите в корневую папку пустой файл с именем ssh. Это даст вам возможность зайти на малину
через SSH используя putty:
https://www.chiark.greenend.org.uk/~sgt ... atest.html

Успешный вход в малину исключит несколько возможных причин - плохую малину, плохую флэшку и плохой
источник питания. Ну а потом уже надо копать дальше...

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Sat May 19, 2018 6:04 pm

MaratG2 wrote:
Fri May 18, 2018 5:25 pm
красный пару раз мигает при запуске и все
если красный после мигания остаётся в состоянии "потух", значит надо менять БП и/или кабель до него.

Красный тухнет когда питания меньше чем в концлагере....

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 4:38 am

hommar wrote:
Sat May 19, 2018 6:04 pm
MaratG2 wrote:
Fri May 18, 2018 5:25 pm
красный пару раз мигает при запуске и все
если красный после мигания остаётся в состоянии "потух", значит надо менять БП и/или кабель до него.

Красный тухнет когда питания меньше чем в концлагере....
Я имел ввиду, что он пару раз мигает, а потом горит, все хорошо
Кстати, зачем проверять, работает ли все, если на LAN все горит?

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 5:06 am

peppy.player wrote:
Sat May 19, 2018 5:18 pm
Возможных причин вагон и маленькая тележка. Попробуйте сначала выяснить малина у вас рабочая или нет?
Установите Stretch или с десктопом (если он вам нужен в дальнейшем) или без:
https://www.raspberrypi.org/downloads/raspbian/

Положите в корневую папку пустой файл с именем ssh. Это даст вам возможность зайти на малину
через SSH используя putty:
https://www.chiark.greenend.org.uk/~sgt ... atest.html

Успешный вход в малину исключит несколько возможных причин - плохую малину, плохую флэшку и плохой
источник питания. Ну а потом уже надо копать дальше...
Вошел, плюс мораль от того, что дело не в малинке и т.д.
Поставил Raspbian, сделал hdmi_hotplug 1, монитор не видит все равно
Attachments
1.png
1.png (108.72 KiB) Viewed 2053 times
2.png
2.png (122.27 KiB) Viewed 2053 times

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 5:14 am

MaratG2 wrote:
Sun May 20, 2018 4:38 am
Я имел ввиду, что он пару раз мигает, а потом горит, все хорошо
Кстати, зачем проверять, работает ли все, если на LAN все горит?
в при старте есть моменты с максимальным потреблением (когда управление частотой процессора ещё не активировано, и проц шпарит на максимальной частоте), если мигает - значит не хватает энергии даже для старта.
Красный светодиод никогда не должен мигать!

PS Причём здесь LAN? на многих компах он мигает даже когда комп выключен, т.к. есть такая фича как "пробуждение по сети".
Кстати, Если всё же предположить что Проблемы с HDMI - то по LAN мадина должна хотя бы пинговаться....
(либо научитесь правильно формулировать свои мысли)

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 5:31 am

MaratG2 wrote:
Sun May 20, 2018 5:06 am
Поставил Raspbian, сделал hdmi_hotplug 1, монитор не видит все равно
тогда надо дальше подбирать параметры:

Code: Select all

hdmi_group=
hdmi_mode=

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 9:02 am

hommar wrote:
Sun May 20, 2018 5:14 am
MaratG2 wrote:
Sun May 20, 2018 4:38 am
Я имел ввиду, что он пару раз мигает, а потом горит, все хорошо
Кстати, зачем проверять, работает ли все, если на LAN все горит?
в при старте есть моменты с максимальным потреблением (когда управление частотой процессора ещё не активировано, и проц шпарит на максимальной частоте), если мигает - значит не хватает энергии даже для старта.
Красный светодиод никогда не должен мигать!

PS Причём здесь LAN? на многих компах он мигает даже когда комп выключен, т.к. есть такая фича как "пробуждение по сети".
Кстати, Если всё же предположить что Проблемы с HDMI - то по LAN мадина должна хотя бы пинговаться....
(либо научитесь правильно формулировать свои мысли)
Ну вот, грубо говоря я использовал малину через другой пк с помощью ssh, значит нормально в этом плане все. А про мигать, розетки я менял, а адаптер из набора(5V, 2.5A

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 9:16 am

hommar wrote:
Sun May 20, 2018 5:31 am
тогда надо дальше подбирать параметры:

Code: Select all

hdmi_group=
hdmi_mode=
Поставил такие(подходят под мой экран):

Code: Select all

hdmi_group=1
hdmi_mode=4

Все равно не видит сигнал

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 5:26 pm

MaratG2 wrote:
Sun May 20, 2018 9:16 am
Поставил такие(подходят под мой экран):

Code: Select all

hdmi_group=1
hdmi_mode=4
Все равно не видит сигнал
А с чего ты взял что они подходят?

peppy.player
Posts: 110
Joined: Mon Mar 07, 2016 6:10 am

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 5:35 pm

Круг подозреваемых сужается :) Собственно их осталось трое - HDMI кабель, HDMI монитор/телевизор и переключатель входов на мониторе/телевизоре.

Ради интереса установил на своей малине 3B+ Stretch с десктопом и подключил к своему монитору. Всё сразу заработало без каких-либо дополнительных установок.

Удачи.

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 6:10 pm

hommar wrote:
Sun May 20, 2018 5:26 pm
MaratG2 wrote:
Sun May 20, 2018 9:16 am
Поставил такие(подходят под мой экран):

Code: Select all

hdmi_group=1
hdmi_mode=4
Все равно не видит сигнал
А с чего ты взял что они подходят?
Посмотрел по таблице раскладки, 720р + 60HZ

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 6:13 pm

peppy.player wrote:
Sun May 20, 2018 5:35 pm
Круг подозреваемых сужается :) Собственно их осталось трое - HDMI кабель, HDMI монитор/телевизор и переключатель входов на мониторе/телевизоре.
Спасибо, монитор NOOBS тоже по идеи без дополнительных настроек должен видеть, но мой не видит. Прямо сейчас пишу с Orange PI PC, его видит идеально, т.е. все более чем работоспособнее. Разве может малинка просто некоторые HDMI не детектить?
Last edited by MaratG2 on Mon May 21, 2018 3:10 am, edited 1 time in total.

peppy.player
Posts: 110
Joined: Mon Mar 07, 2016 6:10 am

Re: Нет изображения на мониторе(NO SIGNAL)

Sun May 20, 2018 6:42 pm

То-есть вы уверены что кабель и монитор в порядке? Orange работает через этот кабель и на этот монитор? И монитор вы включаете перед малиной?

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 3:04 am

peppy.player wrote:
Sun May 20, 2018 6:42 pm
То-есть вы уверены что кабель и монитор в порядке? Orange работает через этот кабель и на этот монитор? И монитор вы включаете перед малиной?
Да, уверен, Orange работает через этот же кабель и на этом же мониторе. Монитор включаю сам да, раньше, перед малиной

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 7:11 am

MaratG2 wrote:
Sun May 20, 2018 6:10 pm
Посмотрел по таблице раскладки, 720р + 60HZ
я почему спрашиваю, потому что у меня есть, назову это экраном,
Который показывает только когда hdmi_group=1, а есть где только когда hdmi_group=2,
даже если параметры вроде одинаковые.
Если поставить неправильную hdmi_group, то будет как раз NoSignal

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 10:30 am

hommar wrote:
Mon May 21, 2018 7:11 am
MaratG2 wrote:
Sun May 20, 2018 6:10 pm
Посмотрел по таблице раскладки, 720р + 60HZ
я почему спрашиваю, потому что у меня есть, назову это экраном,
Который показывает только когда hdmi_group=1, а есть где только когда hdmi_group=2,
даже если параметры вроде одинаковые.
Если поставить неправильную hdmi_group, то будет как раз NoSignal
hdmi_group=2 форматы не 16:9, они мне не подходят. У меня чистый 1280х720+60HZ
И там же еще hdmi_force_hotplug или как-то так, он сам вроде должен определять, у меня не определяет, или, например, NOOBS должен вообще без проблем изначально HDMI определять, у меня не определяет

hommar
Posts: 144
Joined: Sat Mar 25, 2017 1:55 pm
Location: Russia, Yekaterinburg

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 11:57 am

Должен, не должен - устроили ромашку здесь...
Всё эти параметры и нужны когда малина по какой-то причине не может определить.

PS я все больше склоняюсь что провод у вас не очень...

PPS там тоже есть 16:9

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 12:10 pm

hommar wrote:
Mon May 21, 2018 11:57 am
Должен, не должен - устроили ромашку здесь...
Всё эти параметры и нужны когда малина по какой-то причине не может определить.

PS я все больше склоняюсь что провод у вас не очень...

PPS там тоже есть 16:9
Поставил

Code: Select all

hdmi_group=2 
hdmi_mode=14
Все равно не видит

peppy.player
Posts: 110
Joined: Mon Mar 07, 2016 6:10 am

Re: Нет изображения на мониторе(NO SIGNAL)

Mon May 21, 2018 6:43 pm

Всё исправно, но не работает, странно. Я бы всё-таки посоветовал попробовать другой
кабель и монитор если вы ещё не пробовали. Ещё есть настройка config_hdmi_boost,
которая усиливает ток идущий через HDMI. Можно начать с 4 и увеличивать до 9.

Остаётся ещё всемирный разум, если вы им ещё не пользовались:
viewtopic.php?t=34061
https://elinux.org/R-Pi_Troubleshooting ... put_at_all

Если всё это не поможет тогда можете установить VNC сервер и запускать клиент/UI
на дугом компьютере. Перефразируя известного персонажа - сигнала нет, но вы держитесь :)

Удачи.

MaratG2
Posts: 12
Joined: Fri May 18, 2018 5:23 pm

Re: Нет изображения на мониторе(NO SIGNAL)

Tue May 22, 2018 1:30 pm

peppy.player wrote:
Mon May 21, 2018 6:43 pm
Всё исправно, но не работает, странно. Я бы всё-таки посоветовал попробовать другой
кабель и монитор если вы ещё не пробовали. Ещё есть настройка config_hdmi_boost,
которая усиливает ток идущий через HDMI. Можно начать с 4 и увеличивать до 9.

Остаётся ещё всемирный разум, если вы им ещё не пользовались:
viewtopic.php?t=34061
https://elinux.org/R-Pi_Troubleshooting ... put_at_all

Если всё это не поможет тогда можете установить VNC сервер и запускать клиент/UI
на дугом компьютере. Перефразируя известного персонажа - сигнала нет, но вы держитесь :)

Удачи.
Спасибо, попробую

Return to “Русский”