Page 1 of 1

watchdogが起動できない

Posted: Sat Jul 21, 2018 2:54 am
by isonbo
ラズパイ3でraspbian9.4を使っています。
watchdogを動かそうとしているのですが、
$ sudo systemctl start watchdog
のコマンドを入力すると、いつまでも帰ってきません。
ちなみに
$ sudo systemctl status watchdog
の出力は
● watchdog.service - watchdog daemon
Loaded: loaded (/lib/systemd/system/watchdog.service; enabled; vendor preset: enabled)
Active: inactive (dead)
となっています。
どなたか解決方法またはチャック項目を知っていれば教えて下さい。

Re: watchdogが起動できない

Posted: Fri Dec 21, 2018 2:08 am
by doublehp
Can't speak chineese, but I found a solution to this bug.

I had this bug on Ubuntu on Orange Pi zero.

The bug is explained here:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1448924
https://bugzilla.redhat.com/show_bug.cgi?id=1259816

I did not have it on this machine:

Code: Select all

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:        16.04
Codename:       xenial
but I have it here:

Code: Select all

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.5 LTS
Release:        16.04
Codename:       xenial
The solution was:

Code: Select all

echo "WantedBy=default.target" >> /lib/systemd/system/watchdog.service
systemctl daemon-reload
systemctl enable watchdog
reboot
# wait 2 mn, because it needs to reboot twice.
Before the fix:

Code: Select all

# systemctl status watchdog.service
â watchdog.service - watchdog daemon
   Loaded: loaded (/lib/systemd/system/watchdog.service; static; vendor preset: enabled)
   Active: inactive (dead)
After:

Code: Select all

# systemctl status watchdog.service
â watchdog.service - watchdog daemon
   Loaded: loaded (/lib/systemd/system/watchdog.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-12-21 03:02:14 CET; 58s ago
  Process: 1122 ExecStart=/bin/sh -c [ $run_watchdog != 1 ] || exec /usr/sbin/watchdog $watchdog_options (code=exited, status=0/SUCCESS)
  Process: 1120 ExecStartPre=/bin/sh -c [ -z "${watchdog_module}" ] || [ "${watchdog_module}" = "none" ] || /sbin/modprobe $watchdog_module (code=exited, status=0/SUCCESS)
 Main PID: 1126 (watchdog)
   CGroup: /system.slice/watchdog.service
           ââ1126 /usr/sbin/watchdog

Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: int=1s realtime=yes sync=no soft=no mla=5 mem=0
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: ping: no machine to check
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: file: /var/log/syslog:0
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: pidfile: no server process to check
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: interface: no interface to check
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: temperature: maximum = 80
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: temperature: /sys/class/thermal/thermal_zone0/temp
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: test=none(0) repair=none(0) alive=/dev/watchdog heartbeat=none to=...ce=no
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: watchdog now set to 10 seconds
Dec 21 03:02:14 opi-06-app-c13 watchdog[1126]: hardware watchdog identity: sunxi-wdt
Hint: Some lines were ellipsized, use -l to show in full.

Re: watchdogが起動できない

Posted: Tue Dec 25, 2018 2:22 pm
by masafumi_ohta
isonbo wrote:
Sat Jul 21, 2018 2:54 am
ラズパイ3でraspbian9.4を使っています。
watchdogを動かそうとしているのですが、
$ sudo systemctl start watchdog
のコマンドを入力すると、いつまでも帰ってきません。
ちなみに
$ sudo systemctl status watchdog
の出力は
● watchdog.service - watchdog daemon
Loaded: loaded (/lib/systemd/system/watchdog.service; enabled; vendor preset: enabled)
Active: inactive (dead)
となっています。
どなたか解決方法またはチャック項目を知っていれば教えて下さい。
太田です。すいません、かなり多忙にてチェックが遅れました。

このあたり確認されてますか?
viewtopic.php?t=147501

太田

Re: watchdogが起動できない

Posted: Tue Dec 25, 2018 2:23 pm
by masafumi_ohta
doublehp wrote:
Fri Dec 21, 2018 2:08 am
Can't speak chineese, but I found a solution to this bug.
Thanks information doublehp it is Japanese pages not Chinese :-)