Page 2 of 2

Re: Why are Raspberry Pi still using Java 8 when Java 11 is available?

Posted: Tue Apr 30, 2019 8:58 am
by ShiftPlusOne
alnaseh wrote:
ShiftPlusOne wrote: I'll admit I haven't checked, but I'd be very surprised if openjdk 11 didn't work on a pi 0.
we already killed this topic here:
viewtopic.php?t=196887
Just tried it on a pi zero running buster:
Error occurred during initialization of VM
Server VM is only supported on ARMv7+ VFP
As promised, I'm very surprised.

Re: Why are Raspberry Pi still using Java 8 when Java 11 is available?

Posted: Thu Jul 04, 2019 10:21 am
by bullen
Ok, so what is the fix?

Edit: openjdk-11-jre-zero apparently, if you want speed use an old oracle-java8-jdk because it was compiled with soft-float for ARMv6.

But but but, how does one fix a broken installation?

This is so messy.