LeftyF
Posts: 7
Joined: Mon Sep 23, 2013 5:59 pm

Running jar files returns nothing?

Wed Jul 12, 2017 11:07 pm

I'm having a very odd issue on my Pi. First off, I'm running a Raspberry Pi 3 B. OS version:
Linux 4.9.28-v7+ #998 SMP Mon May 15 16:55:39 BST 2017 armv7l GNU/Linux
Java version:
openjdk version "1.8.0_40-internal"
OpenJDK Runtime Environment (build 1.8.0_40-internal-b04)
OpenJDK Zero VM (build 25.40-b08, interpreted mode)

I am trying to run the Java version of metabase, but when I try and start it I'm getting no response at all and nothing writes to the log. Trying to run it manually via "java -jar metabase.jar" from the directory where the jar file is located just hangs and returns no errors or any other response. I get the same response trying to run any jar files. I can run this same jar successfully on another machine running Ubuntu and the same Java version. I've tried several different versions of the JRE with the same result. Any help would be appreciated!

LeftyF
Posts: 7
Joined: Mon Sep 23, 2013 5:59 pm

Re: Running jar files returns nothing?

Thu Jul 13, 2017 7:36 pm

OK, I'm a little rusty with my java skills but I finally tried running the startup command with "-verbose" and I see it's loading the classes for the jar, but it's just taking ages to do it. The output looks like this:

[snip]

[Loaded clojure.lang.LispReader$RegexReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$FnReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$SetReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$EvalReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$UnreadableReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$DiscardReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.LispReader$ConditionalReader from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.APersistentSet from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.PersistentHashSet from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.ITransientSet from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.ATransientSet from file:/opt/metabase/metabase.jar]
[Loaded clojure.lang.PersistentHashSet$TransientHashSet from file:/opt/metabase/metabase.jar]
[Loaded sun.misc.Launcher$BootClassPathHolder from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.misc.Launcher$BootClassPathHolder$1 from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded java.io.FileReader from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded java.net.URLClassLoader$2 from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded java.net.JarURLConnection from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.JarURLConnection from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.URLJarFile$URLJarFileCloseController from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.JarFileFactory from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.URLJarFile from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.URLJarFile$URLJarFileEntry from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Loaded sun.net.www.protocol.jar.JarURLConnection$JarURLInputStream from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]
[Unloading class sun.reflect.GeneratedConstructorAccessor1 0x65885548]
[Loaded java.util.HashMap$KeySet from /usr/lib/jvm/java-8-openjdk-armhf/jre/lib/rt.jar]

[snip]

So I'll just have to be patient and see if it finally loads correctly. Otherwise this may not be a good platform for metabase (at least in java form).

Return to “Java”

Who is online

Users browsing this forum: No registered users and 3 guests