zugdu39z
Posts: 20
Joined: Fri Jun 05, 2015 9:25 pm

[SOLVED]A fatal error Java Runtime Environment .v 6.0_35-b35

Wed Aug 12, 2015 1:17 pm

Hi!

Till two days I will get the failure into my console.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (os_linux_zero.cpp:285), pid=13567, tid=1374155888
# fatal error: caught unhandled signal 11
#
# JRE version: 6.0_35-b35
# Java VM: OpenJDK Zero VM (23.25-b01 mixed mode linux-arm )
# Derivative: IcedTea6 1.13.7
# Distribution: Debian GNU/Linux 7.8 (wheezy), package 6b35-1.13.7-1~deb7u1+rpi1
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/pi/hs_err_pid13567.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# http://icedtea.classpath.org/bugzilla
#
Here are the contend inside from /ome/pi/hs_err_pid13567.log http://up.picr.de/22800879qg.jpg

Please help me!
Last edited by zugdu39z on Thu Aug 13, 2015 4:47 pm, edited 1 time in total.

User avatar
xranby
Posts: 540
Joined: Sat Mar 03, 2012 10:02 pm
Contact: Website

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Wed Aug 12, 2015 4:24 pm

If there is a reliable way to reproduce the bug then it can get studied. By reading your log-file all I can see is that you have been running jdownloader for 2 days. Unfortunally there is no "core" file generated, that can be used to attach a debugger in order to find out why the program crashed.

You can try using a different JVM, right now you use openjdk-6
if you update to openjdk-7-jre then you will use a more up to date java virtual machine

if you have installed many java versions on one pi then you can use the

Code: Select all

update-java-alternatives -l
tool to list all installed variants
and use

Code: Select all

sudo update-java-alternatives -s java-1.7.0-openjdk-armhf
to switch the default java on your Raspbian system.
Xerxes Rånby @xranby I once had two, then I gave one away. Now both are in use every day!
twitter.com/xranby

zugdu39z
Posts: 20
Joined: Fri Jun 05, 2015 9:25 pm

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Wed Aug 12, 2015 6:10 pm

Hi thanks for reply!!

I have with the order

Code: Select all

update-java-alternatives -l
now 4 versions installed.

Code: Select all

java-1.6.0-openjdk-armhf 1057 /usr/lib/jvm/java-1.6.0-openjdk-armhf
java-1.7.0-openjdk-armhf 1043 /usr/lib/jvm/java-1.7.0-openjdk-armhf
jdk-7-oracle-armhf 317 /usr/lib/jvm/jdk-7-oracle-armhf
jdk-8-oracle-arm-vfp-hflt 318 /usr/lib/jvm/jdk-8-oracle-arm-vfp-hflt
I don't know how!

the order

Code: Select all

sudo update-java-alternatives -s java-1.7.0-openjdk-armhf
gives me that as answer:
pi@WoW ~ $
update-alternatives: error: no alternatives for jcmd
update-alternatives: error: no alternatives for jhat
update-alternatives: error: no alternatives for jrunscript
update-alternatives: error: no alternatives for mozilla-javaplugin.so
update-alternatives: error: no alternatives for schemagen
update-alternatives: error: no alternatives for wsgen
update-alternatives: error: no alternatives for wsimport
update-alternatives: error: no alternatives for xjc
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/appletviewer
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/extcheck
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/idlj
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jarsigner
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jar
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/javac
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/javadoc
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/javah
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/javap
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jcmd
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jconsole
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jdb
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jhat
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jinfo
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jmap
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jps
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jrunscript
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jsadebugd
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jstack
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jstatd
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/jstat
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/native2ascii
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/rmic
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/schemagen
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/serialver
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/wsgen
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/wsimport
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/xjc
update-java-alternatives: plugin alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/jre/lib/arm/IcedTeaPlugin.so
should I deinstall the other version and should I have only the version

Code: Select all

java-1.7.0-openjdk-armhf 1043 /usr/lib/jvm/java-1.7.0-openjdk-armhf


installed?

User avatar
xranby
Posts: 540
Joined: Sat Mar 03, 2012 10:02 pm
Contact: Website

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Wed Aug 12, 2015 11:06 pm

zugdu39z wrote:

Code: Select all

sudo update-java-alternatives -s java-1.7.0-openjdk-armhf
gives me that as answer:
...
update-alternatives: error: no alternatives for mozilla-javaplugin.so
...
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/appletviewer
...
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/bin/javac
...
update-java-alternatives: plugin alternative does not exist: /usr/lib/jvm/java-7-openjdk-armhf/jre/lib/arm/IcedTeaPlugin.so
the errors seen above is "ok"
the reason is that you have the openjdk-7 runtime JRE and the JRE do not contain the many java developer tools such as the appletviewer and javac .
the missing webbrowser java plugins can be obtained if you install the icedtea-7-plugin

you can get all the tools and plugins in the list if you install openjdk-7-jdk and icedtea-7-plugin.

The JRE that you have installed is enough if you simply want to run applications such as jdownloader.
zugdu39z wrote: should I deinstall the other version and should I have only the version

Code: Select all

java-1.7.0-openjdk-armhf 1043 /usr/lib/jvm/java-1.7.0-openjdk-armhf

installed?
No, you do not need to uninstall the other versions.
Try switch version if you run into issues with jdownloader.
Xerxes Rånby @xranby I once had two, then I gave one away. Now both are in use every day!
twitter.com/xranby

zugdu39z
Posts: 20
Joined: Fri Jun 05, 2015 9:25 pm

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Thu Aug 13, 2015 5:53 am

Hi there!

Now I have installed the two things here:

Code: Select all

apt-get install openjdk-7-jdk
and

Code: Select all

apt-get install icedtea-7-plugin
and made a fresh restart.

Now it will work to extract the downloads in my Jdownloader after I push the button under downloads -> package -> actions -> extract now.

But automatic it dosn't work.

I will have a look at the message of my java in the console and if the Jdownloader will work 24 h in a day without a failure.

Here are my comments in the console:

http://up.picr.de/22806522ai.png

User avatar
xranby
Posts: 540
Joined: Sat Mar 03, 2012 10:02 pm
Contact: Website

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Thu Aug 13, 2015 1:52 pm

zugdu39z wrote:Now it will work to extract the downloads in my Jdownloader after I push the button under downloads -> package -> actions -> extract now.

But automatic it dosn't work.
No idea, you have to talk to the jdownload developers
you should provide a step by step instruction how to reproduce the "bug" that "automatic unpacking do not work"
so that the developers can reproduce and observe the same issue.
http://jdownloader.org/knowledge/wiki/support/bugreport
zugdu39z wrote: I will have a look at the message of my java in the console and if the Jdownloader will work 24 h in a day without a failure.
it will most likely working work fine now.

zugdu39z wrote: Here are my comments in the console:

http://up.picr.de/22806522ai.png
All ok! normal output seen when you install new packages.
Xerxes Rånby @xranby I once had two, then I gave one away. Now both are in use every day!
twitter.com/xranby

zugdu39z
Posts: 20
Joined: Fri Jun 05, 2015 9:25 pm

Re: A fatal error Java Runtime Environment .v 6.0_35-b35

Thu Aug 13, 2015 4:47 pm

Hi!

It seems that in the moment all is okay with jdownloader and the extract prozess works by now automatic.

Thank you for your help!

Kind regards!

Return to “Java”