hb9dni
Posts: 3
Joined: Mon Oct 27, 2014 6:46 am

Far partire WiFi all'avvio

Mon Oct 27, 2014 6:54 am

Buongiorno a tutti.

Sono nuovo sia di Raspberry che di questa community. Complimenti a tutti specialmente alla sezione Italiana che trovo molto buona.

Ho un Raspberry PI con su l'immagine presa dal sito http://www.westerndstar.co.uk/ e funziona benissimo.

Ho messo una Key USB WiFi, la Zyxel NWD2105 e funziona benissimo. Ho provato col programma WiFi Config e mi connetto piu' o meno semplicemente alla rete di casa e al mio HotSpot Iphone.
la cosa che pero' non va, è l'avvio della connessione WiFi quando avvio il Raspberry..
Vorrei che si avviasse la connessione WiFi quando l'accendo.. altrimenti quando sto in Auto e non ho nulla per entrare nel RB (Tastiera, monitor, ecc...) non posso usare il mio bel giocattolo.
Anticipo che sono un Programmatore Microsoft e di Linux ne so proprio pochissimo... tanto per avviare un programma...e nulla di piu...

Grazie per eventuali aiuti.

Saluti da Stefano P.

Guerriky
Posts: 42
Joined: Thu Jun 12, 2014 3:55 pm

Re: Far partire WiFi all'avvio

Mon Oct 27, 2014 4:31 pm

Ciao,
mi pare strano che non parta da sola.

La regola, con Debian, è: se c'è, connettiti.

In pratica, se il sistema ha tutte le informazioni necessarie a far partire la connessione wifi, la fa partire.

C'è, però, una linea nel file di interfaccia, che controlla la connessione automatica.

Edita quel file:

Code: Select all

nano /etc/network/interfaces
E cerca la linea:

Code: Select all

auto wlan0
Se non c'è, inseriscila prima di:

Code: Select all

iface wlan0 inet ...
NOTE:
La tua interfaccia di rete potrebbe non chiamarsi wlan0, orientati con il prefisso wlan*.
I "..." dopo "iface wlan0 inet" in genere rappresentano la stringa "manual", ma non è detto.

Ciao,
Riccardo

hb9dni
Posts: 3
Joined: Mon Oct 27, 2014 6:46 am

Re: Far partire WiFi all'avvio

Mon Oct 27, 2014 5:54 pm

Grazie per la risposta...
editando il file ho questo testo:
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

ho notato anche che non ho i permessi di scrittura sul file..eppure sono entraro con la password "raspberry" che penso sia dell'utente root
Grazie...

hb9dni
Posts: 3
Joined: Mon Oct 27, 2014 6:46 am

Re: Far partire WiFi all'avvio

Mon Oct 27, 2014 8:41 pm

facendo alcune prove, ho notato che uso il sistema non come root e quindi noto vari file in solo scrittura.

Leggendo qua e là sul web, vedo che chi ha usato questi sistemi, ha aggiornato i driver delle Key USB WiFi e poi l'ha usate... Io ho semplicemente collegato la Key, usato il programma WiFi Config... ho impostato la rete WiFi...salvato la configurazione... e basta..

Forse l'aggiornamento dei driver abilitano la connessione automatica?

Come si aggiornano i driver?

sono Riuscito a mettere la riga "auto wlan0" ma non fa nulla all'avvio.

Grazie

naftaism
Posts: 84
Joined: Fri Feb 22, 2013 8:53 pm

Re: Far partire WiFi all'avvio

Sun Nov 09, 2014 10:13 am

Ciao, prova a cambiare :

Code: Select all

iface wlan0 inet manual
in:

Code: Select all

iface wlan0 inet auto

Return to “Italiano”