Page 1 of 1

transmission-daemon non carica file settings?

Posted: Wed Feb 06, 2013 9:49 pm
by aka399
ciao, non riesco capire ma sembra quasi che fermando il demone, modificando settings.conf e rilanciando il servizio le modifiche apportate non vengano prese in considerazione. ho impostato false sulla whitelist che, a logica, dovrebbe permettere ad ogni ip di usare il demone ma l'errore che ricevo è il 403 forbidden ip non autorizzato. allora provo a inserire l'ip della macchina da cui accedo e metto true sulla withelist. niente. tant'è che riesco ad accedere solo dando transmission-daemon -a 196.168.0.4 cioè permettendo di volta in volta alla macchina l'accesso. ho provato a stopparlo e rilanciarlo anche con killall e force-reload ma non cambia nulla..cosa sbaglio? ogni comando con sudo anteposto.

Re: transmission-daemon non carica file settings?

Posted: Wed Feb 06, 2013 9:57 pm
by oozic
al momento non mi viene in mente niente.
ti do comunque un consiglio: sarebbe più ordinato se tu usassi un topic già esistente che riguarda magari lo stesso argomento o molto simile.

se per ogni minima richiesta apri un topic, va a finire che si riempie la prima pagina di tutte queste richieste, che spesso e volentieri possono essere raggruppate in altri topic, per poter dare spazio e visibilità anche ad altre persone, e facilitare la ricerca di soluzioni per chi ha problemi simili che vede subito in prima pagina una serie di topic che toccano argomenti diversi :)

Re: transmission-daemon non carica file settings?

Posted: Fri Feb 08, 2013 4:40 pm
by aka399
seguirò il consiglio ma dato che ormai è aperto....qualcuno mi da una mano?

Re: transmission-daemon non carica file settings?

Posted: Fri Feb 08, 2013 5:22 pm
by 3-4-Fun
Questo è il mio settings:

root@Archer:/etc/transmission-daemon# cat settings.json | grep whitelist
"rpc-whitelist": "127.0.0.1,192.168.1.*",
"rpc-whitelist-enabled": true,

Magari è solo una questione di sintassi. Ho avuto problemi anche io quando misi la whitelist senza racchiuderle tra ""...

Ciao

Re: transmission-daemon non carica file settings?

Posted: Sat Feb 09, 2013 1:50 pm
by aka399
lo terrò monitorato ma forse il problema era lo spazio tra 127.0.0.1 e 192.168.0.*
prima:

Code: Select all

"rpc-whitelist": "127.0.0.1, 192.168.0.*", 
"rpc-whitelist-enabled": true, 
ora

Code: Select all

"rpc-whitelist": "127.0.0.1,192.168.0.*", 
"rpc-whitelist-enabled": true, 
mah!

Re: transmission-daemon non carica file settings?

Posted: Thu Feb 14, 2013 6:56 pm
by Mepherotus
Ci ho perso anch'io un po di tempo finchè non ho letto il "README.json" =P
/etc/transmission-daemon/README.json


Currently transmission overwrites the settings.json configuration file
on exit. The daemon can be instructed to reload the config with a SIGHUP,
or
# invoke-rc.d transmission-daemon reload

Otherwise changes made manually to the file while the daemon is running
will be silently overwritten on exit.

Re: transmission-daemon non carica file settings?

Posted: Mon Apr 01, 2013 9:02 pm
by aka399
ho un problema: ora non riesco a salvare il settings.json, mi dice spazio esaurito. il file, non so per quale motivo, è vuoto e non riesco più ad usare transmission-daemon.

Re: transmission-daemon non carica file settings?

Posted: Tue Apr 02, 2013 3:17 pm
by oozic
prova a digitare

Code: Select all

df -h
e posta il risultato.

Re: transmission-daemon non carica file settings?

Posted: Thu Apr 04, 2013 7:45 pm
by aka399

Code: Select all

pi@raspberrypi ~ $ df -h
File system     Dim. Usati Dispon. Uso% Montato su
rootfs          3,0G  3,0G       0 100% /
/dev/root       3,0G  3,0G       0 100% /
devtmpfs        220M     0    220M   0% /dev
tmpfs            44M  364K     44M   1% /run
tmpfs           5,0M     0    5,0M   0% /run/lock
tmpfs            88M     0     88M   0% /run/shm
/dev/mmcblk0p1   56M   17M     40M  30% /boot
/dev/sda1       932G  585G    348G  63% /media/Dati
tmpfs            88M     0     88M   0% /tmp
/dev/mmcblk0p3   12G  511M     12G   5% /media/incomplete

Re: transmission-daemon non carica file settings?

Posted: Thu Apr 04, 2013 8:08 pm
by oozic
ti sei risposto da solo :)

Re: transmission-daemon non carica file settings?

Posted: Thu Apr 04, 2013 8:11 pm
by aka399
vero, il problemone one one è che non ricordo la pwd di root e non posso accedere per vedere cos'ha insozzato il tutto. che faccio, piallo?

Re: transmission-daemon non carica file settings?

Posted: Thu Apr 04, 2013 8:16 pm
by oozic
come ti dicevo nell'altro post per la password credo tu debba piallare.
ci sono dei modi di recuperare la password su altri sistemi linux ma prevedono di usare live cd di ricovero o fare boot con un altro os.
il problema del raspi è che il boot è legato comunque alla scheda sd.

puoi provare a inserire la sd in un lettore e se hai un altro os linux puoi recuperare un pò di dati tipo impostazioni o file che ti servono.

Re: transmission-daemon non carica file settings?

Posted: Fri Apr 05, 2013 10:54 am
by aka399
per ora ho risolto in modo brutale ma non piallando, ho tolto la SD e inserita nel pc principale (debian) e da lì cancellato il contenuto di root (due film finiti lì per errore). Ora tutto ok, riscritto file settings e ripreso a funzionare tutto.

Re: transmission-daemon non carica file settings?

Posted: Wed Jul 31, 2013 9:28 am
by Lord Router
forse andava bene anche questa soluzione http://www.gianluzan.it/?p=150 ...