paolosr81
Posts: 2
Joined: Fri Jan 18, 2019 1:21 pm

problema undervoltage detected

Fri Jan 18, 2019 1:26 pm

Salve a tutti , sono Paolo e sono nuovo sia del forum che come utente di Raspberry.
Ho una p3 model b ,più o meno da quando l'ho acquistata - ad inizio estate - mi da un segnale di undervoltage ( si accende il lampo giallo e , quando esco da retropie , prima che la rb si spenga, tra le varie scritte mi compare" undervoltage detected etc.." ).
Uso un alimentatore da 5V e 2.5 ampere e nella raspy ho installato retropie 4.4.4 .

Oggi, con un multimetro, ho misurato la tensione all'ingresso sui pad pp3 e pp7 nel retro della RB.
Ebbene , con il sistema operativo avviato la tensione oscillava tra 4,92v e 5v, ma dopo lo shutdown (ovviamente sempre con l'alimentazione accesa ) la tensione sugli stessi pad era fissa a 5.15 v.
Alla Raspeberry durante il test erano collegati un dualshock via bluethoot, una tastiera usb ed una ventolina (che girava anche dopo lo shutdown di retropie, quindi escluderei sia la causa ).

Quello che mi chiedo è : visto che a sistema operativo "spento" la tensione in ingresso era stabile e sempre sui 5.15v può darsi che la causa sia comunque l'alimentatore scadente? O magari è retropie ? O invece è la raspeberry che è difettosa ?

nicolap8
Posts: 329
Joined: Mon Mar 13, 2017 9:45 pm

Re: problema undervoltage detected

Sun Jan 20, 2019 5:48 pm

Verificala tensione con un secondo multimetro, magari con uno "tarato" in qualche modo: con le tensioni in gioco il margine di errore è piccolo.
Poi sarebbe da verificare la rumorosità dell'alimentazione, con un oscilloscopio.
Purtroppo molti alimentatori hanno una scarsa qualità.
Talvolta un condensatore sull'ingresso migliora le cose ma metterlo alla cieca può anche peggiorarle.
N

paolosr81
Posts: 2
Joined: Fri Jan 18, 2019 1:21 pm

Re: problema undervoltage detected

Thu Jan 24, 2019 4:33 pm

Grazie, ma fino a poco fa (ho cercato su google) nemmeno sapevo cosa fosse un oscilloscopio e come fosse fatto :) :) .
Ho comunque notato che il problema si verifica quando inserisco le periferiche usb a raspberry accesa .
Se le inserisco da spenta, dopo l'avvio la posso usare tranquillamente senza che si verifichi nessun undervoltage (salvo con l'hd esterno da 2.5" , con quello si verifica in ambedue i casi) .
Ho, per la cronaca, anche cambiato s.o. (adesso ho OSMC) ma nulla cambia .
Proverò a vedere se capito un ali originale, a sto punto.

nicolap8
Posts: 329
Joined: Mon Mar 13, 2017 9:45 pm

Re: problema undervoltage detected

Fri Jan 25, 2019 10:42 pm

Io proverei un alimentatore diverso (e di qualità certa).
N

willy_pinguino
Posts: 687
Joined: Sun Jan 22, 2017 9:11 pm

Re: problema undervoltage detected

Sun Apr 21, 2019 1:35 pm

concordo sull'alimentatore, ma starei anche attento al consumo della ventolina... visto che il 3B non scalda poi tanto e che ora ci giochi solamente, hai provato a staccare la ventolina?

comunque sia, non aspettarti che il raspberry sia in grado di alimentare un HD esterno autoalimentato, l'emissione in ampere delle porte usb del raspi è comunque inferiore agli 800mA quindi insufficente per quasi qualunque HD usb autoalimentato che tu possa trovare in commercio che di solito chiedono da 1A in su.

la soluzione più semplice secondo me sarebbe nel comprare un HUB USB con alimentatore esterno da almeno 2,5A e tutte le periferiche tranne forse la tastiera, collegarle al raspberry tramite l'HUB, mantenendo ovviamente l'alimentatore separato per il raspberry (non far alimentare il raspberry all'HUB o potresti andare incontro a problemi ben più gravi e se l'HUB fosse di bassa qualità potresti anche bruciare tutto, raspberry compreso

Rubert
Posts: 1
Joined: Thu May 30, 2019 5:54 am

Re: problema undervoltage detected

Thu May 30, 2019 6:01 am

Ciao, ho avuto il tuo stesso problema e la causa era il cavo usb usato, di qualità infima; probabilmente la caduta di tensione era troppa. Sostituito il cavo e non ho avuto più quei problemi. Ovviamente parlo di un alimentatore il cui "trasformatore" aveva la presa usb per collegamento generico.

R.

Return to “Italiano”