User avatar
aka399
Posts: 59
Joined: Tue Aug 07, 2012 3:15 pm

mount HD 2,5"

Sat Jun 16, 2018 10:14 am

Ciao,
dovrei montare un HD esterno da 2,5" non alimentato al mio RPI ma non viene listato con fdisk (c'è solo la SD card) mentre risulta attaccato a USB (JMicron USA):

Code: Select all

[email protected] ~ $ sudo fdisk -l

Disk /dev/mmcblk0: 7948 MB, 7948206080 bytes
4 heads, 16 sectors/track, 242560 cylinders, total 15523840 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000981cb

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1            8192      122879       57344    c  W95 FAT32 (LBA)
/dev/mmcblk0p2          122880    15523839     7700480   83  Linux
[email protected] ~ $ lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 152d:0567 JMicron Technology Corp. / JMicron USA Technology Corp.
[email protected] ~ $


[email protected] ~ $ dmesg |tail
[  262.226471] sd 0:0:0:0: [sda] ASC=0x44 <<vendor>>ASCQ=0x81
[  442.231660] sd 0:0:0:0: timing out command, waited 180s
[  622.254081] sd 0:0:0:0: timing out command, waited 180s
[  802.276715] sd 0:0:0:0: timing out command, waited 180s
[  802.276856] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=0x08
[  802.276890] sd 0:0:0:0: [sda] Sense Key : 0x4 [current]
[  802.276915] sd 0:0:0:0: [sda] ASC=0x44 <<vendor>>ASCQ=0x81
[  982.299912] sd 0:0:0:0: timing out command, waited 180s
[ 1162.326517] sd 0:0:0:0: timing out command, waited 180s
[ 1162.326663] sd 0:0:0:0: [sda] Attached SCSI disk
sapete indicarmi la procedura per poter montare e usare il disco?

Grazie e saluti a tutti.

User avatar
m3nhir
Posts: 117
Joined: Sat Mar 21, 2015 11:53 am

Re: mount HD 2,5"

Sat Jun 16, 2018 2:55 pm

E possibile che l'alimentazione che fornisce il raspi non sia sufficiente per un corretto funzionamento dell'HD, da qui il fatto che fdisk non lo rilevi. Probabilmente è possibile leggere il dispositivo (per questo viene rilevato come attaccato, ma non sia possibile poi leggerne il contenuto (partizioni e relative tabelle etc:) prova a collegare l'HD usando un HUB usb alimentato, in modo che l'HD riceva una sufficiente alimantazione da questo ed il raspi possa usarlo correttamente. Era capitato anche a me e cosi ho risolto.

User avatar
aka399
Posts: 59
Joined: Tue Aug 07, 2012 3:15 pm

Re: mount HD 2,5"

Sat Jun 16, 2018 3:18 pm

Grazie, proverò senz'altro.

Return to “Italiano”

Who is online

Users browsing this forum: No registered users and 2 guests