SSilver2k2
Posts: 179
Joined: Wed Jun 06, 2012 1:51 am
Location: United States
Contact: Website AOL

PiPlay running on Pi2

Sun Feb 08, 2015 7:30 am

Hey All,
Just got my Pi2 earlier today. Been testing my distro PiPlay on it and checking that everything works. I'm having some more people test it out, but its looking solid and I should be releasing the image this week.

https://www.youtube.com/watch?v=IBubgnwDqdY

If you are brave and don't mind messing up your install, you can try out a preview using these scripts:

Not for the faint of heart! Testers only!
Installer

Code: Select all

wget http://pimame.org/installer_beta.sh
bash installer_beta.sh
Updater (if running an earlier version of PiPlay)

Code: Select all

wget http://pimame.org/update_beta.sh
bash update_beta.sh
My blog of various geeky things - http://blog.sheasilverman.com
PiPLAY - http://piplay.org
DeskCade.com - Mini Raspberry Pi Arcade Cabinet

Bobg2007
Posts: 9
Joined: Wed Jul 04, 2012 12:35 pm

Re: PiPlay running on Pi2

Sun Feb 08, 2015 11:09 pm

Hi,

I've given this a try.

I had already installed rasbpian via Noob, then all I did was download the installed script as describe and run it.

It seemed to install to a point in which is complained about the zxspectrum folder not existing. Unfortunately I didn't get a copy of all of the output, however I will try again and post the output here if you think it would help.

Many thanks for all of your hard work on this.

Digiduck
Posts: 5
Joined: Sun Dec 02, 2012 6:07 am

Re: PiPlay running on Pi2

Mon Feb 09, 2015 2:52 pm

The installation script seems to work correctly, never the less after reboot i get the following message:

Code: Select all

alsactl: load_state:1647 Cannot open /home/pi/pimame/config/piplay-sound.state for reading: No such file or directory
Found hardware: "bcm2835" "Broadcom Mixer" "" "" ""
Hardware is initialized using generic method
Traceback (most recent call last):
  File "launchmenu.py", line 69, in <module>
    main()
  File "launchmenu.py", line 15 , in main
    cfg = PMCfg()
  File "/home/pi/pimame/pimame-menu/pmmenu/pmconfig.py:, line 24, in_init_
    self.ocal_db = sqlite3.connect(path)
sqlite3.OperationalError: unable to open database file
this was after a fresh installation of the latest raspbian release.
overclock 1000 500 2 volt
gpu mem 256

used
sudo bash installer_beta.sh

A302637
Posts: 3
Joined: Fri Feb 20, 2015 9:24 pm

Re: PiPlay running on Pi2

Fri Feb 20, 2015 9:28 pm

I ran into the exact same error on my Pi2, any luck finding a solution?

A302637
Posts: 3
Joined: Fri Feb 20, 2015 9:24 pm

Re: PiPlay running on Pi2

Fri Feb 20, 2015 11:48 pm

Are you by any chance using a 16GB SD Card? I reinstalled from scratch and paid closer attention to the messages on the first boot after the piplay install. I see lots of messages like the following:
mmcblk0: unknown error -5 sending read/write command, card status 0x900
udevd[xxx]: timeout: killin `udisks-part-id /dev/loopx` [xxx]

I'm wondering if there is some bug relating to the SD card I'm using in the Pi2

BHerch
Posts: 1
Joined: Mon Feb 23, 2015 2:50 am

Re: PiPlay running on Pi2

Mon Feb 23, 2015 3:01 am

I am running in to the same issue running a Pi2 with a 32g card and a fresh install of the piplay-0.8-beta8. "cannot open /home/pi/pimame/config/piplay-sound."

A302637
Posts: 3
Joined: Fri Feb 20, 2015 9:24 pm

Re: PiPlay running on Pi2

Mon Feb 23, 2015 9:22 pm

Ok so today I bought an 8GB (still class 10) card and it worked fine.

russywhite
Posts: 1
Joined: Sun Mar 01, 2015 4:24 pm

Re: PiPlay running on Pi2

Sun Mar 01, 2015 4:26 pm

I have the same problem,bought a 8gb SD today and still the same issue. Strange that some work and some do not.

Return to “Gaming”