Posts: 20
Joined: Thu Jul 19, 2012 12:11 pm

PiFBA on Pi 2

Sun Feb 08, 2015 12:14 am

I've been trying to enable the CPS3 support in FBA when building for the Pi 2 but I'm not having much luck.

I can get FBA to acknowledge it supports the CPS3 roms, and include the CPS3 roms in it's gamelist output, but as soon as it starts to load a CPS 3 rom it throws a generic memory error and exits. Has anyone else had any luck enabling the CPS 3 drivers?

I'm not sure if the CPS3 modules in the PiFBA source code even work, so I can't tell if I'm just not linking them properly or if they just don't work :cry:

Update: With a little bit more of a play I was able to get to play, though I'm still without audio.
Found 1 joysticks
Attempt to initialise 'Street Fighter III: New Generation (Asia 970204, NO CD)'
Screen Size: 384 x 224
sfiii_asia_nocd.29f400.u2 ... 512Kb BIOS (OK)
10 ... 8192Kb program (OK)
30 ... 8192Kb graphics (OK)
31 ... 8192Kb graphics (OK)
40 ... 8192Kb graphics (OK)
41 ... 8192Kb graphics (OK)
50 ... 4096Kb graphics (OK)
Lets go!
ALSA: Period size: 736 frames
ALSA: Buffer size: 2940 frames
ALSA: Period size: 2944 bytes
ALSA: Buffer size: 11760 bytes
Finished emulating
---- Shutdown Finalburn Alpha plus ----

ALSA: FIFO Underrun: 618
ALSA: FIFO Overrun: 0
ALSA: Snd Underrun 0
I compiled with these options and got a mostly solid 60fps with only the occasional dip to the mid 50's (within XWindows!), so it certainly has the power for fluid CPS 3 emulation at stock speeds.
-mcpu=cortex-a7 -mfpu=neon-vfpv4 -mfloat-abi=hard

User avatar
Posts: 336
Joined: Thu May 22, 2014 8:55 am
Location: France
Contact: Website

Re: PiFBA on Pi 2

Sun Feb 08, 2015 1:20 pm

Nope the cps3 core il not supported by pifba.
Did you managed to run cps2 or neogeo games with this configuration?

Posts: 20
Joined: Thu Jul 19, 2012 12:11 pm

Re: PiFBA on Pi 2

Sun Feb 08, 2015 3:13 pm

The CPS3 core is working for me, I've been playing the No-CD version of Street Fighter III: New Generation with it. It has no audio when playing CPS3 (but no error) so I think there's something else missing in the config or makefile. It does require some very old and pretty obscure roms though, you can see the details for the cps3 roms it's expecting in "burn/ cps3/d_cps3.cpp".

NeoGeo and CPS 2 play perfectly with those configs too with no performance hitches in anything I've tried.

Update: I had a bit more of a play and got all the CPS 3 games working (just the "No CD" versions) but they still have no audio. From what I can tell, the CPS3 audio emulation is actually working fine, it's the Ras Pi/GP2X alsa wrapper that isn't connected to FBA's internal CPS3 driver, so both appear to be fine with no errors but still no audio in just CPS3 games. I'll have a better look over the next few days at how that wrapper hooks in to the other drivers and hopefully it should be straight forward plugging the CPS3 audio into it.

Posts: 1
Joined: Fri Jan 27, 2017 7:30 am

Re: PiFBA on Pi 2

Fri Jan 27, 2017 7:32 am

Can you tell me how to play cps3 games on pifba pls? I have used lr-fba, but since i have a rp1, it runs pretty bad, thanks in advice!

Return to “Gaming”