OpenTyrian bootable SD image


4 posts
by InsanePie » Tue Dec 30, 2014 6:23 pm
Hello everyone!

I've compiled the latest OpenTyrian (old school vertical scrolling shoot 'em up from ye olde DOS times) using vanfanel's SDL with dispmanx support.
The Image is booting very fast although it's NOT created with rpi-buildroot.
I've used the normal raspbian kernel and copied the needed files from the normal raspbian installation while using busybox as init system.
Thanks to gamaral and his Marshmallow Entertainment System for script ideas.

https://drive.google.com/file/d/0Bxvn4Y ... sp=sharing

Source and normal raspbian tar.gz availble on request

Best regards,
Daniel
Posts: 2
Joined: Tue Dec 30, 2014 6:15 pm
by dudleydes » Sun Feb 08, 2015 1:11 pm
Thanks for the image. OpenTyrian plays really well.

I managed to compile OpenTyrian for my model B. It works fine in X with support for my PS3 controller though, I must say not as smooth as your version. I am looking to add OpenTyrian to my RetroPie and have found difficulties trying to run OpenTyrian outside X.

First I tried launching from the console with the command
Code: Select all
sudo chmod 0666 /dev/tty0
SDL_VIDEODRIVER=directfb ./opentyrian
The game launches but the top and bottom of the screen is cut off. Also, when I exit OpenTyrian, I am left with a black screen which can only be fixed through a power cycle.

Next I tried launching with the command
Code: Select all
SDL_VIDEODRIVER=dispmanx ./opentyrian
In this case, I get the following error:
Code: Select all
error: failed to initialize SDL video: No available video device
Could you please advise how you compiled OpenTyrian with dispmanx support so that it becomes a option as a scaler in the game as in your image? Many thanks.
Posts: 44
Joined: Sun May 18, 2014 12:19 pm
by InsanePie » Mon Feb 09, 2015 8:23 pm
I have sdl-dispmanx (https://github.com/vanfanel/SDL12-kms-dispmanx) installed in /opt/sdl-dispmanx
I've changed the makefile to point to sdl-dispmanx and i've removed all scalers in opentyrian. (it defaults to at least 2x scaling)
Here's the modified source: https://dl.dropboxusercontent.com/u/4640592/opentyrian.tar.gz
SDL-dispmanx was configured with:
CFLAGS="-Ofast -mcpu=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard" ./configure --prefix=/opt/sdl-dispmanx --disable-video-opengl --enable-video-dispmanx --disable-video-fbcon --disable-video-kms --disable-video-directfb --disable-oss --disable-alsatest --disable-pulseaudio --disable-pulseaudio-shared --disable-arts --disable-nas --disable-esd --disable-nas-shared --disable-diskaudio --disable-dummyaudio --disable-mintaudio --disable-video-x11 --disable-input-tslib
Posts: 2
Joined: Tue Dec 30, 2014 6:15 pm
by dudleydes » Wed Feb 11, 2015 5:16 pm
Thank you so much for the source code and dispmanx config flags.

I have managed to compile a opentyrian binary. I was getting a minor error:
Code: Select all
cannot create regular file `bin/': Not a directory
so I made a small change to the makefile so the binary was created in the opentyrian folder as. As I have added OpenTyrian to Retropie, then the opentyrian folder is probably best location for the binary.

I would like to add a tutorial to compiling OpenTyrian to my DOS Gaming on the Pi blog, http://dosonthepi.blogspot.co.uk/. I hope it's okay to share your source code in my tut. Credit will, of course, be given to you for developing this version of OpenTyrian.
Posts: 44
Joined: Sun May 18, 2014 12:19 pm