scastbur
Posts: 3
Joined: Sun Oct 26, 2014 12:51 pm

Unable to launch Chocolate Doom after install on Raspbian

Sun Oct 26, 2014 1:19 pm

Hi,

I have just installed chocolate doom as per the steps in this article:

https://learn.sparkfun.com/tutorials/se ... /dooooooom

I am running a raspberry pi b+ with Raspbian OS. All the dependencies appear to be up to date and everything looks to have compiled without errors, however I'm unable to open the Chocolate Doom setup (1.) or launch the program itself (2.)

(1.)

Code: Select all

[email protected] ~/Doom $ chocolate-setup -iwad DOOM1.WAD
-bash: chocolate-setup: command not found
(2.)

Code: Select all

[email protected] ~/Doom $ chocolate-doom -iwad DOOM1.WAD
                         Chocolate Doom 2.1.0
Z_Init: Init zone memory allocation daemon.
zone memory: 0xb51e3008, 1000000 allocated for zone
Using /home/pi/.chocolate-doom/ for configuration and saves
V_Init: allocate screens.
M_LoadDefaults: Load system defaults.
saving config in /home/pi/.chocolate-doom/default.cfg
W_Init: Init WADfiles.
 adding DOOM1.WAD
===========================================================================
                            DOOM Shareware
===========================================================================
 Chocolate Doom is free software, covered by the GNU General Public
 License.  There is NO warranty; not even for MERCHANTABILITY or FITNESS
 FOR A PARTICULAR PURPOSE. You are welcome to change and distribute
 copies under certain conditions. See the source for more information.
===========================================================================
I_Init: Setting up machine state.
Failed to get I/O port permissions for 0x388: No such device
OPL_Init: Using driver 'SDL'.
NET_Init: Init network subsystem.
M_Init: Init miscellaneous info.
R_Init: Init DOOM refresh daemon - [...................]
P_Init: Init Playloop state.
S_Init: Setting up sound.
D_CheckNetGame: Checking network game status.
startskill 2  deathmatch: 0  startmap: 1  startepisode: 1
player 1 of 1 (1 nodes)
Emulating the behavior of the 'Doom 1.9' executable.
HU_Init: Setting up heads up display.
ST_Init: Init status bar.
Failed to initialize video: Unable to open a console terminal
I have seen similar questions raised in other forums but so far no solution?

Any help appreciated :D :twisted:

Thanks!

itsmedoofer
Posts: 246
Joined: Wed Sep 25, 2013 8:43 am

Re: Unable to launch Chocolate Doom after install on Raspbia

Tue Oct 28, 2014 9:51 am

Hi,

From version 2 you need to run chocolate-doom-setup -iwad blah

Let me know how you get on, I've compiled but think something was up with SDL so am about to have another go.

The error with the game (Failed to get I/O port permissions for 0x388: No such device) is doom not finding the proper Pi MIDI driver, and trying to load a OPL/3 Synth.... Being able to run setup you can alter this and get going like it says in the docs ! :)

scastbur
Posts: 3
Joined: Sun Oct 26, 2014 12:51 pm

Re: Unable to launch Chocolate Doom after install on Raspbia

Wed Oct 29, 2014 9:34 pm

Hey,

Thanks for the response :)

Hmm this is what I get when running the setup command:

Code: Select all

[email protected] ~ $ chocolate-doom-setup -iwad DOOM1.WAD
Using /home/pi/.chocolate-doom/ for configuration and saves
saving config in /home/pi/.chocolate-doom/default.cfg
Failed to initialize GUI
Definitely missing something here but currently not sure what it is!

Did you manage to get up and running yet?

Thanks,
Sam

itsmedoofer
Posts: 246
Joined: Wed Sep 25, 2013 8:43 am

Re: Unable to launch Chocolate Doom after install on Raspbia

Wed Oct 29, 2014 9:53 pm

Hmmm strange, how did you run it, from desktop (after startx) ? I think it needs X running so try from a terminal window on ya desktop.

yea had it running tonight. I've created a .deb file if you want to try that, will put it up somewhere tomorrow.

scastbur
Posts: 3
Joined: Sun Oct 26, 2014 12:51 pm

Re: Unable to launch Chocolate Doom after install on Raspbia

Wed Oct 29, 2014 10:12 pm

Hey,

I'm running it headless and accessing via ssh (using putty) from my windows desktop. Thought it might be something to do with X11 forwarding which I've enabled on the client, with no luck...

Should Raspian need Xorg updating? http://elinux.org/RPi_Xorg_rpi_Driver

itsmedoofer
Posts: 246
Joined: Wed Sep 25, 2013 8:43 am

Re: Unable to launch Chocolate Doom after install on Raspbia

Wed Oct 29, 2014 10:29 pm

Don't think that will work, you will need to be on the local machine or use vnc. X11 forwarding may work but will be slow.

Edit:-
X11 forwarding and connecting with vnc both worked but you really won't be able to play the game like that, you are going to need a monitor.

A shell connection with putty gave the same error you saw.

ymopur
Posts: 1
Joined: Thu Jun 14, 2018 7:44 am

Re: Unable to launch Chocolate Doom after install on Raspbia

Thu Jun 14, 2018 7:49 am

itsmedoofer wrote:
Tue Oct 28, 2014 9:51 am
Hi,

From version 2 you need to run chocolate-doom-setup -iwad blah

Let me know how you get on, I've compiled but think something was up with SDL so am about to have another go.

The error with the game (Failed to get I/O port permissions for 0x388: No such device) is doom not finding the proper Pi MIDI driver, and trying to load a OPL/3 Synth.... Being able to run setup you can alter this and get going like it says in the docs ! :)

chocolate-doom-setup -iwad DOOM1.wad worked for me. Thank you!

Return to “Gaming”

Who is online

Users browsing this forum: No registered users and 6 guests