User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Mon Sep 22, 2014 8:51 pm

DougieLawson wrote:Try un-installing Java8 and replacing it with Java7.

My Raspbian/NOOBS system has oracle-java7-jdk (which is confirmed when I run java -version). All the links in /etc/alternatives point to /usr/lib/jvm/jdk-7-oracle-armhf/.
Good to know! I'll try out Java7 tomorrow.

tx_polkhead
Posts: 21
Joined: Tue Jan 10, 2012 5:41 pm
Location: Dallas, TX 75201, USA
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Mon Sep 22, 2014 10:32 pm

Sorry for the noob question but this sounds like I would use:
sudo apt-get remove x (Java 8)
and a
sudo apt-get install y (Java 7)

where x and y are pointing to the bits I need???

Thanks for the response.

User avatar
DougieLawson
Posts: 35815
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: A MineCraft Server Image - MineCraftPi

Mon Sep 22, 2014 10:46 pm

start with dpkg -l | grep java to see what is installed.

Uninstall what ever packages that command returns then sudo apt-get install oracle-java7* to get Java7 installed.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 11:51 am

DougieLawson wrote:start with dpkg -l | grep java to see what is installed.

Uninstall what ever packages that command returns then sudo apt-get install oracle-java7* to get Java7 installed.
Just tried rebuilding MineCraftPi from scratch using JDK7 ( 2 different versions mind you) - and still receiving the same error.... , Have you verified this as working - or is this just in theory?

As a side - Everything in the image was configured and working properly with JDK8 until version 1.8 of MineCraft was released. JDK8 chosen over JDK7 due to benchmarking tests, which resulted in MineCraft server running with slightly less resources. Now the latest version of the Spigot server is throwing errors when you try to run it. ( latest version of spigot is suppose to be compatible with 1.8 you see ).

User avatar
DougieLawson
Posts: 35815
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 12:05 pm

If it fails the same way with a different Java then the problem lies outside of the Java runtime code and is a bug in your Minecraft 1.8 server code. You may want to post your problem description on a dedicated Minecraft forum as other folks may be getting the same error.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 12:45 pm

DougieLawson wrote:If it fails the same way with a different Java then the problem lies outside of the Java runtime code and is a bug in your Minecraft 1.8 server code. You may want to post your problem description on a dedicated Minecraft forum as other folks may be getting the same error.
As the author of the image - I'm fully aware of the root issue with 1.8 & the current version of spigot.
Last edited by Rionoskae on Tue Sep 23, 2014 12:55 pm, edited 1 time in total.

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 12:49 pm

tx_polkhead wrote:So if this is too much to ask here please let me know...

Everything was working well for me, for weeks if not months. My son and a handful of his buddies were building away in his world but I couldn't leave well enough alone. Actually he wanted to update to 1.8 and I followed the instructions to update to Spigot 1.7 but then things went bad. He could no longer access his server and agreed to a fresh start with a re-imaged card. Back to a fresh formatting and writting of the MineCraft Pi 2.2 image and I get error after error. This is the same Raspberry Pi, the same PNY 8GB class 10 SDHC card (although I've also tried a SanDisk $GB class 4 card too, same errors). At initial boot either everything works and I make him OP and right after I get 'A fatal error has been detected by the Java Runtime Environment:...'

See pic of error on screen here: https://lh5.googleusercontent.com/-ozow ... 194248.jpg .

I format the card, re-image and the same happens or after acquiring an IP address and after 'Loading Libraries please wait...' minutes go by and 'A fatal error has been detected by the Java Runtime Environment:...'

Should I download the image again, or is there another option?

Thanks
I noticed it said "failed to write core dump". Did you run "raspi-config" to expand the file system after imaging? Barring that I would try downloading the image agian. But please be aware that MineCraftPi currently won't work with version 1.8 of the client.... Latest version of Spigot doesn't seem to work ( although it's stated as being able to support 1.8)

I'll work on a new version this week - If nothing else I'll use the bukkit server builds until spigot is sorted.
Here: https://dl.bukkit.org/downloads/bukkit/?page=1

tx_polkhead
Posts: 21
Joined: Tue Jan 10, 2012 5:41 pm
Location: Dallas, TX 75201, USA
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 2:46 pm

I was never able to expand the file system, either the crash happens immediately after making him OP (the next steps would be stop the server followed by raspi-config or it crashes at boot before even getting to a log-in. I could shoot a video of the screen and post it to youtube if you would like to see it happen.


Rionoskae wrote:
tx_polkhead wrote:So if this is too much to ask here please let me know...

Everything was working well for me, for weeks if not months. My son and a handful of his buddies were building away in his world but I couldn't leave well enough alone. Actually he wanted to update to 1.8 and I followed the instructions to update to Spigot 1.7 but then things went bad. He could no longer access his server and agreed to a fresh start with a re-imaged card. Back to a fresh formatting and writting of the MineCraft Pi 2.2 image and I get error after error. This is the same Raspberry Pi, the same PNY 8GB class 10 SDHC card (although I've also tried a SanDisk $GB class 4 card too, same errors). At initial boot either everything works and I make him OP and right after I get 'A fatal error has been detected by the Java Runtime Environment:...'

See pic of error on screen here: https://lh5.googleusercontent.com/-ozow ... 194248.jpg .

I format the card, re-image and the same happens or after acquiring an IP address and after 'Loading Libraries please wait...' minutes go by and 'A fatal error has been detected by the Java Runtime Environment:...'

Should I download the image again, or is there another option?

Thanks
I noticed it said "failed to write core dump". Did you run "raspi-config" to expand the file system after imaging? Barring that I would try downloading the image agian. But please be aware that MineCraftPi currently won't work with version 1.8 of the client.... Latest version of Spigot doesn't seem to work ( although it's stated as being able to support 1.8)

I'll work on a new version this week - If nothing else I'll use the bukkit server builds until spigot is sorted.
Here: https://dl.bukkit.org/downloads/bukkit/?page=1

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 23, 2014 10:44 pm

So good news! Looks like I was able to get MineCraft to work with 1.8 using the default minecraft_server.jar file.

This most likely translates to a performance hit - but I wont' know by how much until I dig in further. The spigot.jar / bukkit.jar variations haven't caught up quite yet - with no real ETA for when they might be available. 1.8 now leverages a elua.txt file which must be manually set to "true" during install. This may be part of what is holding up spigot/bukkit development, but I'm un sure at this point.

In any case, I'm currently working on a new version to support 1.8. While performance may take a hit - It will now be compatible with the B+ model, so that's a plus.

I'll followup once the new image is live.

~Cheers,
Rionoskae

Update:
I spoke too soon.... the default minecraft_server.jar can't even run on the Pi, it's completely starved of resources. Just not possible.... So I guess we wait....

Apparently Spigot is fighting a legal battle after the MS takeover of Mohjang - You can read about it here: http://www.spigotmc.org/threads/our-dmc ... nse.28772/

It may be awhile before things get back on track....(if ever)

I'm really not sure what else I can do or try to get this working on the Pi once more... If you have suggestions - I'd be happy to hear from you...but right now - I've tried everything I can think of to revive MineCraftPi and I just can't seem to make it happen. Any ideas would be greatly appreciated!

tx_polkhead
Posts: 21
Joined: Tue Jan 10, 2012 5:41 pm
Location: Dallas, TX 75201, USA
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Thu Sep 25, 2014 2:02 pm

So is the image available that worked before? Like I said this was running just great for quite a while, It was still playable just without the latest 1.8 new features. Is it possible to run the older version? Did I change something or is something on the image new or is MineCraft changed enough that it will not work anymore?

AlexD
Posts: 1
Joined: Sun Sep 28, 2014 1:36 pm

Re: A MineCraft Server Image - MineCraftPi

Sun Sep 28, 2014 1:38 pm

Hello, great work :)
I was wondering however, how do I edit the server.properties file?
Many thanks
Alex

JaminBenny
Posts: 3
Joined: Fri Sep 26, 2014 11:19 pm

Re: A MineCraft Server Image - MineCraftPi

Mon Sep 29, 2014 8:36 pm

My B+ eth0 is not getting seen. Ideas?
Also no keyboard?

User avatar
DougieLawson
Posts: 35815
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 30, 2014 12:01 am

JaminBenny wrote:My B+ eth0 is not getting seen. Ideas?
Also no keyboard?
That means the firmware files in /boot are too old to run with a B+. They need to be updated to no later than June 2014.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Sep 30, 2014 12:36 am

tx_polkhead wrote:So is the image available that worked before? Like I said this was running just great for quite a while, It was still playable just without the latest 1.8 new features. Is it possible to run the older version? Did I change something or is something on the image new or is MineCraft changed enough that it will not work anymore?
Not that I'm aware of... I'm pretty sure MineCraft forces you to update to 1.8. Nothing was changed on the image, The Microsoft takeover of MineCraft has yielded the open source server it uses (spigot / craftbukkit) un-usable for the time being.

Hopefully they are able to resolve whatever legal issues they are encountering and spigot releases a working version for 1.8 - but for now there isn't much I can do until that happens....

tx_polkhead
Posts: 21
Joined: Tue Jan 10, 2012 5:41 pm
Location: Dallas, TX 75201, USA
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Fri Oct 03, 2014 9:02 pm

Not sure why it works now and why I was getting error after error last week but just for grins I burned the image once again, booted and this time after loading libraries it actually loaded! After attempting to OP my son's user name I stopped the server to run the config, I expanded the file system, and upped the overclocking to medium and crossed my fingers to reboot. Sure enough it is working! Well the OP doesn't stick. He does not have OP rights, perhaps I didn't do it right, I'll look in to it later, for now happy time are back!

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Sat Oct 04, 2014 4:44 pm

tx_polkhead wrote:Not sure why it works now and why I was getting error after error last week but just for grins I burned the image once again, booted and this time after loading libraries it actually loaded! After attempting to OP my son's user name I stopped the server to run the config, I expanded the file system, and upped the overclocking to medium and crossed my fingers to reboot. Sure enough it is working! Well the OP doesn't stick. He does not have OP rights, perhaps I didn't do it right, I'll look in to it later, for now happy time are back!
That is great news :) I didn't change anything on my end - I'm willing to bet that they resolved some of the legal issues since the takeover and have since loosened their grip on opening things up.

Are you using 1.8 then?

tx_polkhead
Posts: 21
Joined: Tue Jan 10, 2012 5:41 pm
Location: Dallas, TX 75201, USA
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Sat Oct 04, 2014 6:53 pm

Using 1.8, but then downgrading at launch. Created a new profile > Version Selection > Use version: > release 1.7.10 and it plays perfectly. Now I have to figure out how share the server publicly, I am running a different router since last time...

Any Ideas why I am getting the following error when trying to OP " I'm sorry, but you do not have permission to preform this command. Please contact the server administrators if you believe that this is an error."

yellow
Posts: 1
Joined: Sun Oct 12, 2014 9:48 am

Re: A MineCraft Server Image - MineCraftPi

Sun Oct 12, 2014 9:59 am

hello
I have a B+ with Sandisk Ultra 32G
Can you make an image with Cauldron/MCPC+ 1.6.4?
Spigot can't install mods :(

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Tue Oct 14, 2014 8:45 pm

yellow wrote:hello
I have a B+ with Sandisk Ultra 32G
Can you make an image with Cauldron/MCPC+ 1.6.4?
Spigot can't install mods :(
Spigot can support mods - The image comes with 2 installed already.

I don't have any plans to cut over to any alternatives.

ooberrampage
Posts: 16
Joined: Fri Sep 05, 2014 10:49 pm

Re: A MineCraft Server Image - MineCraftPi

Mon Dec 01, 2014 12:20 am

Any reason I can't change the view distance from the server properties file? No matter what I change it to, when server is started it loads up at 4 chunks. Go back into server file, it still says whatever I changed it to. Any ideas?

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Mon Dec 01, 2014 5:03 pm

ooberrampage wrote:Any reason I can't change the view distance from the server properties file? No matter what I change it to, when server is started it loads up at 4 chunks. Go back into server file, it still says whatever I changed it to. Any ideas?
My guess is the server is still running when you were trying to make the changes - which would in effect ( I believe ) lock the file, since it would be in use.

Try booting up to command line and exiting the server when starts and then try making changes.

ooberrampage
Posts: 16
Joined: Fri Sep 05, 2014 10:49 pm

Re: A MineCraft Server Image - MineCraftPi

Wed Dec 03, 2014 1:49 am

how i have been trying to change it is like this

type stop to stop the server
login to pi
type sudo nano /opt/MineCraft/server.properties
adjust view distance value
ctrl x to save
reboot

is this the correct method?

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Wed Dec 03, 2014 3:38 pm

Yea that should be it...

ooberrampage
Posts: 16
Joined: Fri Sep 05, 2014 10:49 pm

Re: A MineCraft Server Image - MineCraftPi

Thu Dec 04, 2014 12:19 am

i myself just cannot figure this out. going back into the text file any values i changed are what i changed them to, even the view distance. however, the server always loads up with a view-distance value of 4. almost as if something is overriding the server properties file. has anyone else here been able to change the value and it actually take effect?

User avatar
Rionoskae
Posts: 204
Joined: Thu Mar 06, 2014 5:40 pm
Location: WI
Contact: Website

Re: A MineCraft Server Image - MineCraftPi

Thu Dec 04, 2014 12:48 am

ooberrampage wrote:i myself just cannot figure this out. going back into the text file any values i changed are what i changed them to, even the view distance. however, the server always loads up with a view-distance value of 4. almost as if something is overriding the server properties file. has anyone else here been able to change the value and it actually take effect?
Hmm... that is odd. For what it's worth - I've found the view distance of 4 to be optimal performance wise...

Return to “Gaming”