LeSanglier
Posts: 226
Joined: Fri Jan 11, 2013 8:11 pm
Location: In Hell with God
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Jul 25, 2014 10:55 am

Hi,

There is no previous of the source code ?
:oops:
Mon blog sur le Raspberry Pi : http://framboisepi.fr/
Pour avoir plus de chance d'avoir une réponse à votre question,
allez sur le forum français Rasberry Pi : http://forum.raspfr.org

User avatar
Nintendo16kid
Posts: 32
Joined: Sun Dec 29, 2013 10:34 pm
Location: England

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Sep 05, 2014 1:04 pm

Haven't been here in a while lol.
I have tried to get Xonotic to run, but unfortunately no luck. Well, kinda... :(
Image
The mouse was locked in the corner of the screen, but the audio was mostly working but there is a lot of interference through the audio jack, maybe its my own hardware doing that.
This is probably an extremely easy thing I have overlooked.
To get it to sort of work, get the data folder from Xonotic, and use "darkplaces-sdl -**xonoticdatafilename**" to run.
I am amazed at what can be done by such a small and cheap device!

kwadroke
Posts: 30
Joined: Tue Jan 29, 2013 4:20 am

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Dec 12, 2014 8:14 pm

I just tried running Xonotic on the Pi using the "Lower quality download". I too had the mouse pointer stuck, but, I haven't had much luck with the Quake I demo and the mouse (keeps showing "Unknown Command libudev" after a few seconds).
I increased the swap file to 512mb, and added some graphics tweaks in the config. I also extracted all of the .pk3 files to help with CPU/memory usage.
I was able to get a map to load, but doesn't display anything but the HUD, then hangs up the system.
I think I will try to use the older files from here http://forums.xonotic.org/showthread.php?tid=4029 some time in the future and see if it works better.
ArkanPi - Raspberry Pi Users in Arkansas - http://pi.arkgeeks.com/

adih2001
Posts: 18
Joined: Sat Mar 01, 2014 9:06 am

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Jan 29, 2015 12:06 pm

Nice tutorial dude! I am just asking if is possible to run darkpaces engine on raspberry pi model A+ without huge overclocking?

KitchUK
Posts: 256
Joined: Fri Jul 19, 2013 5:40 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Wed Feb 11, 2015 9:29 am

Anyone tested performance with this on a RPi2?

On the RPi on 720p I was getting average of 25-30fps with numerous jumps to even 60fps at times. It ran extremely well. I'd be interested to know how it's running with more processing power.

Hiradur
Posts: 96
Joined: Fri Mar 01, 2013 10:59 am

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Feb 13, 2015 9:49 am

Have the changes been merged into the main repository of darkplaces already?

atheneheaven
Posts: 1
Joined: Sun Aug 25, 2013 8:41 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Feb 13, 2015 11:22 pm

Hi
I've followed the instructions to install this on my RPi2 but I get an error when I run the last command.
You may consider adding -basedir /path/to/game to your launch commandline.
Can anyone tell me what that means?

User avatar
Trixster
Posts: 259
Joined: Sat Jul 07, 2012 3:53 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Sun Mar 08, 2015 12:42 pm

You need to be in the darkplaces directory before typing darkplaces-sdl

User avatar
Trixster
Posts: 259
Joined: Sat Jul 07, 2012 3:53 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Sun Mar 08, 2015 2:00 pm

The rpi2 gets over 30fps sustained at 1080p with some of the lighting effects dialled down, but the stuttery movement when strafing or going forward/backwards is dreadful. Any ideas on how to improve this?

User avatar
autonomous
Posts: 24
Joined: Tue Apr 23, 2013 5:24 pm
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Wed Jun 03, 2015 5:52 pm

Trixster wrote:The rpi2 gets over 30fps sustained at 1080p with some of the lighting effects dialled down, but the stuttery movement when strafing or going forward/backwards is dreadful. Any ideas on how to improve this?
You can try changing the sys_ticrate parameter in the darkplaces/id1/config.cfg file. This is a standard quake configuration parameter. The server ticrate was reduced to 10fps to deal with the hideously poor performance of the single core version of the chipset used in the Raspberry PI. You also need to remove or change the config.cfg files cached under ~/.darkplaces.

Description of the sys_ticrate parameter:

Code: Select all

sys_ticrate 0.05 duration of a server frame is in seconds, where 0.05 is 20fps server rate, 0.1 is 10fps (can not be set higher than 0.1), 0 runs as many server frames as possible.

User avatar
Aaronaurus
Posts: 9
Joined: Tue Jul 14, 2015 5:32 am
Location: England, UK

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Jul 23, 2015 4:17 am

Just wondering why the choice to force the resolution based on the boot config? Am I missing something?

Makes it a pain to have to change resolution that way.
Last edited by Aaronaurus on Sat Aug 08, 2015 5:12 pm, edited 2 times in total.

super213
Posts: 50
Joined: Sat Jul 04, 2015 7:00 pm
Location: USA

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Wed Jul 29, 2015 8:33 pm

Can some one help! when i try to run it i get this
////////////
darkplaces-sdl: error while loading shared libraries: libtxc_dxtn.so: cannot open shared object file: No such file or directory
///////////

Hiradur
Posts: 96
Joined: Fri Mar 01, 2013 10:59 am

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Jul 30, 2015 7:41 am

super213 wrote:Can some one help! when i try to run it i get this
////////////
darkplaces-sdl: error while loading shared libraries: libtxc_dxtn.so: cannot open shared object file: No such file or directory
///////////
Try

Code: Select all

sudo apt-get install libtxc-dxtn-s2tc0

super213
Posts: 50
Joined: Sat Jul 04, 2015 7:00 pm
Location: USA

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Jul 30, 2015 4:02 pm

Hiradur wrote:
super213 wrote:Can some one help! when i try to run it i get this
////////////
darkplaces-sdl: error while loading shared libraries: libtxc_dxtn.so: cannot open shared object file: No such file or directory
///////////
Try

Code: Select all

sudo apt-get install libtxc-dxtn-s2tc0
Fixed it with a reboot. some reason the pi was not behaving correctly. i was a little late before i could edit my post. sorry for wasting your time.

KitchUK
Posts: 256
Joined: Fri Jul 19, 2013 5:40 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Sep 18, 2015 11:42 am

Hi Autonomous,

Do you think you will be updating this project anymore? Are there any possibles of adjustment to tailor for the increased CPU power of the Pi 2? Is darkplaces optimized for multi core CPU's?

Thanks,

P.S Could we now maybe run Half Life on the Pi 2? Any plans? (Wishful thinking).

User avatar
DougieLawson
Posts: 34178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Fri Sep 18, 2015 8:28 pm

Don't hold your breath waiting for a reply as autonomous hasn't visited the forums since Wed 10 Jun 2015, 08:17
Note:The use of baseball bats for educational purposes is completely disallowed on this forum.

Any DMs sent on Twitter will be answered next month.


Thorn
Posts: 21
Joined: Wed Aug 10, 2011 7:09 pm
Location: Scotland
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Tue Oct 13, 2015 3:32 pm

Hi,
Did these changes ever merge with Darkplaces?

If not, could you please release the source?

exobuzz
Posts: 135
Joined: Mon Nov 26, 2012 6:58 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Oct 15, 2015 2:13 am

Seems there is no source available for the rpi port - Been over a year - considering the source is GPL licenced, the rpi modifications should have been made available at the same time as the public binary release. I have removed the binary from RetroPie due to this.

User avatar
stuartheath
Posts: 23
Joined: Mon Jun 18, 2012 9:42 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Mon Jan 04, 2016 3:23 pm

How do I center the video on my tv. It seems to be shifted to a left bottom corner leaving a border on the top and right side!

User avatar
DougieLawson
Posts: 34178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Mon Jan 04, 2016 3:32 pm

stuartheath wrote:How do I center the video on my tv. It seems to be shifted to a left bottom corner leaving a border on the top and right side!
Edit your config.txt and remove all of the overscan lines.
Note:The use of baseball bats for educational purposes is completely disallowed on this forum.

Any DMs sent on Twitter will be answered next month.

User avatar
stuartheath
Posts: 23
Joined: Mon Jun 18, 2012 9:42 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Mon Jan 04, 2016 3:54 pm

DougieLawson wrote:Edit your config.txt and remove all of the overscan lines.
Thanks that worked, but trying to change the res to 800x600 with no luck, stays at 1080. Changed the config in both id1 folders! Any ideas? Thanks again!

User avatar
DougieLawson
Posts: 34178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Mon Jan 04, 2016 4:36 pm

If you're able to run the tvservice program it will tell you what modes your display is capable of running.
On non-Raspbian systems you should be able to build tvservice from https://github.com/raspberrypi/userland

The alternative is get a copy of Raspbian booted and running and use the ready built tvservice

tvservice -m CEA;tvservice -m DMT # list all the modes.
Note:The use of baseball bats for educational purposes is completely disallowed on this forum.

Any DMs sent on Twitter will be answered next month.

alfredox123
Posts: 28
Joined: Wed Apr 27, 2016 6:01 am

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Tue May 31, 2016 11:59 pm

i did all steps as noted on the readme but i only get black screen after i type dakplaces-sdl, im using raspberry pi 1 model b

exobuzz
Posts: 135
Joined: Mon Nov 26, 2012 6:58 pm

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Thu Sep 08, 2016 1:28 am

Just FYI - Author has no intention of releasing the source code.

There was an issue open for it - which some comments were made on - the author first claimed their interpretation of the GPL meant they didn't need to release the source as they were not selling it. Then they claimed the sourcecode was "stolen" in a burglary.

Putting this here as the issue was locked and all the replies removed / and the title renamed to try and "hide" the issue.

https://github.com/autonomous1/darkplacesrpi/issues/11

Return to “Gaming”