User avatar
DougieLawson
Posts: 34166
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Moonlight Embedded

Sat Jul 09, 2016 9:24 am

Has the IP address for your RPi changed?
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

User avatar
Dis93
Posts: 130
Joined: Thu Apr 07, 2016 8:30 pm
Location: Wuthering, Yorkshire

Re: Moonlight Embedded

Sat Jul 09, 2016 9:29 am

Hi Dougie,

No the IP address hasn't changed , both are fixed.
Anyways, it was a glitch, restarted my Win10 box, now it works. shrugs
Pi 3B - RS one nine design clear case - Official Black 5v 2.5A PSU - HDMI>DVI-D - 32Gb Samsung EVO+ - Raspbian/Kodi/RetroPie
Pi Zero - Official White 5v 2A PSU - Raspberry Wifi - 32Gb Samsung EVO+ - Raspbian

harmltc
Posts: 2
Joined: Wed Jan 04, 2017 3:19 pm

Re: Moonlight Embedded

Wed Mar 08, 2017 3:26 pm

I've setup Moonlight Embedded on Retropie/Emulationstation using different guides and i am very happy with the results. My X360 controllers are recognized and i can navigate every menu. When launching Moonlight Embedded (stream PC/Steam) i can still navigate menus and play games without any problem. Great!

The next step was to look for a rhythm game like Guitar Hero, and was found in the form of Phase Shift (http://www.dwsk.co.uk/index_phase_shift.html). Installed and worked like a charm. X360 guitar controller worked out of the box by connecting the USB wireless receiver to my PC (which i also use to my RPI3). Added the game to Steam so it can be launched by EmulationStation/Moonlight.

Now, when my X360 guitar controller is connected to my RPI3 using the wireless receiver, i can navigate all the menus in EmulationStation, all the menus in Moonlight/Steam, but when i launch Phase Shift the game freezes when i touch a button. Normal X360 controllers work fine in the game.

I know this might be a Phase Shift problem, but in the forums over there they couldnt really help me because they dont use this setup, so thats why i try it here. Also, Phase Shift looks like a great game to play from your couch using Moonlight, so it might interest others to help!

numotiv
Posts: 2
Joined: Thu Jun 08, 2017 9:52 pm

Re: Moonlight Embedded

Thu Jun 08, 2017 9:55 pm

Hello there, not sure if this has come up before but I was wondering if its possible to stream in 4x3? I have a 4k monitor on my computer and I am streaming to my pi on a crt tv. I set the resolution to 320x240(I'm streaming n64/ps2 etc) which works fine but there is a black bar on the top and bottom. I can actually see a bit of the console text so clearly the image just isn't filling the screen.

volc
Posts: 1
Joined: Wed Jun 21, 2017 9:30 pm

Re: Moonlight Embedded

Wed Jun 21, 2017 9:35 pm

Hey guys just wanted to share my script for starting moonlight. Been using this quite a bit.
This script can wol your pc and checks with netcat if steam is ready. Then it will connect. No more running up and down ;)


#!/bin/bash
host='*.*.*.*' #Gamestream host you paired with
wol='1' #Set to 0 if you don't need wake on lan (install package wakeonlan)
mac='94:DE:80:66:XX:XX' #mac address of Gamestream host
port='27036' #Port to check if SteamStreaming is live
res='-1080' #Moonlight resolution
fps='-fps 60' #Moonlight frames per second
map='-mapping /home/pi/Moonlight/xbox.map' #Path of moonlight mapping file
#WakeonLAN
if [ $wol -eq '1' ]
then
wakeonlan $mac
fi

function fail {
echo $1 >&2
exit 1
}

function streamit {
local n=1
local max=45
local delay=2
while true; do
nc -v -z -w1 $host $port 2>/dev/null && break || {
if [[ $n -lt $max ]]; then
((n++))
sleep $delay;
elif [[ $n -eq 10 ]]; then
echo "Waited 10 seconds"
elif [[ $n -eq 20 ]]; then
echo "Waited 20 seconds"
elif [[ $n -eq 30 ]]; then
echo "Waited 30 seconds"
elif [[ $n -eq 40 ]]; then
echo "Waited 40 seconds"
elif [[ $n -eq 50 ]]; then
echo "Waited 50 seconds"
else
fail "Failed to stream from GameStream, is your Geforce Experience running?"
fi
}
done
}
echo "GameStream Ready, starting Moonlight"
moonlight stream $host $res $fps $map

#Gamestream start
streamit

Henster
Posts: 1
Joined: Thu Jul 06, 2017 1:49 pm

Re: Moonlight Embedded

Thu Jul 06, 2017 2:14 pm

Hi,
Does the wireless Xbox one controller adapter dongle work with moonlight for the rpi? https://encrypted-tbn1.gstatic.com/imag ... Q4JhDRHIUQ Also, does this allow me to play 2 player if I got another controller (Games like gang beasts and niddhog)?

ZaLiTHkA
Posts: 1
Joined: Thu Apr 06, 2017 6:46 pm

Re: Moonlight Embedded

Sun Nov 05, 2017 5:30 pm

Greetings,

Maybe a bit of a pipedream here, but does anyone know if it's possible to use a Logitech G27 with this setup..?

I'm designing my own sim racing seat and frame (to build in the coming holidays), hoping to use it with something like this to play my Steam games (PC in my room) with my G27 on my lounge TV. But of course, the design will be different if this isn't an option, because it will need to work with the monitors at a different height.

So far this is the only thing I haven't managed to find any information on yet.. Any bright ideas?

1031982
Posts: 6
Joined: Sun Nov 13, 2016 7:41 am

Re: Moonlight Embedded

Fri Nov 10, 2017 10:56 am

Has anyone had an issue with an XBox 360 wireless controller being identified by Steam as an XBox One controller through Moonlight?
I just did a clean install of RetroPie and as soon as I connect the controller doesn't work because of this. I have a wireless mouse and keyboard I use for any real typing, and that's how I get out of it.

DefaultName
Posts: 1
Joined: Mon Nov 20, 2017 9:07 pm

Re: Moonlight Embedded

Mon Nov 20, 2017 9:14 pm

Hi everyone,

I just registered to ask for help and see that 1031982 has a very similar problem to mine. I have Moonlight up and running on a raspi2 (retropie), installed using TechWizTime's script. Streaming works great but I have a problem with my controllers:

I have two wired Xbox 360 controllers. Both are configured in retropie (not sure if this is necessary). When I stream I can only get Steam to recognize one of them and it shows up as an Xbox One controller. This means that right trigger seems to be mapped to start etc.

Does anyone know how to troubleshoot this?

nadaso8
Posts: 5
Joined: Wed Aug 02, 2017 8:28 pm

Re: Moonlight Embedded

Thu Feb 15, 2018 1:45 am

**_NVidia Geforce Experience version:_**
3.12.0.84

**Moonlight Embedded version:**
2.4.4

**Moonlight Embedded source:** _repository/included in distribution/compiled from source/..._
?? I just recently downloaded it using the instructions under raspbian osmc

**Moonlight Embedded running on:** _Raspberry Pi/Cubox-i/Hummingboard/Other linux device/..._
raspberry pi 3 with the screen outputting to the Pimeroni Hyperpixle Dpi touchscreen

**Moonlight Embedded running on distribution:** _Arch Linux/Raspbian/OpenELEC/..._
raspbian
**Verbose output `-verbose` of Moonlight Embedded:**
Searching for server...
Connect to xxx.xxx.x.xx...
No mapping available for Touchscreen (03000000001000000001000000001000000001) on /dev/input/event0
Initializing platform...done
Resolving host name...done
Starting RTSP handshake... RTSP: Failed to connect to UDP port 48010
failed: -1
Cleaning up platform...done

**What is the expected result?**
moonlight outputs to the small dpi screen I have installed

**What happens instead of that?**
moonlight outputs to Nothing. I'm guessing moonlight is trying to force output to Hdmi even though I have the output set to the dpi screen in config.txt . Just wondering if anyone had any guesses at fixing this, input would be greatly appreciated.
have a nice day and don't run sudo startx

Spainer
Posts: 3
Joined: Sat Jul 28, 2018 4:18 pm

Re: Moonlight Embedded

Tue Jul 31, 2018 5:07 pm

Since 3 days I am trying the imposible mission to connect my PS3 controller through bluetooth. There is many threads in google but dont fix my issue.

Always when I launch the moonlight says my mapping is incorrect and when I tried to set up a mapping

$ moonlight map -input /dev/input/event2 controller.map
No mapping available for PLAYSTATION(R)3 Controller (060000004c0500006802000000010000) on /dev/input/event2

I've seen the file gamecontrollerdb.txt

Image

I change the name if could be the problem..

The PS3 controller was installed with RetroPie.

Please help.

Spainer
Posts: 3
Joined: Sat Jul 28, 2018 4:18 pm

Re: Moonlight Embedded

Wed Aug 08, 2018 8:34 am

I guess the moonlight proyect is dead.

Well I will buy a Steam Link.

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Moonlight Embedded

Wed Aug 08, 2018 8:58 am

Spainer wrote:
Wed Aug 08, 2018 8:34 am
I guess the moonlight proyect is dead.

Well I will buy a Steam Link.

Have you asked the developers for help ?

https://github.com/irtimmer/moonlight-e ... /README.md
Adieu

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5371
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Moonlight Embedded

Wed Aug 08, 2018 8:59 am


ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5371
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Moonlight Embedded

Wed Aug 08, 2018 9:02 am

Having said that, Steam Link is a great alternative. I picked one up for basically free during the summer sale (I think it was around 2 GBP) and it works much better than expected.

Spainer
Posts: 3
Joined: Sat Jul 28, 2018 4:18 pm

Re: Moonlight Embedded

Wed Aug 08, 2018 9:26 am

Hi

There are many issues open with the same problem. And nobody help... Just now I was going to open another one, altrough without hope.

I tested PS3 through BT and USB, XBOX 360 Wireless and XBOX one by USB, and nothing. I invest about 20-30 hours to fix it, and I am a bit tired, sometimes I think why I didn't buy Steam Link in summer sales xD (Still I had not bought RBP, and I want use it with moonlight xD).

With the wireless joypads I have the " Map on "PS3 Controller blabla" is incorrect" with USB joypads I havent got error the output of -verbose seems right but the joypad doesnt works...

I have a question, Should the joypad appears in Device controllers on Windowds host?

Also It's possible the problem is the GFE version, but downgrade the version means I must to download the software in unnoficial sources...

Thanks

ivancaas
Posts: 1
Joined: Sat Aug 11, 2018 9:42 am

Re: Moonlight Embedded

Sat Aug 11, 2018 9:47 am

Hi, I have a problem with my moonlight embedded. My controller works perfectly on my PC, if i connect it, it works correctly in the retro Pie if I CONNECT it, but if its connected to my retropie and I launch steam from my retropie, the controller input from the retropie is not sended to Steam, or pc, I dont know why, if steam and retro pie recognices it if I installa the controller in each device. The keyboard and mouse inputs are sended to steam, is only in the Controller the problem. Thank you for reading

Return to “Gaming”