hay7410
Posts: 4
Joined: Fri Sep 13, 2013 5:38 pm

retroarch.cfg troubles

Fri Sep 13, 2013 5:53 pm

I am new to Linux based systems and recently just received my Raspberry Pi that I have been trying to turn into a retro arcade system. I have been following http://supernintendopi.wordpress.com/ mostly as well as other sites and forums attempting to get my system up and running. I have gone through the entire process twice from installing the RetroPie image to transferring roms and configuring both the ES front end controls and the configs/all/retroarch.cfg file for the emulators. The ES front end controls work fine (I am using a USB SNES controller), but after two days of researching and messing with my retroarch.cfg file I cant seem to get it to work within the emulators. The only thing that works there is hotkey/exit button combination that I set up as start and select "8" and "9" respectively. I have been testing the controls mostly in the NES emulator on super Mario games but I have tried others as well and cant get it to work. I have tried the cd RetroPie/emulators/RetroArch/tools
./retroarch-joyconfig >> ~/RetroPie/configs/all/retroarch.cfg command line and it writes to the file. Also have edited it myself adding the hotkey and deleting the extra buttons.

Please someone offer me some advice so I can get this fixed, it is driving me crazy and consuming all my thoughts!

Takenover83
Posts: 166
Joined: Mon Sep 02, 2013 5:39 am

Re: retroarch.cfg troubles

Sat Sep 14, 2013 1:33 am

Does your controller work when you test it? I am guessing yes if it works via emulationstation.

Code: Select all

jstest /dev/input/js0
Your retroarch config command looks correct to me. But maybe try this one to see if it does anything different?

Code: Select all

./retroarch-joyconfig -o p1.cfg -p 1 -j 0
sudo cat p*.cfg >> ~/RetroPie/configs/all/retroarch.cfg

hay7410
Posts: 4
Joined: Fri Sep 13, 2013 5:38 pm

Re: retroarch.cfg troubles

Sat Sep 14, 2013 5:42 pm

I tried jstest /dev/input/js0 and my controller is responsive to all buttons. After that I tried your ./retroarch-joyconfig -o p1.cfg -p 1 -j 0
command lines and I got the joyconfig prompts at the command screen "configuring binds for player #1 on joypad #0. after that was complete i typed sudo cat p*.cfg >> ~/RetroPie/configs/all/retroarch.cfg in the same command line still in the /RetroPie/emulators/RetroArch/tools directory and I dont think the sudo command had any action when entered (I saw no text scrolling and it just gave me a new line.

After a sudo reboot, I tried my NES roms again. ES front end controlls still navigate the menus flawlessly, but once a rom is loaded like Super Mario 3 none of the controlls respond (with the exception of select and start pressed together to kick me back out to ES).

I attached a few shots of my command lines. Maybe I'm doing something wrong but hopefully I can get this working before I give up.
Attachments
linux2.jpg
linux2.jpg (63.88 KiB) Viewed 3437 times
linux.jpg
linux.jpg (54.03 KiB) Viewed 3437 times

Takenover83
Posts: 166
Joined: Mon Sep 02, 2013 5:39 am

Re: retroarch.cfg troubles

Sat Sep 14, 2013 8:55 pm

Maybe upload your retroarch.cfg too. It looks like it should be working.

hay7410
Posts: 4
Joined: Fri Sep 13, 2013 5:38 pm

Re: retroarch.cfg troubles

Wed Sep 18, 2013 3:47 pm

Here is a picture of my retroarch file. I can upload the file or text later when I am at home with my SSH program.
Attachments
retroarch.jpg
retroarch.jpg (52.4 KiB) Viewed 3342 times

hay7410
Posts: 4
Joined: Fri Sep 13, 2013 5:38 pm

Re: retroarch.cfg troubles

Wed Oct 02, 2013 7:49 pm

Still no luck. Out of ideas but don't want to throw in the towel.

Return to “Gaming”