rpix86 (Raspberry Pi x86 emulator) version 0.19 released!


244 posts   Page 10 of 10   1 ... 6, 7, 8, 9, 10
by Pate » Sat Jun 20, 2015 12:44 pm
Hello bigrip, welcome to the forum!

Can you run ls -al commands in your /dev/input and /dev/input/by-id folders, and then copy the result here? I don't need the actual files (and they are virtual files so you could not copy them anyways), I just need to see the names of the files. This might give me ideas as to why rpix86 does not handle the files correctly.

Also, have you tried to start rpix86 with -k0, -k1 or -k2 parameter, to see if one of those would make rpix86 to recognise the keyboard?

Thanks for your interest in rpix86!

Pate
Now working on piro: http://piro.patrickaalto.com
See my rpix86 project at http://rpix86.patrickaalto.com
Posts: 115
Joined: Tue Feb 05, 2013 9:04 am
Location: Finland
by bigrip » Sat Jun 20, 2015 2:29 pm
hi

the -k2 parameter works thanks.

here is the output trom ls -al
insgesamt 0
drwxr-xr-x 4 root root 180 Jun 20 16:22 .
drwxr-xr-x 13 root root 3260 Jun 20 16:22 ..
drwxr-xr-x 2 root root 140 Jan 1 1970 by-id
drwxr-xr-x 2 root root 100 Jan 1 1970 by-path
crw-rw---T 1 root input 13, 64 Jan 1 1970 event0
crw-rw---T 1 root input 13, 65 Jan 1 1970 event1
crw-rw---T 1 root input 13, 66 Jun 20 16:22 event2
crw-rw---T 1 root input 13, 63 Jan 1 1970 mice
crw-rw---T 1 root input 13, 32 Jan 1 1970 mouse0
Posts: 2
Joined: Fri Jun 19, 2015 10:36 pm
by Orotomo » Wed Jun 24, 2015 7:51 am
Excuse me fine sir,

I seem to be having a problem. (My partner decided to act high class on this, I'm sorry) We are working on a project that has led us to using your magnificent program, and we are having a slight issue. We are trying to run Fallout 1 (a game from 1999) on the RPi. Because it is a DOS game, we tried DOSBox, which was too slow, and now we are trying RPix86. It works wonderfully, it is as great as we could hope, with one flaw. When we slide the cursor over to the main menu, it doesn't switch to the game's cursor. This means that we are unable to select anything on the main menu and are unable to actually start the game. It would be most beneficial if you had any ideas on how to fix this. (We can send you a poor quality video of what we mean if we poorly explained it.)

Thank you for your time (and for the program).

Sincerely,
Orotomo
Posts: 3
Joined: Wed Jun 24, 2015 7:39 am
by Pate » Wed Jun 24, 2015 2:18 pm
Hello Orotomo, welcome to the forum!

I think I understand your description of the problem, however, it looks like I would need to take a look at the game itself to be able to figure out what goes wrong. I don't have that game myself, and it seems not to be freely downloadable, so I am not able to help you immediately, sorry.

There is of course a chance that I could figure out something further based on your video, so if it is not a lot of work for you, perhaps you could send that my way?

Thanks for your interest in rpix86!

Patrick
Now working on piro: http://piro.patrickaalto.com
See my rpix86 project at http://rpix86.patrickaalto.com
Posts: 115
Joined: Tue Feb 05, 2013 9:04 am
Location: Finland
by Orotomo » Fri Jun 26, 2015 3:43 am
Hello Pate,

Thanks for the reply, and we're sorry for taking so long to reply. Anyway, I've attached a video (from a phone, sorry), that shows what happens with rpix86, as well as what is supposed to happen. If you can get anything from this, we'd really appreciate it.

Thanks again,
Orotomo
Posts: 3
Joined: Wed Jun 24, 2015 7:39 am
by Pate » Fri Jun 26, 2015 4:40 am
Sorry, I don't see the video.

Could you perhaps post the video to Youtube and send me a link (in a private message if you wish)?

Or perhaps the video is just waiting for moderation or something?

Pate
Now working on piro: http://piro.patrickaalto.com
See my rpix86 project at http://rpix86.patrickaalto.com
Posts: 115
Joined: Tue Feb 05, 2013 9:04 am
Location: Finland
by Orotomo » Fri Jun 26, 2015 5:55 am
Sorry, I think I might have actually forgotten to attach it. Either way, here's the link: https://youtu.be/l0JtmV1AAyM

Orotomo
Posts: 3
Joined: Wed Jun 24, 2015 7:39 am
by Pate » Fri Jun 26, 2015 12:05 pm
Ok, thanks for the video!

I hadn't realized you run rpix86 within the X environment. Can you check whether the mouse works when running from the console shell prompt? I believe those two run environments have different mouse emulation, so it is possible that the mouse works better when running rpix86 from the shell prompt.

Running from the shell prompt makes rpix86 run almost 2x faster, so it would be the recommended environment in any case. :)

Pate
Now working on piro: http://piro.patrickaalto.com
See my rpix86 project at http://rpix86.patrickaalto.com
Posts: 115
Joined: Tue Feb 05, 2013 9:04 am
Location: Finland
by Pate » Sun Jun 28, 2015 7:32 am
rpix86 version 0.19 released!

This version contains the following fixes and improvements:
- Implemented missing FPU opcodes (TradeWars 2002).
- Implemented JPE/JPO opcode hacks for TradeWars 2002.
- Fixed DMA current register off-by-1 problem (Tyrian 2000).

You can download the latest version directly from http://rpix86.patrickaalto.com/rdown.html (be sure to read my blog post about the changes in this version at http://rpix86.patrickaalto.com/rblog.html).

Thank you for your interest in rpix86, let me know of any bugs you encounter!

Pate
Now working on piro: http://piro.patrickaalto.com
See my rpix86 project at http://rpix86.patrickaalto.com
Posts: 115
Joined: Tue Feb 05, 2013 9:04 am
Location: Finland
by Vanfanel » Sat Jul 04, 2015 5:33 pm
Hi Pate! I've been testing 0.19 and I've found that Jazz Jackrabbit works!! Awesome!!
However, it has broken scroll. Screen moves VERY badly. Can it be fixed? The game's playability suffers from this issue.
Also:
-The music in Prince Of Persia intro is still broken
-Keen1 seems to suffer the same scrolling problems that Jazz has...
-Ishar intro music is broken, as is the music in Dungeon Master intro.
Posts: 403
Joined: Sat Aug 18, 2012 5:58 pm
by Mindy » Sun Jul 12, 2015 6:31 am
Hi there Patrick,

I'm a bit new to this but hope you can clarify . I understand Pix86 emulator replicates com ports 1 & 2 of a DOS based PC
This obviously is for games using serial mouse and joysticks. How do I physically connect up to these on the Pi ? The obvious options are to utilise the USB ports or general purpose I/o lines .

Regards Chris Lewis
Posts: 1
Joined: Sun Jul 12, 2015 6:24 am
by Xenosts » Sun Jan 24, 2016 7:59 pm
Hi, i need help. I've installed the 0.19 versione of Rpix86. I have tested Warcraft Orc and Humans and it run flawlessly. But when i click on the rpix86 windows i have two mouse cursor. One of the Raspbian and one of the game. When i play, if i move the cursor over the windows borders, the mouse go out. This is a video with my problem: https://youtu.be/y6HlP1kdSmk i hope you can help me to fix it.
P.S. sorry for the bad english, I'm Italian!
Posts: 10
Joined: Thu Jun 04, 2015 12:35 pm
by turk187 » Mon Aug 29, 2016 10:38 pm
I just bought my first 2 Pi's, one to make a dos box and one for an internet radio for my dad.

I got Rpix86/4dos to run and played a couple of old games, but am wondering if there is a way to set up the PI so it just boots straight to the C prompt? I mean Loads Rpix86 automatically?
Posts: 2
Joined: Mon Aug 29, 2016 4:33 pm
by IngAU » Sat Oct 08, 2016 4:49 pm
Hello,

has anyone experienced problems in running rpix86 after upgrading Raspbian to the latest version including the new Pixel desktop?
I was able to run rpix86 in a window with no problems.
After updating and upgrading distribution now in the window I can get after running rpix86 I can see like the window is divided in 4 quadrants and the DOS screen appears in both top quadrants (with very small fonts) and the 2 lower quadrants show the desktop wallpaper.
Apparently Rpix86 seems to work fine.
So I think the problem is somehow related to the update of the desktop.
But I cannot figure out how to fix it.

Anyone else with the same problem?

Alberto
Posts: 1
Joined: Sat Oct 08, 2016 3:43 pm
by kfasheldon » Sun Dec 25, 2016 10:30 pm
..Sane problem on setting up nice new Pi3 tried this in aticipation and get the quad screen issue, any fix please ..

Thanks
Posts: 1
Joined: Fri Dec 23, 2016 3:05 pm
by jesperhol » Fri Jan 06, 2017 2:30 pm
I don't know if someone asked this question before.

But i have problem with rpix86. I cant use my numpad on my keyboard?

Is there somehow to fix this or is it just not possible to use the numpad
Posts: 1
Joined: Fri Jan 06, 2017 2:27 pm
by Otto » Tue Jan 31, 2017 1:40 pm
Hi Pate!

Excellent work on this emulator!

Supercars International works fine on the Pi1, however on the Pi2 the audio drops out causing the game to hang at the next cut scene (black screen) ? This normally happens on this first track.

Cheers,
Lee
Posts: 32
Joined: Thu Sep 08, 2011 7:52 am
by raysaaron » Tue May 02, 2017 5:28 pm
nfs has a screen glitch i cant explian it go try yourself.
Posts: 30
Joined: Sun Feb 12, 2017 4:20 am
by IBM Portable PC » Fri May 26, 2017 9:42 pm
I know that rpix86 is not designed to work over SSH. However, it does work, only not in any way that is useful. Hopefully this will change in the future. Here's a screen shot from my Macbook:
Screen Shot 2017-05-27 at 7.38.33 AM.png
Screen Shot 2017-05-27 at 7.38.33 AM.png (59.27 KiB) Viewed 249 times
Posts: 39
Joined: Sun Apr 26, 2015 10:18 am
Location: Melbourne, Australia