Page 1 of 1

2 joypads on Retroarch

Posted: Tue Feb 05, 2013 9:23 am
by pehter
I have 2 usb joypads that are exactly the same.
I've configured them both with the retroarch-joyconfig, everything was fine.
What I've noticed was that when I'm playing a game (snes is the only one where I tested this) , the player 2 controller only works when I press a key in player 1 controller, either the controller or the keyboard.
If I hold any useless key on a game, on player 1 , player 2 works fine. If no keys are pressed, player 2 won't respond..
whats happening? what can I do?
(on lsusb command, the joypads are identified as Dragonrise Inc. Gamepad )

thanks

Re: 2 joypads on Retroarch

Posted: Fri Jul 05, 2013 3:36 pm
by Kivutar
I have exactly the same problem.

I tried it with 3 joysticks:
- a wired xbox360 gamepad
- a thrustmaster
- a free.fr gamepad

Each of them work well individually.

On certain games, player two keys works only if player 1 press a key.

The game I use for testing this bug is super bomberman 5 on pocketsnes retroarch.

On some games (or cores) I have no problems playing with two characters. One of these games is Bubble Bobble on mastersystem retroarch.

I also noticed a similar bug, with only one player, on Tactics Ogres SNES. None of the keys are working exept if I press the square key at the same time (on a psx gamepad layout).

Any help would be apreciated. Thanks.

Re: 2 joypads on Retroarch

Posted: Fri Jul 05, 2013 9:46 pm
by teeth_03
Apparently, its a bug with the default SNES emulator, the other ones, as I've read, seem to work better but I haven't tried to get one working with emulation station yet.

I'm kind of curious why RetroPie still uses PocketSNES if PiSNES or whatever its called works better.

Re: 2 joypads on Retroarch

Posted: Fri Jul 05, 2013 11:55 pm
by Aloshi
Swapping out the emulator should be as simple as uncommenting a line in ~/.emulationstation/es_systems.cfg and commenting the old one.

Re: 2 joypads on Retroarch

Posted: Sat Jul 06, 2013 12:00 am
by teeth_03
I tried that, but received an error about a missing library, something along the lines of GLES but I forget the exact error. My install also lacked a configuration file for PiSNES, using the script to install it and not the image.

Re: 2 joypads on Retroarch

Posted: Sat Jul 06, 2013 9:12 pm
by Kivutar
PiSNES is the most optimized SNES emulator at the moment. That's why Retropie provide it.

However, swaping emulator is not the subject. Retroarch architecture adds features that can't be achieve with emulationstation, wich I need here.

Are we the only one to suffer from this joypad bug on libretro, or is it everybody?

Re: 2 joypads on Retroarch

Posted: Sun May 24, 2015 11:21 am
by bootsector
Hi!

I'm using RetroPie SD-card Image for Raspberry Pi 1 Version 2.6 and I'm getting this exact issue!

Is there a way to overcome it without changing the current SNES emulator core?