bfready
Posts: 60
Joined: Sun Jun 16, 2019 2:13 pm

Sound / Music Distortion in Morrowwind?

Sun Feb 23, 2020 3:27 am

Hey, guys.

I've had Morrowwind running on my RPi4 w/ 4gb and Raspbian Buster for over a month now. Music and sound played fine before. Now, the music in Morrowwind is very distorted and plays slower than normal (almost like how you can play a video in slowmotion on Youtube). If I turn down the music and play with just sounds effects, it is playable, but some sounds have distortion too. Most notably, the whale like noise the Silt Striders make.

It's not a bad ground or bad speaker because Youtube plays fine. I can even go into the Data Files / music/ explorer/ and use VLC to play the Morrowind intro and it sounds fine. But, when I am in Morrowind, it sounds bad.

I tried looking for sounds configurations in openmw.cfg, but did not find anything other than an option to disable the sound.

Anyone have this problem before? Any suggestions? The logs mention initializing OpenAL, but I see no errors related to audio.


Here's the logs, in case anyone is curious. I may just try to reinstall and see if this fixes it.

Thanks for the help!

openmw logs:
Crash handler installed
Loading config file: /home/pi/.config/openmw/openmw.cfg
Loading config file: /home/pi/Morrowind/OPENMW_PILAB/openmw.cfg
OpenMW version 0.46.0
Revision: 2e05e0e829
Using default (English) font encoding.
OSG version: 3.6.5
SDL version: 2.0.10
Loading settings file: /home/pi/Morrowind/OPENMW_PILAB/settings-default.cfg
Loading settings file: /home/pi/.config/openmw/settings.cfg
Adding BSA archive /home/pi/Morrowind/OPENMW_PILAB/Morrowind/Data Files/Morrowind.bsa
Adding BSA archive /home/pi/Morrowind/OPENMW_PILAB/Morrowind/Data Files/Tribunal.bsa
Adding BSA archive /home/pi/Morrowind/OPENMW_PILAB/Morrowind/Data Files/Bloodmoon.bsa
Adding data directory resources/vfs
Adding data directory /home/pi/Morrowind/OPENMW_PILAB/Morrowind/Data Files
Ignoring duplicate data directory /home/pi/Morrowind/OPENMW_PILAB/Morrowind/Data Files
Initializing OpenAL...
Opened "Built-in Audio Analog Mono"
ALC Version: 1.1
ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_output_limiter ALC_SOFT_pause_device
Vendor: OpenAL Community
Renderer: OpenAL Soft
Version: 1.1 ALSOFT 1.19.1
Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFTX_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
Built-in Audio Analog Mono
Enumerated HRTF names:
default-44100 default-48000 Built-In 44100hz Built-In 48000hz
Failed to open video: Resource 'video/bethesda logo.bik' not found
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Playing music/special/morrowind title.mp3
Failed to open video: Resource 'video/mw_logo.bik' not found
Added new setting: [Video] window border = false
Changed setting: [Sound] master volume = 0.674067
Changed setting: [Sound] music volume = 1
Updating settings file: "/home/pi/.config/openmw/settings.cfg"
Quitting peacefully.

bfready
Posts: 60
Joined: Sun Jun 16, 2019 2:13 pm

Re: Sound / Music Distortion in Morrowwind?

Sun Feb 23, 2020 9:17 pm

I tried reinstalling Morrowind. Distortion is still heard after doing this. I am now noticing that it's not just Morrowind.

GZDoom has the same problem.
PPSSPP has the same problem.
Neverwinter nights has the same problem
Boswars is ok
Anything played on Chromium is ok
alsaplay [various wavs found in Morrowind] plays clear and fast

Not sure if it's related, but when my sound was playing ok in Morrowind it had this in the logs:
Initializing OpenAL...
Opened "ALSA Default"

Instead of what it shows now in the logs:
Initializing OpenAL...
Opened "Built-in Audio Analog Mono"

If anyone has any ideas, I sure do appreciate it.
Last edited by bfready on Tue Feb 25, 2020 4:01 am, edited 2 times in total.

bfready
Posts: 60
Joined: Sun Jun 16, 2019 2:13 pm

Re: Sound / Music Distortion in Morrowwind?

Sun Feb 23, 2020 9:39 pm

I found what was causing the slow distorted music and sound. Pulseaudio must have been conflicting with the "Alsa default."
I uninstalled Pulseaudio by typing sudo apt-get remove pulseaudio.

Now when I run morrowind, I see:
Opened "ALSA Default"
Rather than the Built-in audio analog mono message I saw before.

Music is clear and at normal speed now.

I am not sure if this will have an adverse effect on any other SW I am using, but so far sound works on all my applications.
I hope this helps someone out in the future.

Salawat
Posts: 19
Joined: Fri Dec 27, 2019 7:58 pm

Re: Sound / Music Distortion in Morrowwind?

Sat Apr 04, 2020 2:21 am

THANK YOU, BFREADY!

I'd been installing a slew of new games to test configurations for a little one, and apparently pulseaudio snuck its way in, and reducing the audio on Mineccraft to a horrid mess! It took more research than I'd like to admit, but your post made the lightbulb come on.

Again, thank you. I can enjoy the rest of my weekend now.

bfready
Posts: 60
Joined: Sun Jun 16, 2019 2:13 pm

Re: Sound / Music Distortion in Morrowwind?

Sun Apr 19, 2020 12:46 am

That is so awesome, Salawat! This is exactly why I try to document my problems as much as possible (hoping someone else benefits from it).

Return to “Gaming”