darthlink
Posts: 10
Joined: Fri Apr 14, 2017 4:02 am

disable emulationstation from boot

Tue Oct 29, 2019 5:38 pm

Hello everyone, here is the situation.

I have recently re-formated my pie to install the new version and everything was working perfectly.

Then i went to install retropie and that too was working ok.

My issue is that before i install retropie, when i was booting or rebooting, it always went back in to the xwindows as autologin. Now whe i boot or reboot, it goes straight into command line. Well actually it kinda goes into graphical interface for about 10 seconds then it fall back into command line.

I do know how to get back to graphic by typing: startx

That is of from when i am home but when i want to connect with VNC, i cannot reboot or else i am doomed.

I believe it is because somehow emulationstion is in the raspbian boot file and may boot in the background to be ready.

Even when i went to raspi-config to make sure it boot into desktop, it does not change anything. its still fall back to commande line after 10 seconds or so.

I would like to know if there is a way to disable emulationstation from the raspbian boot so that whenever i boot or reboot, it does not go or fall back into command lines please?

Thank you very much.

P.S. i have the raspberrypî 3 B+

SkywalkerSW5
Posts: 80
Joined: Fri Apr 19, 2019 3:54 pm

Re: disable emulationstation from boot

Wed Oct 30, 2019 12:52 am

I don't know for sure, but try going into the RetroPie settings ( the one that looks like raspi-config), go to Advanced Settings, and I think its EmulatonStation or boot or startup or something like that config. That should show some settings about Startup.
Random dude. Likes dogs. And Linux. Complete NOOB.

darthlink
Posts: 10
Joined: Fri Apr 14, 2017 4:02 am

Re: disable emulationstation from boot

Wed Oct 30, 2019 1:56 am

Thank you very much for your reply but after all, i manage to fix it.

I had to go through emulationstation configuration to disable the splashscreen and to change the boot to desktop.

Now its all ok.


Return to “Gaming”